aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mutt-devel
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-06-09 08:51:13 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-06-09 08:51:13 +0800
commitc887b3d5b07333c2de94f68e84eb11676defb79d (patch)
tree53108ecf0289d895950e12bab9cdcd748165f5d8 /mail/mutt-devel
parentdc99a20a9742b9696ddc73e49196572a06bdd502 (diff)
downloadfreebsd-ports-gnome-c887b3d5b07333c2de94f68e84eb11676defb79d.tar.gz
freebsd-ports-gnome-c887b3d5b07333c2de94f68e84eb11676defb79d.tar.zst
freebsd-ports-gnome-c887b3d5b07333c2de94f68e84eb11676defb79d.zip
bring mutt-devel up to devel
PR: 27640 Submitted by: Udo Schweigert <ust@cert.siemens.de> Reviewed by: will
Diffstat (limited to 'mail/mutt-devel')
-rw-r--r--mail/mutt-devel/Makefile63
-rw-r--r--mail/mutt-devel/distinfo4
-rw-r--r--mail/mutt-devel/files/patch-0158
-rw-r--r--mail/mutt-devel/files/patch-0512
-rw-r--r--mail/mutt-devel/pkg-plist189
-rw-r--r--mail/mutt-devel/pkg-plist.htmlfiles10
6 files changed, 116 insertions, 220 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 22620b429a8b..e9fe8888b54d 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -1,40 +1,28 @@
# ex:ts=8
-# Ports collection makefile for: mutt w/pgp hooks
-# Date created: Thur July 25, 1996
-# Whom: David O'Brien (obrien@NUXI.com)
+# Ports collection makefile for: mutt development
+# Date created: Fri June 8, 2001
+# Whom: David W. Chapman Jr. (dwcjr@inethouston.net)
#
# $FreeBSD$
#
-PORTNAME= mutt
-PORTVERSION= 1.2.5
-CATEGORIES+= mail
-MASTER_SITES= ftp://ftp.guug.de/pub/mutt/ \
- ftp://ftp.uib.no/pub/mutt/ \
- ftp://pgp.rasip.fer.hr/pub/mutt/international/ \
- ftp://ftp.gbnet.net/pub/mutt-international/ \
- ftp://riemann.iam.uni-bonn.de/pub/mutt/ \
- ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/mutt-international/ \
- ftp://ftp.gwdg.de/pub/unix/mail/mutt/international/ \
- ftp://ftp.iks-jena.de/pub/mitarb/lutz/crypt/software/pgp/mutt/
-DISTNAME= ${PORTNAME}-${PORTVERSION}i
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} charmaps-0.0.tar.gz
+PORTNAME= mutt-devel
+PORTVERSION= 1.3.19
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.demon.co.uk/pub/mirrors/mutt/devel \
+ ftp://ftp.parodius.com/pub/mutt/devel/
+DISTNAME= mutt-${PORTVERSION}i
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-PATCH_SITES= http://www.spinnaker.de/mutt/compressed/ \
- http://www.frmug.org/mutt/mutt/${PKGNAME:S/^mutt-//}/ \
- http://www.math.fu-berlin.de/~leitner/mutt/${PKGNAME:S/^mutt-//}/ \
- http://www.efrei.fr/~parmelan/mutt/${PKGNAME:S/^mutt-//}/ \
- ftp://www.frmug.org/pub/mutt/mutt/${PKGNAME:S/^mutt-//}/ \
- ftp://riemann.iam.uni-bonn.de/pub/mutt/
-PATCHFILES= patch-${PORTVERSION}.rr.compressed.1.gz
-PATCH_DIST_STRIP= -p1
+MAINTAINER= ust@cert.siemens.de
-MAINTAINER?= obrien@FreeBSD.org
+USE_GMAKE= yes
+USE_AUTOMAKE= yes
.if defined(PACKAGE_BUILDING)
WITH_SLANG= yes
-BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
+BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell \
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell \
urlview:${PORTSDIR}/textproc/urlview
.if ${MACHINE_ARCH} != "alpha"
@@ -43,7 +31,9 @@ WITH_DOCS= yes
.endif
.endif
-LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
+ giconv.2:${PORTSDIR}/converters/libiconv
+
.if defined(WITH_SLANG)
LIB_DEPENDS+= slang.1:${PORTSDIR}/devel/libslang
.elif defined(WITH_NCURSES_PORT)
@@ -57,14 +47,18 @@ USE_OPENSSL= yes
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
.endif
+
DIST_SUBDIR= mutt
GNU_CONFIGURE= yes
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-pop --enable-imap --enable-flock --disable-fcntl \
--with-sharedir=${PREFIX}/share/mutt \
- --with-docdir=${PREFIX}/share/doc/mutt --with-charmaps \
+ --with-docdir=${PREFIX}/share/doc/mutt \
+ --sysconfdir=${PREFIX}/etc \
+ --with-iconv=${PREFIX} \
--enable-compressed
+
.if defined(WITH_LOCALES_FIX)
CONFIGURE_ARGS+= --enable-locales-fix
.endif
@@ -77,15 +71,11 @@ CONFIGURE_ARGS+= --with-curses=${PREFIX}
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
.endif
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
-MAN1= mutt.1 mutt_dotlock.1
-MAN5= muttrc.5
-
-pre-patch:
- (cd ${WRKSRC}; ${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/charmaps-0.0.tar.gz)
+MAN1= flea.1 mutt.1 mutt_dotlock.1 muttbug.1
+MAN5= muttrc.5 mbox.5
pre-configure:
- cd ${WRKSRC}/charmaps/maps; ${LN} CP1251 WINDOWS-1251
- cd ${WRKSRC}/charmaps/maps; ${RM} -f *.orig
+ (cd ${WRKSRC}; aclocal -I m4)
.if !defined(NOPORTDOCS)
post-build:
@@ -109,8 +99,7 @@ post-install:
@cd ${WRKSRC}/doc ; ${INSTALL_MAN} manual.txt PGP-Notes.txt \
${PREFIX}/share/doc/mutt
.if defined(WITH_DOCS)
- ${INSTALL} ${COPY} -o ${MANOWN} -g ${MANGRP} -m 0755 \
- -d ${PREFIX}/share/doc/mutt/html
+ env MANMODE=0755 ${INSTALL_MAN} -d ${PREFIX}/share/doc/mutt/html
${INSTALL_MAN} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/mutt/html
${INSTALL_MAN} ${WRKSRC}/doc/*.latin1 ${PREFIX}/share/doc/mutt
.endif
diff --git a/mail/mutt-devel/distinfo b/mail/mutt-devel/distinfo
index b25490c3e49e..6c4f3c4c4e87 100644
--- a/mail/mutt-devel/distinfo
+++ b/mail/mutt-devel/distinfo
@@ -1,3 +1 @@
-MD5 (mutt/mutt-1.2.5i.tar.gz) = 0ba5367059abdd55daceb82dce6be42f
-MD5 (mutt/charmaps-0.0.tar.gz) = e79b9f57da1f6a4d0a63ff60a4ef7da8
-MD5 (mutt/patch-1.2.5.rr.compressed.1.gz) = 95bec646c20ef1d7f5680302dce2783b
+MD5 (mutt/mutt-1.3.19i.tar.gz) = 9fbc13fbf6f8de51e1fe4c9f7ba78149
diff --git a/mail/mutt-devel/files/patch-01 b/mail/mutt-devel/files/patch-01
index 836dbb773b2c..55cf75c6dba3 100644
--- a/mail/mutt-devel/files/patch-01
+++ b/mail/mutt-devel/files/patch-01
@@ -1,11 +1,47 @@
---- charmaps/maps/KOI8-R.bak Wed Jan 20 01:30:20 1999
-+++ charmaps/maps/KOI8-R Sat May 13 21:27:42 2000
-@@ -157,7 +157,7 @@
- <?S> /x92 <U2593> DARK SHADE
- <Iu> /x93 <U2320> TOP HALF INTEGRAL
- <fS> /x94 <U25A0> BLACK SQUARE
--<sb> /x95 <U2022> BULLET
-+<Sb> /x95 <U2219> BULLET OPERATOR
- <RT> /x96 <U221A> SQUARE ROOT
- <?2> /x97 <U2248> ALMOST EQUAL TO
- <=<> /x98 <U2264> LESS-THAN OR EQUAL TO
+--- configure.in.orig Thu May 3 10:31:09 2001
++++ configure.in Thu May 3 10:34:15 2001
+@@ -417,14 +417,14 @@
+ [ mutt_cv_func_iconv=no
+ mutt_cv_lib_iconv=no
+ AC_TRY_LINK([#include <stdlib.h>
+-#include <iconv.h>],
++#include <giconv.h>],
+ [iconv_t cd = iconv_open("",""); iconv(cd,NULL,NULL,NULL,NULL); iconv_close(cd);],
+ mutt_cv_func_iconv=yes)
+ if test "$mutt_cv_func_iconv" = no; then
+ mutt_save_LIBS="$LIBS"
+- LIBS="$LIBS -liconv"
++ LIBS="$LIBS -lgiconv"
+ AC_TRY_LINK([#include <stdlib.h>
+-#include <iconv.h>],
++#include <giconv.h>],
+ [iconv_t cd = iconv_open("",""); iconv(cd,NULL,NULL,NULL,NULL); iconv_close(cd);],
+ mutt_cv_lib_iconv=yes
+ mutt_cv_func_iconv=yes)
+@@ -435,7 +435,7 @@
+ AC_MSG_ERROR(Unable to find iconv library)
+ fi
+ if test "$mutt_cv_lib_iconv" = yes; then
+- LIBICONV="-liconv"
++ LIBICONV="-lgiconv"
+ fi
+ AC_DEFINE(HAVE_ICONV)
+
+@@ -448,7 +448,7 @@
+ mutt_save_LIBS="$LIBS"
+ LIBS="$LIBS $LIBICONV"
+ AC_TRY_RUN([
+-#include <iconv.h>
++#include <giconv.h>
+ int main()
+ {
+ iconv_t cd;
+@@ -479,7 +479,7 @@
+ mutt_save_LIBS="$LIBS"
+ LIBS="$LIBS $LIBICONV"
+ AC_TRY_RUN([
+-#include <iconv.h>
++#include <giconv.h>
+ #include <string.h>
+ int main()
+ {
diff --git a/mail/mutt-devel/files/patch-05 b/mail/mutt-devel/files/patch-05
index 364bc49a259d..13a52d9daa40 100644
--- a/mail/mutt-devel/files/patch-05
+++ b/mail/mutt-devel/files/patch-05
@@ -63,14 +63,14 @@
{
case -1: /* abort - don't resort */
return -1;
---- compose.c.orig Wed Aug 25 10:23:12 1999
-+++ compose.c Sun Sep 26 23:46:25 1999
+--- compose.c.orig Mon Feb 12 18:02:38 2001
++++ compose.c Fri Mar 30 17:04:09 2001
@@ -130,7 +130,7 @@
- struct pgp_vinfo *pgp = pgp_get_vinfo(PGP_SIGN);
+ char input_signas[SHORT_STRING];
- switch (mutt_multi_choice (_("(e)ncrypt, (s)ign, sign (a)s, (b)oth, select (m)ic algorithm, or (f)orget it? "),
-- _("esabmf")))
-+ N_("esabmf")))
+ switch (mutt_multi_choice (_("(e)ncrypt, (s)ign, sign (a)s, (b)oth, or (f)orget it? "),
+- _("esabf")))
++ N_("esabf")))
{
case 1: /* (e)ncrypt */
bits |= PGPENCRYPT;
diff --git a/mail/mutt-devel/pkg-plist b/mail/mutt-devel/pkg-plist
index a05217648e99..174a29e55685 100644
--- a/mail/mutt-devel/pkg-plist
+++ b/mail/mutt-devel/pkg-plist
@@ -1,4 +1,5 @@
@comment $FreeBSD$
+bin/flea
bin/mutt
bin/mutt_dotlock
bin/muttbug
@@ -6,185 +7,30 @@ bin/pgpewrap
bin/pgpring
etc/Muttrc
etc/mime.types
-share/mutt/charmaps/ANSI_X3.110-1983
-share/mutt/charmaps/ANSI_X3.4-1968
-share/mutt/charmaps/ASMO_449
-share/mutt/charmaps/BALTIC
-share/mutt/charmaps/BS_4730
-share/mutt/charmaps/BS_VIEWDATA
-share/mutt/charmaps/CP1250
-share/mutt/charmaps/CP1251
-share/mutt/charmaps/CP1252
-share/mutt/charmaps/CP1253
-share/mutt/charmaps/CP1254
-share/mutt/charmaps/CP1255
-share/mutt/charmaps/CP1256
-share/mutt/charmaps/CP1257
-share/mutt/charmaps/CSA_Z243.4-1985-1
-share/mutt/charmaps/CSA_Z243.4-1985-2
-share/mutt/charmaps/CSA_Z243.4-1985-GR
-share/mutt/charmaps/CSN_369103
-share/mutt/charmaps/CWI
-share/mutt/charmaps/DEC-MCS
-share/mutt/charmaps/DIN_66003
-share/mutt/charmaps/DS_2089
-share/mutt/charmaps/EBCDIC-AT-DE
-share/mutt/charmaps/EBCDIC-AT-DE-A
-share/mutt/charmaps/EBCDIC-CA-FR
-share/mutt/charmaps/EBCDIC-DK-NO
-share/mutt/charmaps/EBCDIC-DK-NO-A
-share/mutt/charmaps/EBCDIC-ES
-share/mutt/charmaps/EBCDIC-ES-A
-share/mutt/charmaps/EBCDIC-ES-S
-share/mutt/charmaps/EBCDIC-FI-SE
-share/mutt/charmaps/EBCDIC-FI-SE-A
-share/mutt/charmaps/EBCDIC-FR
-share/mutt/charmaps/EBCDIC-IS-FRISS
-share/mutt/charmaps/EBCDIC-IT
-share/mutt/charmaps/EBCDIC-PT
-share/mutt/charmaps/EBCDIC-UK
-share/mutt/charmaps/EBCDIC-US
-share/mutt/charmaps/ECMA-CYRILLIC
-share/mutt/charmaps/ES
-share/mutt/charmaps/ES2
-share/mutt/charmaps/GB_1988-80
-share/mutt/charmaps/GOST_19768-74
-share/mutt/charmaps/GREEK-CCITT
-share/mutt/charmaps/GREEK7
-share/mutt/charmaps/GREEK7-OLD
-share/mutt/charmaps/HP-ROMAN8
-share/mutt/charmaps/IBM037
-share/mutt/charmaps/IBM038
-share/mutt/charmaps/IBM1004
-share/mutt/charmaps/IBM1026
-share/mutt/charmaps/IBM1047
-share/mutt/charmaps/IBM256
-share/mutt/charmaps/IBM273
-share/mutt/charmaps/IBM274
-share/mutt/charmaps/IBM275
-share/mutt/charmaps/IBM277
-share/mutt/charmaps/IBM278
-share/mutt/charmaps/IBM280
-share/mutt/charmaps/IBM281
-share/mutt/charmaps/IBM284
-share/mutt/charmaps/IBM285
-share/mutt/charmaps/IBM290
-share/mutt/charmaps/IBM297
-share/mutt/charmaps/IBM420
-share/mutt/charmaps/IBM423
-share/mutt/charmaps/IBM424
-share/mutt/charmaps/IBM437
-share/mutt/charmaps/IBM500
-share/mutt/charmaps/IBM850
-share/mutt/charmaps/IBM851
-share/mutt/charmaps/IBM852
-share/mutt/charmaps/IBM855
-share/mutt/charmaps/IBM857
-share/mutt/charmaps/IBM860
-share/mutt/charmaps/IBM861
-share/mutt/charmaps/IBM862
-share/mutt/charmaps/IBM863
-share/mutt/charmaps/IBM864
-share/mutt/charmaps/IBM865
-share/mutt/charmaps/IBM868
-share/mutt/charmaps/IBM869
-share/mutt/charmaps/IBM870
-share/mutt/charmaps/IBM871
-share/mutt/charmaps/IBM875
-share/mutt/charmaps/IBM880
-share/mutt/charmaps/IBM891
-share/mutt/charmaps/IBM903
-share/mutt/charmaps/IBM904
-share/mutt/charmaps/IBM905
-share/mutt/charmaps/IBM918
-share/mutt/charmaps/IEC_P27-1
-share/mutt/charmaps/INIS
-share/mutt/charmaps/INIS-8
-share/mutt/charmaps/INIS-CYRILLIC
-share/mutt/charmaps/INVARIANT
-share/mutt/charmaps/ISO-8859-1
-share/mutt/charmaps/ISO-8859-10
-share/mutt/charmaps/ISO-8859-2
-share/mutt/charmaps/ISO-8859-3
-share/mutt/charmaps/ISO-8859-4
-share/mutt/charmaps/ISO-8859-5
-share/mutt/charmaps/ISO-8859-6
-share/mutt/charmaps/ISO-8859-7
-share/mutt/charmaps/ISO-8859-8
-share/mutt/charmaps/ISO-8859-9
-share/mutt/charmaps/ISO-IR-90
-share/mutt/charmaps/ISO_10367-BOX
-share/mutt/charmaps/ISO_10646
-share/mutt/charmaps/ISO_2033-1983
-share/mutt/charmaps/ISO_5427
-share/mutt/charmaps/ISO_5427-EXT
-share/mutt/charmaps/ISO_5428
-share/mutt/charmaps/ISO_646.BASIC
-share/mutt/charmaps/ISO_646.IRV
-share/mutt/charmaps/ISO_6937
-share/mutt/charmaps/ISO_6937-2-25
-share/mutt/charmaps/ISO_6937-2-ADD
-share/mutt/charmaps/ISO_8859-1,GL
-share/mutt/charmaps/ISO_8859-SUPP
-share/mutt/charmaps/IT
-share/mutt/charmaps/JIS_C6220-1969-JP
-share/mutt/charmaps/JIS_C6220-1969-RO
-share/mutt/charmaps/JIS_C6229-1984-A
-share/mutt/charmaps/JIS_C6229-1984-B
-share/mutt/charmaps/JIS_C6229-1984-B-ADD
-share/mutt/charmaps/JIS_C6229-1984-HAND
-share/mutt/charmaps/JIS_C6229-1984-HAND-ADD
-share/mutt/charmaps/JIS_C6229-1984-KANA
-share/mutt/charmaps/JIS_X0201
-share/mutt/charmaps/JUS_I.B1.002
-share/mutt/charmaps/JUS_I.B1.003-MAC
-share/mutt/charmaps/JUS_I.B1.003-SERB
-share/mutt/charmaps/KOI-8
-share/mutt/charmaps/KOI8-R
-share/mutt/charmaps/KSC5636
-share/mutt/charmaps/LATIN-GREEK
-share/mutt/charmaps/LATIN-GREEK-1
-share/mutt/charmaps/MAC-IS
-share/mutt/charmaps/MACINTOSH
-share/mutt/charmaps/MSZ_7795.3
-share/mutt/charmaps/NATS-DANO
-share/mutt/charmaps/NATS-DANO-ADD
-share/mutt/charmaps/NATS-SEFI
-share/mutt/charmaps/NATS-SEFI-ADD
-share/mutt/charmaps/NC_NC00-10
-share/mutt/charmaps/NEXTSTEP
-share/mutt/charmaps/NF_Z_62-010
-share/mutt/charmaps/NF_Z_62-010-1973
-share/mutt/charmaps/NS_4551-1
-share/mutt/charmaps/NS_4551-2
-share/mutt/charmaps/PT
-share/mutt/charmaps/PT2
-share/mutt/charmaps/SAMI
-share/mutt/charmaps/SEN_850200_B
-share/mutt/charmaps/SEN_850200_C
-share/mutt/charmaps/T.101-G2
-share/mutt/charmaps/T.61-7BIT
-share/mutt/charmaps/T.61-8BIT
-share/mutt/charmaps/VIDEOTEX-SUPPL
-share/mutt/charmaps/WINDOWS-1251
share/locale/cs/LC_MESSAGES/mutt.mo
share/locale/da/LC_MESSAGES/mutt.mo
share/locale/de/LC_MESSAGES/mutt.mo
share/locale/el/LC_MESSAGES/mutt.mo
share/locale/eo/LC_MESSAGES/mutt.mo
+share/locale/et/LC_MESSAGES/mutt.mo
share/locale/es/LC_MESSAGES/mutt.mo
share/locale/fr/LC_MESSAGES/mutt.mo
share/locale/gl/LC_MESSAGES/mutt.mo
+share/locale/hu/LC_MESSAGES/mutt.mo
share/locale/id/LC_MESSAGES/mutt.mo
share/locale/it/LC_MESSAGES/mutt.mo
+share/locale/ja/LC_MESSAGES/mutt.mo
share/locale/ko/LC_MESSAGES/mutt.mo
+share/locale/lt/LC_MESSAGES/mutt.mo
share/locale/nl/LC_MESSAGES/mutt.mo
share/locale/pl/LC_MESSAGES/mutt.mo
share/locale/pt_BR/LC_MESSAGES/mutt.mo
share/locale/ru/LC_MESSAGES/mutt.mo
share/locale/sk/LC_MESSAGES/mutt.mo
share/locale/sv/LC_MESSAGES/mutt.mo
+share/locale/tr/LC_MESSAGES/mutt.mo
share/locale/uk/LC_MESSAGES/mutt.mo
+share/locale/zh_CN.GB2312/LC_MESSAGES/mutt.mo
share/locale/zh_TW.Big5/LC_MESSAGES/mutt.mo
share/doc/mutt/manual.txt
share/doc/mutt/COPYRIGHT
@@ -210,7 +56,24 @@ share/doc/mutt/samples/pgp6.rc
share/doc/mutt/samples/sample.mailcap
share/doc/mutt/samples/sample.muttrc
share/doc/mutt/samples/sample.muttrc-tlr
-@dirrm share/mutt/charmaps
-@dirrm share/mutt
+share/doc/mutt/samples/iconv/iconv.aix-3.2.5.rc
+share/doc/mutt/samples/iconv/iconv.aix-4.1.5.rc
+share/doc/mutt/samples/iconv/iconv.aix-4.2.0.rc
+share/doc/mutt/samples/iconv/iconv.aix-4.3.2.rc
+share/doc/mutt/samples/iconv/iconv.freebsd-3.3.rc
+share/doc/mutt/samples/iconv/iconv.glibc-2.1.3.rc
+share/doc/mutt/samples/iconv/iconv.glibc-2.1.90.rc
+share/doc/mutt/samples/iconv/iconv.hpux-10.01.rc
+share/doc/mutt/samples/iconv/iconv.hpux-10.20.rc
+share/doc/mutt/samples/iconv/iconv.hpux-11.00.rc
+share/doc/mutt/samples/iconv/iconv.irix-6.5.rc
+share/doc/mutt/samples/iconv/iconv.osf1-4.0a.rc
+share/doc/mutt/samples/iconv/iconv.osf1-4.0d.rc
+share/doc/mutt/samples/iconv/iconv.solaris-2.4.rc
+share/doc/mutt/samples/iconv/iconv.solaris-2.5.1.rc
+share/doc/mutt/samples/iconv/iconv.solaris-2.6-cjk.rc
+share/doc/mutt/samples/iconv/iconv.solaris-2.6.rc
+share/doc/mutt/samples/iconv/iconv.solaris-2.7.rc
+@dirrm share/doc/mutt/samples/iconv
@dirrm share/doc/mutt/samples
@dirrm share/doc/mutt
diff --git a/mail/mutt-devel/pkg-plist.htmlfiles b/mail/mutt-devel/pkg-plist.htmlfiles
index 20e58f0d08a0..75660ec86688 100644
--- a/mail/mutt-devel/pkg-plist.htmlfiles
+++ b/mail/mutt-devel/pkg-plist.htmlfiles
@@ -242,6 +242,16 @@ share/doc/mutt/html/manual307.html
share/doc/mutt/html/manual308.html
share/doc/mutt/html/manual309.html
share/doc/mutt/html/manual310.html
+share/doc/mutt/html/manual311.html
+share/doc/mutt/html/manual312.html
+share/doc/mutt/html/manual313.html
+share/doc/mutt/html/manual314.html
+share/doc/mutt/html/manual315.html
+share/doc/mutt/html/manual316.html
+share/doc/mutt/html/manual317.html
+share/doc/mutt/html/manual318.html
+share/doc/mutt/html/manual319.html
+share/doc/mutt/html/manual320.html
share/doc/mutt/html/manual31.html
share/doc/mutt/html/manual32.html
share/doc/mutt/html/manual33.html