aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mutt14
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2001-12-06 04:30:19 +0800
committerobrien <obrien@FreeBSD.org>2001-12-06 04:30:19 +0800
commit9f9e91d7b7f1db01b7f3c789a03a23bcbc56962d (patch)
tree099a09ef7c3a0d31696f704ecd07ea851a08d4cd /mail/mutt14
parent7fdc70bfb1bc2f721ec6bbc39de02608d75400f6 (diff)
downloadfreebsd-ports-gnome-9f9e91d7b7f1db01b7f3c789a03a23bcbc56962d.tar.gz
freebsd-ports-gnome-9f9e91d7b7f1db01b7f3c789a03a23bcbc56962d.tar.zst
freebsd-ports-gnome-9f9e91d7b7f1db01b7f3c789a03a23bcbc56962d.zip
Update this to build with proper dependancies again.
When I added the folder compression patch, I didn't realize we now needed automake & autoconf. Bringing those two in, now makes gmake required. :-( Also we can't patch `configure' as before, now we must patch `configure.in' and `aclocal.m4'.
Diffstat (limited to 'mail/mutt14')
-rw-r--r--mail/mutt14/Makefile2
-rw-r--r--mail/mutt14/files/patch-0421
-rw-r--r--mail/mutt14/files/patch-aclocal.m411
-rw-r--r--mail/mutt14/files/patch-configure.in9
4 files changed, 22 insertions, 21 deletions
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index 22620b429a8b..ee1547be9c66 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -59,6 +59,8 @@ BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
DIST_SUBDIR= mutt
GNU_CONFIGURE= yes
+USE_AUTOMAKE= yes # configure.in is patched by <PATCHFILES>
+USE_GMAKE= yes # grrr, why is this now required if USE_AUTOMAKE ?!?!?
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-pop --enable-imap --enable-flock --disable-fcntl \
diff --git a/mail/mutt14/files/patch-04 b/mail/mutt14/files/patch-04
deleted file mode 100644
index f0763a9c7060..000000000000
--- a/mail/mutt14/files/patch-04
+++ /dev/null
@@ -1,21 +0,0 @@
---- configure.orig Tue Jan 18 14:19:14 2000
-+++ configure Tue Feb 29 01:47:49 2000
-@@ -1925,6 +1925,9 @@
- /* We use char because int might match the return type of a gcc2
- builtin and then its argument prototype would still apply. */
- char $ac_func();
-+#ifdef __FreeBSD__
-+#define bkgdset initscr
-+#endif
-
- int main() {
-
-@@ -5710,7 +5713,7 @@
- s%@FFLAGS@%$FFLAGS%g
- s%@DEFS@%$DEFS%g
- s%@LDFLAGS@%$LDFLAGS%g
--s%@LIBS@%$LIBS%g
-+s%@LIBS@%$LIBS -lxpg4%g
- s%@exec_prefix@%$exec_prefix%g
- s%@prefix@%$prefix%g
- s%@program_transform_name@%$program_transform_name%g
diff --git a/mail/mutt14/files/patch-aclocal.m4 b/mail/mutt14/files/patch-aclocal.m4
new file mode 100644
index 000000000000..6635a1a90fa6
--- /dev/null
+++ b/mail/mutt14/files/patch-aclocal.m4
@@ -0,0 +1,11 @@
+--- aclocal.m4.orig Fri Jul 28 11:50:25 2000
++++ aclocal.m4 Wed Dec 5 12:10:16 2001
+@@ -62,4 +62,4 @@
+-AM_MISSING_PROG(ACLOCAL, aclocal, $missing_dir)
+-AM_MISSING_PROG(AUTOCONF, autoconf, $missing_dir)
+-AM_MISSING_PROG(AUTOMAKE, automake, $missing_dir)
+-AM_MISSING_PROG(AUTOHEADER, autoheader, $missing_dir)
++AM_MISSING_PROG(ACLOCAL, aclocal14, $missing_dir)
++AM_MISSING_PROG(AUTOCONF, autoconf213, $missing_dir)
++AM_MISSING_PROG(AUTOMAKE, automake14, $missing_dir)
++AM_MISSING_PROG(AUTOHEADER, autoheader213, $missing_dir)
diff --git a/mail/mutt14/files/patch-configure.in b/mail/mutt14/files/patch-configure.in
new file mode 100644
index 000000000000..c26517da78ac
--- /dev/null
+++ b/mail/mutt14/files/patch-configure.in
@@ -0,0 +1,9 @@
+--- configure.in.orig Fri Jul 28 11:50:24 2000
++++ configure.in Wed Dec 5 12:18:13 2001
+@@ -610,4 +615,6 @@
+ AC_SUBST(MUTTLOCALEDIR)
+ AC_DEFINE_UNQUOTED(MUTTLOCALEDIR, "$MUTTLOCALEDIR")
++
++MUTTLIBS="$MUTTLIBS -lxpg4"
+
+ AC_OUTPUT(Makefile intl/Makefile m4/Makefile dnl