aboutsummaryrefslogtreecommitdiffstats
path: root/mail/nocc/Makefile
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-01-29 17:43:09 +0800
committerale <ale@FreeBSD.org>2004-01-29 17:43:09 +0800
commitbeb1a47bd04eabb7a44a3bb9b39be91b4ce37510 (patch)
tree4a47c26740ae1504708defffa531c4b8e40ea8f2 /mail/nocc/Makefile
parentad2aea7636123323a9921c441483f2c53e836654 (diff)
downloadfreebsd-ports-gnome-beb1a47bd04eabb7a44a3bb9b39be91b4ce37510.tar.gz
freebsd-ports-gnome-beb1a47bd04eabb7a44a3bb9b39be91b4ce37510.tar.zst
freebsd-ports-gnome-beb1a47bd04eabb7a44a3bb9b39be91b4ce37510.zip
- Use bsd.php.mk
- Make portlint happy Approved by: nork (mentor/implicitly)
Diffstat (limited to 'mail/nocc/Makefile')
-rw-r--r--mail/nocc/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/mail/nocc/Makefile b/mail/nocc/Makefile
index fe66db63c585..7bc939bffc99 100644
--- a/mail/nocc/Makefile
+++ b/mail/nocc/Makefile
@@ -14,11 +14,14 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ale@FreeBSD.org
COMMENT= A web-based e-mail system which access POP3 and IMAP mail servers
-RUN_DEPENDS= ${LOCALBASE}/bin/php-config:${PORTSDIR}/www/mod_php4
+WANT_PHP_WEB= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
NO_BUILD= yes
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/php4/bsd.php.mk"
+
pre-everything::
@${ECHO} ""
@${ECHO} "You have to configure PHP with IMAP support in order"
@@ -30,7 +33,7 @@ pre-everything::
pre-patch:
@${SED} 's|%%PREFIX%%|${PREFIX}|g' \
- ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+ ${PKGDIR}/pkg-message > ${PKGMESSAGE}
do-install:
${MKDIR} ${PREFIX}/www/nocc
@@ -51,4 +54,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>