aboutsummaryrefslogtreecommitdiffstats
path: root/mail/notmuch
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2018-11-08 15:35:30 +0800
committerkrion <krion@FreeBSD.org>2018-11-08 15:35:30 +0800
commitddcf7a1c15d77c500bc276321b343c7003b07a71 (patch)
treec628189d20b8198d6903755d3e31300718864894 /mail/notmuch
parent546198ea1d91091330551a6f6e97fab5b8488381 (diff)
downloadfreebsd-ports-gnome-ddcf7a1c15d77c500bc276321b343c7003b07a71.tar.gz
freebsd-ports-gnome-ddcf7a1c15d77c500bc276321b343c7003b07a71.tar.zst
freebsd-ports-gnome-ddcf7a1c15d77c500bc276321b343c7003b07a71.zip
Update to 0.28
PR: 232310 Submitted by: maintainer
Diffstat (limited to 'mail/notmuch')
-rw-r--r--mail/notmuch/Makefile12
-rw-r--r--mail/notmuch/distinfo6
-rw-r--r--mail/notmuch/files/patch-configure18
-rw-r--r--mail/notmuch/files/patch-contrib_notmuch-mutt_Makefile15
-rw-r--r--mail/notmuch/pkg-plist1
5 files changed, 45 insertions, 7 deletions
diff --git a/mail/notmuch/Makefile b/mail/notmuch/Makefile
index 5b3aec5d74b9..b7ef35ed5b7f 100644
--- a/mail/notmuch/Makefile
+++ b/mail/notmuch/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= notmuch
-PORTVERSION= 0.27
+PORTVERSION= 0.28
CATEGORIES?= mail
MASTER_SITES= https://notmuchmail.org/releases/
@@ -27,7 +27,7 @@ TEST_DEPENDS= bash:shells/bash \
gwc:sysutils/coreutils \
${LOCALBASE}/bin/gdb:devel/gdb
-USES= compiler:c++11-lang gmake pkgconfig python:build,test
+USES= compiler:c++11-lang gmake gnome pkgconfig python:build,test
USE_GNOME= glib20
USE_LDCONFIG= yes
@@ -60,12 +60,16 @@ DOXYGEN_CONFIGURE_WITH= api-docs
MANPAGES_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
MANPAGES_CONFIGURE_WITH= docs
-# install completions even in absence of shells/bash-completions
+# Install bash completions without incurring a dependcy on
+# shells/bash-completion. Also avoid automatic installation of
+# info pages on FreeBSD 10.
post-configure:
${REINPLACE_CMD} \
+ -e '/^BASH_ABSOLUTE[[:blank:]]*=/s|=.*|=${LOCALBASE}/bin/bash|' \
+ -e '/^HAVE_BASH[[:blank:]]*=/s/=.*/=1/' \
-e '/^HAVE_INSTALL_INFO[[:blank:]]*=/s/=.*/=0/' \
-e '/^HAVE_MAKEINFO[[:blank:]]*=/s/=.*/=0/' \
- -e '/^WITH_BASH[[:blank:]]*=/s/=.*/= 1/' \
+ -e '/^WITH_BASH[[:blank:]]*=/s/=.*/=1/' \
${WRKSRC}/Makefile.config
post-install:
diff --git a/mail/notmuch/distinfo b/mail/notmuch/distinfo
index d54ff57f5744..033a9e5a8485 100644
--- a/mail/notmuch/distinfo
+++ b/mail/notmuch/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1529138705
-SHA256 (notmuch-0.27.tar.gz) = 40d3192f8f130f227b511fc80be86310c7f60ccb6d043b563f201fa505de0876
-SIZE (notmuch-0.27.tar.gz) = 912583
+TIMESTAMP = 1539421796
+SHA256 (notmuch-0.28.tar.gz) = acca75cec91651ccd2a7e31f7004e2ae14eff4ae38e375b8a88414c464cd0a37
+SIZE (notmuch-0.28.tar.gz) = 921069
diff --git a/mail/notmuch/files/patch-configure b/mail/notmuch/files/patch-configure
new file mode 100644
index 000000000000..65e506936eee
--- /dev/null
+++ b/mail/notmuch/files/patch-configure
@@ -0,0 +1,18 @@
+--- configure.orig 2018-10-16 07:56:32 UTC
++++ configure
+@@ -566,6 +566,7 @@ if command -v ${BASH} > /dev/null; then
+ printf "Yes (%s).\n" "$bash_absolute"
+ else
+ have_bash=0
++ bash_absolute=
+ printf "No. (%s not found)\n" "${BASH}"
+ fi
+
+@@ -576,6 +577,7 @@ if command -v ${PERL} > /dev/null; then
+ printf "Yes (%s).\n" "$perl_absolute"
+ else
+ have_perl=0
++ perl_absolute=
+ printf "No. (%s not found)\n" "${PERL}"
+ fi
+
diff --git a/mail/notmuch/files/patch-contrib_notmuch-mutt_Makefile b/mail/notmuch/files/patch-contrib_notmuch-mutt_Makefile
new file mode 100644
index 000000000000..013ddd5cdb48
--- /dev/null
+++ b/mail/notmuch/files/patch-contrib_notmuch-mutt_Makefile
@@ -0,0 +1,15 @@
+--- contrib/notmuch-mutt/Makefile.orig 2018-10-13 17:57:20 UTC
++++ contrib/notmuch-mutt/Makefile
+@@ -18,8 +18,10 @@ install: all
+ mkdir -p $(DESTDIR)$(prefix)/bin
+ sed "1s|^#!.*|#! $(PERL_ABSOLUTE)|" < $(NAME) > $(DESTDIR)$(prefix)/bin/$(NAME)
+ chmod 755 $(DESTDIR)$(prefix)/bin/$(NAME)
+- install -D -m 644 $(NAME).1 $(DESTDIR)$(mandir)/man1/$(NAME).1
+- install -D -m 644 $(NAME).rc $(DESTDIR)$(sysconfdir)/Muttrc.d/$(NAME).rc
++ mkdir -p $(DESTDIR)$(mandir)/man1
++ install -m 644 $(NAME).1 $(DESTDIR)$(mandir)/man1/$(NAME).1
++ mkdir -p $(DESTDIR)$(sysconfdir)/Muttrc.d
++ install -m 644 $(NAME).rc $(DESTDIR)$(sysconfdir)/Muttrc.d/$(NAME).rc
+
+ clean:
+ rm -f notmuch-mutt.1 README.html
diff --git a/mail/notmuch/pkg-plist b/mail/notmuch/pkg-plist
index 78b13c376b86..0d03dc51ff7b 100644
--- a/mail/notmuch/pkg-plist
+++ b/mail/notmuch/pkg-plist
@@ -23,4 +23,5 @@ lib/libnotmuch.so
lib/libnotmuch.so.5
lib/libnotmuch.so.5.2.0
share/bash-completion/completions/notmuch
+share/zsh/functions/Completion/Unix/_email-notmuch
share/zsh/functions/Completion/Unix/_notmuch