aboutsummaryrefslogtreecommitdiffstats
path: root/mail/osbf-lua/Makefile
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2009-02-02 02:10:25 +0800
committerlippe <lippe@FreeBSD.org>2009-02-02 02:10:25 +0800
commitc63c33ad7e744bf2b734d545bac14aa1fc0490c0 (patch)
treead12ba399b80e7b3668813dee522d4de74e10e8f /mail/osbf-lua/Makefile
parenta2c68d794709e8f569de7ed377feb60b1a04b233 (diff)
downloadfreebsd-ports-gnome-c63c33ad7e744bf2b734d545bac14aa1fc0490c0.tar.gz
freebsd-ports-gnome-c63c33ad7e744bf2b734d545bac14aa1fc0490c0.tar.zst
freebsd-ports-gnome-c63c33ad7e744bf2b734d545bac14aa1fc0490c0.zip
OSBF-Lua (Orthogonal Sparse Bigrams with confidence Factor) is a Lua C module for text classification. It is a port of the OSBF classifier implemented in the CRM114 project. This implementation attempts to put focus on the classification task itself by using Lua as the scripting language, a powerful yet light-weight and fast language, which makes it easier to build and test more elaborated filters and training methods.
WWW: http://osbf-lua.luaforge.net/ Submitted by: RicardoSSP <ricardo.katz@gmail.com> (via mail) Reviewed by: myself
Diffstat (limited to 'mail/osbf-lua/Makefile')
-rw-r--r--mail/osbf-lua/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/mail/osbf-lua/Makefile b/mail/osbf-lua/Makefile
new file mode 100644
index 000000000000..0524dccbdd87
--- /dev/null
+++ b/mail/osbf-lua/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: osbf-lua
+# Date created: 2009-01-14
+# Whom: RicardoSSP <ricardo.katz@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= osbf-lua
+PORTVERSION= 2.0.4
+CATEGORIES= mail
+MASTER_SITES= http://luaforge.net/frs/download.php/2094/
+
+MAINTAINER= ricardo.katz@gmail.com
+COMMENT= This tool is used as classifier for mails, primarly as Anti Spam
+
+USE_GMAKE= YES
+USE_LDCONFIG= YES
+USE_LUA= 5.1+
+ALL_TARGET=
+INSTALL_TARGET= install
+
+OPTIONS= SPAMFILTER_PLUGIN "OSBF Spamfilter Plugin" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SPAMFILTER_PLUGIN)
+INSTALL_TARGET+= install_spamfilter
+PLIST_SUB+= SPAMFILTER=""
+.else
+PLIST_SUB+= SPAMFILTER="@comment "
+.endif
+
+.include <bsd.port.post.mk>