aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-Mail-POP3Client
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>2001-09-20 16:43:24 +0800
committermharo <mharo@FreeBSD.org>2001-09-20 16:43:24 +0800
commitf8c4230c63323fd75bc29543551108f7c2643d22 (patch)
treefef69e2614f1bf85292c95f405321ee14b15ba04 /mail/p5-Mail-POP3Client
parentd41338766723637160385c96e1de9c39c1c6b2c5 (diff)
downloadfreebsd-ports-gnome-f8c4230c63323fd75bc29543551108f7c2643d22.tar.gz
freebsd-ports-gnome-f8c4230c63323fd75bc29543551108f7c2643d22.tar.zst
freebsd-ports-gnome-f8c4230c63323fd75bc29543551108f7c2643d22.zip
Update to 2.9
Approved by: maintainer
Diffstat (limited to 'mail/p5-Mail-POP3Client')
-rw-r--r--mail/p5-Mail-POP3Client/Makefile2
-rw-r--r--mail/p5-Mail-POP3Client/distinfo2
-rw-r--r--mail/p5-Mail-POP3Client/pkg-descr12
-rw-r--r--mail/p5-Mail-POP3Client/pkg-plist7
4 files changed, 10 insertions, 13 deletions
diff --git a/mail/p5-Mail-POP3Client/Makefile b/mail/p5-Mail-POP3Client/Makefile
index dbd208efb039..9f7808ba5e9e 100644
--- a/mail/p5-Mail-POP3Client/Makefile
+++ b/mail/p5-Mail-POP3Client/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Mail-POP3Client
-PORTVERSION= 2.7
+PORTVERSION= 2.9
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Mail
diff --git a/mail/p5-Mail-POP3Client/distinfo b/mail/p5-Mail-POP3Client/distinfo
index 8ac32c297bb0..6c4a0ed58056 100644
--- a/mail/p5-Mail-POP3Client/distinfo
+++ b/mail/p5-Mail-POP3Client/distinfo
@@ -1 +1 @@
-MD5 (POP3Client-2.7.tar.gz) = 4d31818aa5bfa8ccea711b23b25640ef
+MD5 (POP3Client-2.9.tar.gz) = baf932b842bc5e1c8283548fcdb72ab7
diff --git a/mail/p5-Mail-POP3Client/pkg-descr b/mail/p5-Mail-POP3Client/pkg-descr
index 394af7705446..ae7a5ad53141 100644
--- a/mail/p5-Mail-POP3Client/pkg-descr
+++ b/mail/p5-Mail-POP3Client/pkg-descr
@@ -1,16 +1,16 @@
-DESCRIPTION
+DESCRIPTION
This module implements an Object-Oriented interface to a POP3 server. It is
based on RFC1081.
-USAGE
+USAGE
Here is a simple example to list out the headers in your remote mailbox:
-#!/usr/local/bin/perl
+#!/usr/bin/perl
-use Mail::POP3Client;
+use Mail::POP3Client;
$pop = new Mail::POP3Client("me", "mypassword", "pop3.do.main");
-for ($i = 1; $i <= $pop->Count; $i++) {
+for ($i = 1; $i <= $pop->Count; $i++) {
print $pop->Head($i), "\n";
-}
+}
diff --git a/mail/p5-Mail-POP3Client/pkg-plist b/mail/p5-Mail-POP3Client/pkg-plist
index 12728e15c13b..dfc2d7f7200d 100644
--- a/mail/p5-Mail-POP3Client/pkg-plist
+++ b/mail/p5-Mail-POP3Client/pkg-plist
@@ -1,8 +1,5 @@
lib/perl5/site_perl/%%PERL_VER%%/Mail/POP3Client.pm
-lib/perl5/site_perl/%%PERL_VER%%/auto/Mail/POP3Client/autosplit.ix
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/POP3Client/.packlist
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Mail/POP3Client
+@unexec rmdir -f %D/lib/perl5/site_perl/%%PERL_VER%%/Mail 2>/dev/null || true
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/POP3Client
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Mail
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/Mail
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail 2>/dev/null || true