aboutsummaryrefslogtreecommitdiffstats
path: root/mail/p5-Mail-SpamAssassin/Makefile
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
committerpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
commitbdc7b8de9b4a00d6f78b8a20e6e92ad630e44558 (patch)
tree0af98c25fc0d67ccc871639ecd10e8476cfd8de7 /mail/p5-Mail-SpamAssassin/Makefile
parenta72ed0005b1dc840337c91df5cde89b1015c75f8 (diff)
downloadfreebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.gz
freebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.zst
freebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.zip
- Remove ports that only work with < perl 5.12 (devel/p5-B-Size, devel/p5-Devel-Arena)
- Remove conditionals for PERL_LEVEL < 501200 - Remove regression-test targets b/c this will be centralized in Mk/bsd.perl.mk - Other minor cleanups RUN_DEPENDS = ${BUILD_DEPENDS} -> RUN_DEPENDS:= ${BUILD_DEPENDS} PR: ports/165605 Submitted by: pgollucci (myself) Approved by: portmgr (linimon) Exp Run by: linimon Tested by: make index
Diffstat (limited to 'mail/p5-Mail-SpamAssassin/Makefile')
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile18
1 files changed, 0 insertions, 18 deletions
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index f52a819f2c3a..bc2d48ab00bf 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -65,16 +65,6 @@ USE_OPENSSL= yes
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-Archive-Tar>=1.23:${PORTSDIR}/archivers/p5-Archive-Tar \
- p5-IO-Zlib>=1.04:${PORTSDIR}/archivers/p5-IO-Zlib \
- p5-Test-Harness>=3.16:${PORTSDIR}/devel/p5-Test-Harness
-.endif
-
.if defined (WITH_SPAMC)
CONFIGURE_ARGS+= BUILD_SPAMC=yes
.else
@@ -114,15 +104,7 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DB
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
.endif
-.if defined(WITH_RAZOR)
RUN_DEPENDS+= razor-agents>=2.84:${PORTSDIR}/mail/razor-agents
-.else
-.if ${PERL_LEVEL} < 501000
-.if !defined(WITH_DKIM)
-RUN_DEPENDS+= p5-Digest-SHA1>=2.11:${PORTSDIR}/security/p5-Digest-SHA1
-.endif
-.endif
-.endif
.if defined(WITH_DKIM)
RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL