aboutsummaryrefslogtreecommitdiffstats
path: root/mail/pantomime-ssl
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-10-27 17:56:46 +0800
committerdinoex <dinoex@FreeBSD.org>2002-10-27 17:56:46 +0800
commit3b282e8380c3ce858828a5efbe95b120accf5270 (patch)
treeaa23e77c53de6c72c8cbe41639e85b13b863fded /mail/pantomime-ssl
parentc44cd5bf61d15da467004cdc0bbebe3b019e00c6 (diff)
downloadfreebsd-ports-gnome-3b282e8380c3ce858828a5efbe95b120accf5270.tar.gz
freebsd-ports-gnome-3b282e8380c3ce858828a5efbe95b120accf5270.tar.zst
freebsd-ports-gnome-3b282e8380c3ce858828a5efbe95b120accf5270.zip
SSL Connections for pantomime
Diffstat (limited to 'mail/pantomime-ssl')
-rw-r--r--mail/pantomime-ssl/Makefile50
-rw-r--r--mail/pantomime-ssl/TODO22
-rw-r--r--mail/pantomime-ssl/distinfo1
-rw-r--r--mail/pantomime-ssl/pkg-comment1
-rw-r--r--mail/pantomime-ssl/pkg-descr1
-rw-r--r--mail/pantomime-ssl/pkg-plist12
6 files changed, 87 insertions, 0 deletions
diff --git a/mail/pantomime-ssl/Makefile b/mail/pantomime-ssl/Makefile
new file mode 100644
index 000000000000..1a7ac2842562
--- /dev/null
+++ b/mail/pantomime-ssl/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: Pantomime-SSL
+# Date created: 27.October 2002
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pantomime
+PORTVERSION= 1.0.5
+CATEGORIES= mail
+MASTER_SITES= http://www.collaboration-world.com/mirror/ \
+ http://extrovert.screwdriver.net/~extra/ \
+ ftp://ftp.tuwien.ac.at/z6/publishing/gnustep/libs/
+PKGNAMESUFFIX= -ssl
+DISTNAME= Pantomime-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+
+BUILD_DEPENDS+= ${LOCALLIBDIR}/libPantomime.so:${PORTSDIR}/mail/pantomime
+RUN_DEPENDS+= ${LOCALLIBDIR}/libPantomime.so:${PORTSDIR}/mail/pantomime
+
+PREFIX= ${LOCALBASE}/GNUstep
+WRKSRC= ${WRKDIR}/Pantomime/Bundles/SSL
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+ALL_TARGET=
+NO_MTREE= yes
+LOCALLIBDIR= ${PREFIX}/Local/Libraries/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu
+
+.include <bsd.port.pre.mk>
+
+.include "${PORTSDIR}/security/openssl/Makefile.ssl"
+
+.if ${MACHINE_ARCH} == "i386"
+GNU_ARCH= ix86
+.else
+GNU_ARCH= ${MACHINE_ARCH}
+.endif
+
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L}
+
+do-build:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
+
+do-install:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+
+.include <bsd.port.post.mk>
diff --git a/mail/pantomime-ssl/TODO b/mail/pantomime-ssl/TODO
new file mode 100644
index 000000000000..99a3fccd6300
--- /dev/null
+++ b/mail/pantomime-ssl/TODO
@@ -0,0 +1,22 @@
+
+ 3.1 How do I get SSL working?
+(Linux/MacOS X) [ Linux ]
+You need to install OpenSSL. This library is available in packages for most distributions. As an example, under Debian/Linux, you can do:
+
+% apt-get install libssl-dev
+
+and all the prerequisites will be installed.
+Once you have installed OpenSSL, simply compile the TCPSSLConnection by doing:
+
+% cd Pantomime/Bundles/SSL; make; make install
+
+
+[ MacOS X]
+Under Apple Mac OS X, the SSL code was developped and tested using the OpenSSL package from the Fink project. You first need to install Fink, following their instructions. Once you've installed Fink, you can install OpenSSL by doing:
+
+% apt-get install openssl-dev
+
+Once you have installed the OpenSSL package, you can open the Pantomime project inside Project Builder. Compile Pantomime using the default target first and once it has completed, select the TCPSSLConnection target and build this target. Once you've sucessfully build it, copy the TCPSSLConnection bundle to your user's library directory by doing:
+
+% mkdir ~/Library/Pantomime; cd Pantomime/build; cp -R TCPSSLConnection.bundl ~/Library/Pantomime
+
diff --git a/mail/pantomime-ssl/distinfo b/mail/pantomime-ssl/distinfo
new file mode 100644
index 000000000000..f226d0c09b32
--- /dev/null
+++ b/mail/pantomime-ssl/distinfo
@@ -0,0 +1 @@
+MD5 (Pantomime-1.0.5.tar.gz) = bb468e335dd3be2523f42a98d5c9ddf1
diff --git a/mail/pantomime-ssl/pkg-comment b/mail/pantomime-ssl/pkg-comment
new file mode 100644
index 000000000000..b766dfc98d62
--- /dev/null
+++ b/mail/pantomime-ssl/pkg-comment
@@ -0,0 +1 @@
+SSL Connections for pantomime
diff --git a/mail/pantomime-ssl/pkg-descr b/mail/pantomime-ssl/pkg-descr
new file mode 100644
index 000000000000..b766dfc98d62
--- /dev/null
+++ b/mail/pantomime-ssl/pkg-descr
@@ -0,0 +1 @@
+SSL Connections for pantomime
diff --git a/mail/pantomime-ssl/pkg-plist b/mail/pantomime-ssl/pkg-plist
new file mode 100644
index 000000000000..0bcfaf50f90b
--- /dev/null
+++ b/mail/pantomime-ssl/pkg-plist
@@ -0,0 +1,12 @@
+Local/Library/Pantomime/TCPSSLConnection.bundle/Contents/Info.plist
+Local/Library/Pantomime/TCPSSLConnection.bundle/Resources/Info-gnustep.plist
+Local/Library/Pantomime/TCPSSLConnection.bundle/Resources/Info.plist
+Local/Library/Pantomime/TCPSSLConnection.bundle/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/TCPSSLConnection
+@exec ln -sf ../Resources %D/Local/Library/Pantomime/TCPSSLConnection.bundle/Contents/Resources
+@unexec rm -f %D/Local/Library/Pantomime/TCPSSLConnection.bundle/Contents/Resources
+@dirrm Local/Library/Pantomime/TCPSSLConnection.bundle/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu
+@dirrm Local/Library/Pantomime/TCPSSLConnection.bundle/%%GNU_ARCH%%/%%OPSYS%%
+@dirrm Local/Library/Pantomime/TCPSSLConnection.bundle/%%GNU_ARCH%%
+@dirrm Local/Library/Pantomime/TCPSSLConnection.bundle/Contents
+@dirrm Local/Library/Pantomime/TCPSSLConnection.bundle/Resources
+@dirrm Local/Library/Pantomime/TCPSSLConnection.bundle