aboutsummaryrefslogtreecommitdiffstats
path: root/mail/pine4
diff options
context:
space:
mode:
authoralex <alex@FreeBSD.org>2000-06-28 00:25:32 +0800
committeralex <alex@FreeBSD.org>2000-06-28 00:25:32 +0800
commit10eaec7522e4a25af864de43848c1e9dd53d29ae (patch)
treef2b0a9c4c2b9417efb7bab6c96f83e643980fe9f /mail/pine4
parentf85553b1fa2a1957ed168ef959a876347a8e4aef (diff)
downloadfreebsd-ports-gnome-10eaec7522e4a25af864de43848c1e9dd53d29ae.tar.gz
freebsd-ports-gnome-10eaec7522e4a25af864de43848c1e9dd53d29ae.tar.zst
freebsd-ports-gnome-10eaec7522e4a25af864de43848c1e9dd53d29ae.zip
Add a WITH_LDAP knob. Defaults to off, of course.
PR: 18228 Submitted by: Mikko Tyolajarvi <mikko@dynas.se>
Diffstat (limited to 'mail/pine4')
-rw-r--r--mail/pine4/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/mail/pine4/Makefile b/mail/pine4/Makefile
index b603e51ac322..3dfb296277ba 100644
--- a/mail/pine4/Makefile
+++ b/mail/pine4/Makefile
@@ -20,6 +20,15 @@ Y2K= http://www.washington.edu/pine/QandA/sysadmins.html#Millenium
MAN1= pine.1 pico.1 pilot.1
+# Define "WITH_LDAP" to include ldap support.
+# If the ldap port is installed somewhere other than /usr/local, define
+# LDAP_PREFIX as well.
+#
+.if defined(WITH_LDAP)
+LDAP_PREFIX?= ${LOCALBASE}
+BUILD_DEPENDS+= ${LDAP_PREFIX}/lib/libldap.a:${PORTSDIR}/net/ldap
+.endif
+
post-patch:
for i in ${WRKSRC}/doc/pine.1 \
${WRKSRC}/pine/init.c \
@@ -38,6 +47,11 @@ post-patch:
$$i.sed >$$i ; \
${RM} $$i.sed ; \
done
+.if defined(WITH_LDAP)
+ -mkdir ${WRKSRC}/ldap
+ ln -sf ${LDAP_PREFIX}/include ${WRKSRC}/ldap/include
+ ln -sf ${LDAP_PREFIX}/lib ${WRKSRC}/ldap/libraries
+.endif
do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ./build bsf)