aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix25
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-01-25 04:11:07 +0800
committermnag <mnag@FreeBSD.org>2006-01-25 04:11:07 +0800
commit70a5821e227fae41942e4b9aa378831a353c6a6b (patch)
treea261ae36516d13b718c0cdfcc554b4a2d0012788 /mail/postfix25
parent2fa6426a1a0c79bad027ecf9896a3864fbd6b54e (diff)
downloadfreebsd-ports-gnome-70a5821e227fae41942e4b9aa378831a353c6a6b.tar.gz
freebsd-ports-gnome-70a5821e227fae41942e4b9aa378831a353c6a6b.tar.zst
freebsd-ports-gnome-70a5821e227fae41942e4b9aa378831a353c6a6b.zip
- Linker fix when use OPENSSL from ports
- portlint(1) PR: 92282 Reported by: dinoex Submitted by: Vivek Khera <vivek@khera.org> (maintainer)
Diffstat (limited to 'mail/postfix25')
-rw-r--r--mail/postfix25/Makefile1
-rw-r--r--mail/postfix25/pkg-plist2
-rw-r--r--mail/postfix25/scripts/configure.postfix6
3 files changed, 4 insertions, 5 deletions
diff --git a/mail/postfix25/Makefile b/mail/postfix25/Makefile
index d0e0c74cfd39..171db8be1fce 100644
--- a/mail/postfix25/Makefile
+++ b/mail/postfix25/Makefile
@@ -36,7 +36,6 @@ COMMENT= A secure alternative to widely-used Sendmail
CONFLICTS= courier-0.* postfix-1.* postfix-2.0.* postfix-2.1.* postfix-2.3.* \
sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
USE_SUBMAKE= yes
-USE_REINPLACE= yes
USE_RC_SUBR= postfix.sh
MAN1= postalias.1 postcat.1 postconf.1 postdrop.1 postfix.1 postkick.1 \
diff --git a/mail/postfix25/pkg-plist b/mail/postfix25/pkg-plist
index 84aaa9deaa28..779dff1908ea 100644
--- a/mail/postfix25/pkg-plist
+++ b/mail/postfix25/pkg-plist
@@ -231,4 +231,4 @@ bin/mailq
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm libexec/postfix
@dirrm etc/postfix/dist
-@dirrmtry etc/postfix
+@dirrmtry etc/postfix
diff --git a/mail/postfix25/scripts/configure.postfix b/mail/postfix25/scripts/configure.postfix
index 02ec70804163..eae87e9a881b 100644
--- a/mail/postfix25/scripts/configure.postfix
+++ b/mail/postfix25/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix25/scripts/Attic/configure.postfix,v 1.70 2006-01-12 16:23:59 mnag Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix25/scripts/Attic/configure.postfix,v 1.71 2006-01-24 20:09:39 mnag Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -192,7 +192,7 @@ while [ "$1" ]; do
if /usr/bin/nm ${LOCALBASE}/lib/mysql/libmysqlclient.a | grep -wq "SSL_new"; then
echo "USE_OPENSSL= yes"
echo "POSTFIX_CCARGS+= -I\${OPENSSLLIB}"
- echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} -lssl -lcrypto"
+ echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} \${LDFLAGS} -lssl -lcrypto"
fi
fi
echo "MYSQL_SUFFIX= +mysql"
@@ -258,7 +258,7 @@ if [ -z "${BATCH}" ]; then
if /usr/bin/nm ${LOCALBASE}/lib/mysql/libmysqlclient.a | grep -wq "SSL_new"; then
echo "USE_OPENSSL= yes"
echo "POSTFIX_CCARGS+= -I\${OPENSSLLIB}"
- echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} -lssl -lcrypto"
+ echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} \${LDFLAGS} -lssl -lcrypto"
fi
fi
fi