aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postsrsd
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-03-26 03:25:13 +0800
committermat <mat@FreeBSD.org>2017-03-26 03:25:13 +0800
commite4d474bed5cb0dd486e59537673898e9b5b2df7c (patch)
treed63ba75ea8a6a85c1c6e642e879fa709578ad1c7 /mail/postsrsd
parent26bb34aafbc670b1a63fb4c7e5cac9201b57a359 (diff)
downloadfreebsd-ports-gnome-e4d474bed5cb0dd486e59537673898e9b5b2df7c.tar.gz
freebsd-ports-gnome-e4d474bed5cb0dd486e59537673898e9b5b2df7c.tar.zst
freebsd-ports-gnome-e4d474bed5cb0dd486e59537673898e9b5b2df7c.zip
Remove unneeded dependency, use the opt_CMAKE_BOOL helper, and make sure
tr runs without any LC_* set or it will fail. PR: 218040 Submitted by: mat Approved by: maintainer Sponsored by: Absolight
Diffstat (limited to 'mail/postsrsd')
-rw-r--r--mail/postsrsd/Makefile7
-rw-r--r--mail/postsrsd/files/postsrsd.in2
2 files changed, 4 insertions, 5 deletions
diff --git a/mail/postsrsd/Makefile b/mail/postsrsd/Makefile
index fa5c60ce3349..d5c74d6fdbb0 100644
--- a/mail/postsrsd/Makefile
+++ b/mail/postsrsd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= postsrsd
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= mail
MAINTAINER= ports@bsdserwis.com
@@ -11,9 +12,7 @@ COMMENT= Postfix Sender Rewriting Scheme daemon
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= help2man:misc/help2man \
- base64:converters/base64
-RUN_DEPENDS= base64:converters/base64
+BUILD_DEPENDS= help2man:misc/help2man
USE_GITHUB= yes
GH_ACCOUNT= roehling
@@ -28,7 +27,7 @@ PORTDOCS= README.md main.cf.ex README_UPGRADE.md
OPTIONS_DEFINE= DOCS
-DOCS_CMAKE_ON= -DENABLE_DOCS:STRING="ON"
+DOCS_CMAKE_BOOL= ENABLE_DOCS
PLIST_FILES= sbin/postsrsd man/man8/postsrsd.8.gz
diff --git a/mail/postsrsd/files/postsrsd.in b/mail/postsrsd/files/postsrsd.in
index ca0190588306..17c3d00cd415 100644
--- a/mail/postsrsd/files/postsrsd.in
+++ b/mail/postsrsd/files/postsrsd.in
@@ -71,7 +71,7 @@ postsrsd_prepcmd ()
chown ${postsrsd_uid} ${_piddir}
fi
if [ ! -f "${postsrsd_secret}" ] ; then
- tr -cd "[:alnum:]" < /dev/urandom | head -c 24 > "${postsrsd_secret}"
+ env -i tr -cd "[:alnum:]" < /dev/urandom | head -c 24 > "${postsrsd_secret}"
fi
}