aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmail-scanner1
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2006-01-22 01:37:14 +0800
committerkrion <krion@FreeBSD.org>2006-01-22 01:37:14 +0800
commit6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac (patch)
treedca11c502d0bd243534b867dc91d5cb34bdb1adb /mail/qmail-scanner1
parent858c4e0ba24549dd475d1151d3982145bd8a83ff (diff)
downloadfreebsd-ports-gnome-6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac.tar.gz
freebsd-ports-gnome-6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac.tar.zst
freebsd-ports-gnome-6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac.zip
- Fix 'all-depends-list' target in cases if dependencies list is
very long and if some dependencies can't be added into the list. [1] - Fix FAM support. Make gamin the default FAM system. [2] - Introduce new 'quicksearch' target to show only port, path and info section of the matching ports. [3] - Introduce new category - rubygems. [4] - Fix stale dependencies while installing qmail slaveport and another port that depends on qmail. [5] - Add commentary for describes target in bsd.port.mk. [6] - Fix warning issued during make index on archs !368. [7] - Add USE_DOS2UNIX variable. If set to "YES", remove the ^M from all files under ${WRKSRC}. If set to a string, remove in all files under ${WRKSRC} with one of these names the ^Ms. [8] - Add new variables PERL_RUN_DEPENDS and PERL_BUILD_DEPENDS by checking the existance of the Perl modules with the "perl -e 'use module;'" command. [9] - Fix bsd.port.mk variable quoting issues. No quoting is necessary anymore either in the Makefile or on the command line. Affected variables include: BROKEN FORBIDDEN IGNORE MANUAL_PACKAGE_BUILD NO_CDROM NO_PACKAGE RESTRICTED [10] - Add NOFETCHFILES variable. If set, don't download these files from the ${MASTER_SITES} or ${MASTER_SITE_BACKUP} (but do from ${MASTER_SITE_OVERRIDE}). [11] - Improve 'search' target output. [12] - Add a new virtual category for Amateur Radio - hamradio. [13] - Cleanup some old/unused pathes in bsd.port.mk. [14] - Add @dirrmtry for plists which does the same as: "@unexec rmdir %D/foo 2>/dev/null || true" [15] - Remove virtual category - offix. [16] - Use portsnap instead of cvsup or cvs on "make update" in /usr/ports. [17] - Move location of bsd.autotools.mk within bsd.port.mk [18] - Add bsd.linux-rpm.mk, fix INSTALLS_SHLIB for Linux ports [19] - Use new USE_RC_SUBR format for FreeBSD version >= 700007 [20] - Replace the string "FreeBSD" by "The FreeBSD Project" in the security warning [21] - Add bsd.local.mk for local modification to ports framework. [22] - Replace rcNG spelling by rc.d [23] - Remove superfluous USE_REINPLACE. [24] Special thanks to: linimon for spending hours with all these patches clement for fixes kris for help with pointyhat PR: ports/86310 [1], ports/89498 [2], ports/83530 [3], ports/83789 [4], ports/84053 [5], ports/86281 [6], ports/87214 [7], ports/87234 [8], ports/87318 [9], ports/87396 [10], ports/87605 [11], ports/87840 [12], ports/88230 [13], ports/88493 [14], ports/88711 [15], ports/88751 [16], ports/89281 [17], ports/89999 [18], ports/90031 [19], ports/90150 [20], ports/90668 [21], ports/91433 [23], ports/88754 [24] Submitted by: mi [1], marcus [2], Lars Engels <lars.engels@0x20.net> [3], pav [4, 16, 20, 24], garga [5], cperciva [6], vd [7], edwin [8, 9, 11, 15, 21], fenner [10], Arseny Nasokin <tarc.po.cs.msu.su@tarc.po.cs.msu.su> [12], Carl Makin <carl@stagecraft.cx> [13], arved [14], NIIMI Satoshi <sa2c@sa2c.net> [17], thierry [18], jylefort [19], linimon [22], dougb [23]
Diffstat (limited to 'mail/qmail-scanner1')
-rw-r--r--mail/qmail-scanner1/Makefile16
-rw-r--r--mail/qmail-scanner1/pkg-plist30
2 files changed, 25 insertions, 21 deletions
diff --git a/mail/qmail-scanner1/Makefile b/mail/qmail-scanner1/Makefile
index 3ce416e540a2..caf6915735ca 100644
--- a/mail/qmail-scanner1/Makefile
+++ b/mail/qmail-scanner1/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qmail-scanner
PORTVERSION= 1.25
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,14 +17,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= freebsd@simplerezo.com
COMMENT= Content/Anti-virus Scanner for qmail
-BUILD_DEPENDS= ${QMAIL_QUEUE}:${PORTSDIR}/mail/qmail \
- reformime:${PORTSDIR}/mail/maildrop \
+BUILD_DEPENDS= reformime:${PORTSDIR}/mail/maildrop \
${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-# A normal qmail installation puts everything into /var/qmail/.
-# Must match your qmail installation
-QMAIL_DIR?= /var/qmail
-QMAIL_QUEUE= ${QMAIL_DIR}/bin/qmail-queue
+QMAIL_QUEUE= ${QMAIL_PREFIX}/bin/qmail-queue
USE_PERL5= yes
NO_BUILD= yes
@@ -79,12 +75,14 @@ CONFIGURE_ARGS+= --spams-tosuffix "${QMAILSCAN_SPAMSTOSUFFIX}"
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_QMAIL= yes
+
SPOOLDIR= ${PREFIX}/qmailscan
PLIST_SUB= SPOOLDIR="${SPOOLDIR:S,${PREFIX}/,,}"
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= \
- --qmaildir "${QMAIL_DIR}" --spooldir "${SPOOLDIR}" \
+ --qmaildir "${QMAIL_PREFIX}" --spooldir "${SPOOLDIR}" \
--bindir "${PREFIX}/bin" --qmail-queue-binary "${QMAIL_QUEUE}" \
--admin "${QMAILSCAN_ADMIN}" --notify "${QMAILSCAN_NOTIFY}" \
--silent-viruses "${QMAILSCAN_SILENTVIRUSES}" \
@@ -137,7 +135,7 @@ pre-configure:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} PRE-INSTALL
@if ! ${TEST} -f ${QMAIL_QUEUE}; then \
${ECHO_MSG} "Unable to found qmail-queue binary trying '${QMAIL_QUEUE}'."; \
- ${ECHO_MSG} "Please set QMAIL_DIR to your qmail installation directory !"; \
+ ${ECHO_MSG} "Please set QMAIL_PREFIX to your qmail installation directory !"; \
exit 1; \
fi
diff --git a/mail/qmail-scanner1/pkg-plist b/mail/qmail-scanner1/pkg-plist
index 4eaf88befb04..f7e3018df384 100644
--- a/mail/qmail-scanner1/pkg-plist
+++ b/mail/qmail-scanner1/pkg-plist
@@ -2,16 +2,22 @@
bin/qmail-scanner-queue.pl
bin/qs2mrtg.pl
share/examples/qs2mrtg/mrtg-qmail-scanner.cfg
+@dirrm share/examples/qs2mrtg
+@unexec if cmp -s %D/%%SPOOLDIR%%/quarantine-attachments.txt %D/%%SPOOLDIR%%/quarantine-attachments.sample; then rm -f %D/%%SPOOLDIR%%/quarantine-attachments.txt && rm -f %D/%%SPOOLDIR%%/quarantine-attachments.db; fi
%%SPOOLDIR%%/quarantine-attachments.sample
-@unexec if cmp -s %%SPOOLDIR%%/quarantine-attachments.txt %%SPOOLDIR%%/quarantine-attachments.sample; then rm -f %%SPOOLDIR%%/quarantine-attachments.txt; fi
-@unexec rmdir share/examples/qs2mrtg 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/archives/cur 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/archives/new 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/archives/tmp 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/archives 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/quarantine/cur 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/quarantine/new 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/quarantine/tmp 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/quarantine 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%%/tmp 2>/dev/null || true
-@unexec rmdir %%SPOOLDIR%% 2>/dev/null || true
+@exec [ ! -f %D/%%SPOOLDIR%%/quarantine-attachments.txt ] && cp %D/%%SPOOLDIR%%/quarantine-attachments.sample %D/%%SPOOLDIR%%/quarantine-attachments.txt
+%%SPOOLDIR%%/qmail-scanner-queue-version.txt
+@unexec rmdir %D/%%SPOOLDIR%%/archives/cur 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/archives/new 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/archives/tmp 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/archives 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/quarantine/cur 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/quarantine/new 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/quarantine/tmp 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/quarantine 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/working/cur 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/working/new 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/working/tmp 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/working 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%%/tmp 2>/dev/null || true
+@unexec rmdir %D/%%SPOOLDIR%% 2>/dev/null || true