aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmail
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-02-06 07:26:48 +0800
committerBryan Drewery <bdrewery@FreeBSD.org>2013-02-06 07:26:48 +0800
commit1bc99547837a0c68f7c0cf77a14138a3644f357a (patch)
tree596002bb632a069680f12bb14ec9935b1bba056b /mail/qmail
parent3428697732211a0d509bbb009ebb9c17da7bebcb (diff)
downloadfreebsd-ports-gnome-1bc99547837a0c68f7c0cf77a14138a3644f357a.tar.gz
freebsd-ports-gnome-1bc99547837a0c68f7c0cf77a14138a3644f357a.tar.zst
freebsd-ports-gnome-1bc99547837a0c68f7c0cf77a14138a3644f357a.zip
- Remove indefinite article from COMMENT
- Avoid directly including bsd.openssl.mk by including bsd.port.options.mk and using proper USE_OPENSSL
Diffstat (limited to 'mail/qmail')
-rw-r--r--mail/qmail/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index b3bdef8407e9..8e928974238a 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -11,7 +11,7 @@ DISTFILES?= ${DISTNAME}${EXTRACT_SUFX}
EXTRACT_ONLY?= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER?= bdrewery@FreeBSD.org
-COMMENT?= A secure, reliable, efficient, simple, and fast MTA
+COMMENT?= Secure, reliable, efficient, simple, and fast MTA
DIST_SUBDIR= qmail
@@ -334,6 +334,12 @@ CONFIGURESCRIPTS= config config-fast
WANT_QMAIL= yes
+.include <bsd.port.options.mk>
+
+.if defined(SLAVE_LDAP) && ${PORT_OPTIONS:MTLS}
+USE_OPENSSL= yes
+.endif
+
.include <bsd.port.pre.mk>
.if ${PREFIX} != ${LOCALBASE}
@@ -359,11 +365,6 @@ CFLAGS+= -DDEBUG
.if defined(SLAVE_LDAP)
-. if ${PORT_OPTIONS:MTLS}
-# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-. endif
-
. for param in ${LDAP_PARAMS}
. if ${PORT_OPTIONS:M${param}}
LDAPFLAGS+= -D${param}