aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmailadmin
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2005-12-15 17:31:32 +0800
committerroam <roam@FreeBSD.org>2005-12-15 17:31:32 +0800
commit589c79b73413c1853cdc10e62dab57b8345b8831 (patch)
tree8a432f8807f50e34daf8e5c3eca5c087dcc32615 /mail/qmailadmin
parent6fe8dfe1947ad3b44584fa29deb7b585e1c120c3 (diff)
downloadfreebsd-ports-gnome-589c79b73413c1853cdc10e62dab57b8345b8831.tar.gz
freebsd-ports-gnome-589c79b73413c1853cdc10e62dab57b8345b8831.tar.zst
freebsd-ports-gnome-589c79b73413c1853cdc10e62dab57b8345b8831.zip
Add the VPOPMAIL_DIR knob to specify a different directory where
vpopmail has previously been installed. Bump PORTREVISION. NB: change this with extreme caution! For instance, if vpopmail is not already installed in this directory, building the vpopmail port as a dependency will NOT automatically cause it to be installed there! Requested by: Jan-Erik Moon <jan@1kdigital.com>
Diffstat (limited to 'mail/qmailadmin')
-rw-r--r--mail/qmailadmin/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/mail/qmailadmin/Makefile b/mail/qmailadmin/Makefile
index 2b4cfb4683d7..61f4ae68916b 100644
--- a/mail/qmailadmin/Makefile
+++ b/mail/qmailadmin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qmailadmin
PORTVERSION= 1.2.7
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -15,12 +16,20 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= roam@FreeBSD.org
COMMENT= CGI program for administering Qmail with vchkpw/vpopmail
+# vpopmail installation directory
+#
+# NB: change this with extreme caution! For instance, if vpopmail is not
+# already installed in this directory, building the vpopmail port as
+# a dependency will NOT automatically cause it to be installed there!
+
+VPOPMAIL_DIR?= ${LOCALBASE}/vpopmail
+
BUILD_DEPENDS= \
autorespond:${PORTSDIR}/mail/autorespond \
- ${LOCALBASE}/vpopmail/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
+ ${VPOPMAIL_DIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
RUN_DEPENDS= \
autorespond:${PORTSDIR}/mail/autorespond \
- ${LOCALBASE}/vpopmail/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
+ ${VPOPMAIL_DIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
.if defined(WITHOUT_IDX)
BUILD_DEPENDS+= ezmlm-send:${PORTSDIR}/mail/ezmlm
@@ -92,7 +101,7 @@ CONFIGURE_ARGS+= \
--enable-htmllibdir=${DATADIR} \
--enable-cgibindir=${PREFIX}/${CGIBINDIR}/${CGIBINSUBDIR} \
--enable-cgipath=${CGIBINURL}/${CGIBINSUBDIR}/qmailadmin \
- --enable-vpopmaildir=${LOCALBASE}/vpopmail \
+ --enable-vpopmaildir=${VPOPMAIL_DIR} \
--enable-autoresponder-path=${LOCALBASE}/bin \
--enable-ezmlmdir=${LOCALBASE}/bin
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}