aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qpopper
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-11-14 11:15:03 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-11-14 11:15:03 +0800
commit3c8a36012b142a4660c87d9284eb0ce5f7bc5a58 (patch)
treebb5ae18425703acfafa9b7ebb7f28ff3e2e09400 /mail/qpopper
parent5558ef6556714b55605398a4c15a914103fbdb96 (diff)
downloadfreebsd-ports-gnome-3c8a36012b142a4660c87d9284eb0ce5f7bc5a58.tar.gz
freebsd-ports-gnome-3c8a36012b142a4660c87d9284eb0ce5f7bc5a58.tar.zst
freebsd-ports-gnome-3c8a36012b142a4660c87d9284eb0ce5f7bc5a58.zip
- Remove redundant definitions of IPV6_DESC and [OPEN]SSL_DESC when closely
matching standard ones from `Mk/bsd.options.desc.mk' - Rename couple of options to standard name or the one that better reflects their usage
Diffstat (limited to 'mail/qpopper')
-rw-r--r--mail/qpopper/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index 9f36fb0dad55..887efa6905de 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -41,7 +41,7 @@ PKGDEINSTALL= ${PKGINSTALL}
OPTIONS_DEFINE= APOP_ONLY APOP DOCUMENTATION DRAC FULL_POPD_DEBUG PAM \
POPPASSD SAMPLE_POPUSERS SHY_ENABLED \
- SSL STANDALONE_MODE U_OPTION
+ OPENSSL STANDALONE_MODE U_OPTION
APOP_ONLY_DESC= build with APOP authentication only
APOP_DESC= build with APOP
@@ -52,14 +52,13 @@ PAM_DESC= build with PAM authentication
POPPASSD_DESC= build the poppassd daemon
SAMPLE_POPUSERS_DESC= build a default reject file
SHY_ENABLED_DESC= hide qpopper version in POP3 banner
-SSL_DESC= build with SSL/TLS support
STANDALONE_MODE_DESC= build qpopper to be run without inetd
U_OPTION_DESC= include support for user .qpopper-options
-OPTIONS_DEFAULT= APOP SSL U_OPTION
+OPTIONS_DEFAULT= APOP OPENSSL U_OPTION
OPTIONS_SUB= yes
-SSL_USES= ssl
+OPENSSL_USES= ssl
.include <bsd.port.pre.mk>
@@ -119,7 +118,7 @@ USE_RC_SUBR= ${PORTNAME}
.endif
# The default is to build without SSL/TLS support.
-.if ${PORT_OPTIONS:MSSL}
+.if ${PORT_OPTIONS:MOPENSSL}
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.endif