aboutsummaryrefslogtreecommitdiffstats
path: root/mail/roundcube-automatic_addressbook
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2014-08-18 21:32:14 +0800
committerrobak <robak@FreeBSD.org>2014-08-18 21:32:14 +0800
commitd0b419c7f3ab31e9bbf67b669e657054ac2e9c14 (patch)
treef7410a21749dfe85f17aa3be664bcad9e3483b4f /mail/roundcube-automatic_addressbook
parentbb886dc33c83247ef0c34433fdb52ece9e80c46d (diff)
downloadfreebsd-ports-gnome-d0b419c7f3ab31e9bbf67b669e657054ac2e9c14.tar.gz
freebsd-ports-gnome-d0b419c7f3ab31e9bbf67b669e657054ac2e9c14.tar.zst
freebsd-ports-gnome-d0b419c7f3ab31e9bbf67b669e657054ac2e9c14.zip
mail/roundcube-automatic_addressbook: stage
- Add stage support - Set maintainership to anes@anes.su - Fix some tabulations PR: 192307 Submitted by: Anes Mukhametov <anes@anes.su> Approved by: marino (mentor)
Diffstat (limited to 'mail/roundcube-automatic_addressbook')
-rw-r--r--mail/roundcube-automatic_addressbook/Makefile24
1 files changed, 7 insertions, 17 deletions
diff --git a/mail/roundcube-automatic_addressbook/Makefile b/mail/roundcube-automatic_addressbook/Makefile
index 2bc79d7f8991..1c329384bf63 100644
--- a/mail/roundcube-automatic_addressbook/Makefile
+++ b/mail/roundcube-automatic_addressbook/Makefile
@@ -2,12 +2,12 @@
PORTNAME= automatic_addressbook
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://code.crapouillou.net/attachments/download/19/
PKGNAMEPREFIX= roundcube-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= anes@anes.su
COMMENT= Roundcube webmail automatic addressbook plugin
LICENSE= GPLv3
@@ -19,25 +19,15 @@ USES= tar:bzip2
NO_BUILD= yes
WRKSRC?= ${WRKDIR}/${PORTNAME}
-RCDIR= ${PREFIX}/www/roundcube
-WWWDIR= ${RCDIR}/plugins/automatic_addressbook
+RCDIR= ${PREFIX}/www/roundcube
+WWWDIR= ${RCDIR}/plugins/automatic_addressbook
SUB_FILES= pkg-message
SUB_LIST= RCDIR=${RCDIR} PLUGINDIR=${WWWDIR}
-# This target is only meant to be used by the port maintainer.
-x-generate-plist: build
- cd ${WRKSRC}; \
- ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
- ${SED} -e "s,^\.,%%WWWDIR%%," >${WRKDIR}/pkg-plist.tmp ; \
- ${FIND} . -type d | ${SORT} -r | ${SED} \
- -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
- -e "s,^\.,@dirrm %%WWWDIR%%," >>${WRKDIR}/pkg-plist.tmp
-
-NO_STAGE= yes
do-install:
- @${MKDIR} ${WWWDIR}
- @cd ${WRKSRC} && ${PAX} -r -w . ${WWWDIR}
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ cd ${WRKSRC} && ${PAX} -r -w . ${STAGEDIR}${WWWDIR}
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>