aboutsummaryrefslogtreecommitdiffstats
path: root/mail/smfsav/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-02-18 05:16:46 +0800
committerpav <pav@FreeBSD.org>2008-02-18 05:16:46 +0800
commit1cc1d195c80905f7a8a909ebb613529bb76f86f9 (patch)
treece686c775f283bdd9977d24be946013852c22e15 /mail/smfsav/Makefile
parent199bec2e3cd1c4860076e3778a57343c3c50dfde (diff)
downloadfreebsd-ports-gnome-1cc1d195c80905f7a8a909ebb613529bb76f86f9.tar.gz
freebsd-ports-gnome-1cc1d195c80905f7a8a909ebb613529bb76f86f9.tar.zst
freebsd-ports-gnome-1cc1d195c80905f7a8a909ebb613529bb76f86f9.zip
It's a lightweight, fast and reliable Sendmail milter that implements
a real-time Sender e-Mail Address Verification technology. This technology can stop some kinds of SPAM with a spoofed sender's e-Mail address. Also it implements a real-time Recipient e-Mail Address Verification technology. It can be useful if your machine is a backup MX for the recipient's domains or if your machine forwards all e-Mail messages as a relay host for your domains to another internal or external e-Mail servers. It's a lite alternative for the spamilter, milter-sender and milter-ahead milters. WWW: http://smfs.sourceforge.net/ PR: ports/116948 Submitted by: Anton Lysenok / Bart Tapolsky <bart@tapolsky.net.ua>
Diffstat (limited to 'mail/smfsav/Makefile')
-rw-r--r--mail/smfsav/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/mail/smfsav/Makefile b/mail/smfsav/Makefile
new file mode 100644
index 000000000000..2104dc4bb085
--- /dev/null
+++ b/mail/smfsav/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: smfsav
+# Date created: 17 February 2008
+# Whom: Anton Lysenok <bart@tapolsky.net.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smfsav
+PORTVERSION= 1.4.0
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}:0 \
+ ${MASTER_SITE_ISC}:1
+MASTER_SITE_SUBDIR= smfs/:0 \
+ bind8/src/8.4.7/:1
+DISTNAME= smf-sav-1.4.0
+DISTFILES= smf-sav-1.4.0.tar.gz:0 \
+ bind-src.tar.gz:1
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= bart@tapolsky.net.ua
+COMMENT= Sendmail Sender Address Validator
+
+PLIST_FILES= sbin/smfsav \
+ etc/smfsav.conf-dist
+
+.if !defined(NOPORTDOCS)
+PLIST_FILES+= %%PORTDOCS%%%%DOCSDIR%%/COPYING \
+ %%PORTDOCS%%%%DOCSDIR%%/CHANGES \
+ %%PORTDOCS%%%%DOCSDIR%%/README
+PLIST_DIRS= share/doc/${PORTNAME}
+.endif
+
+USE_RC_SUBR= smfsav
+
+SUB_FILES= pkg-message
+
+pre-build:
+ @${ECHO}
+ @${ECHO} [*] Compiling BIND 8 to make SmfSav able to resolve DNS names
+ ${MAKE} all -C ${WRKDIR}/src
+ @${ECHO}
+ @${ECHO} [*] Compiling SmfSav
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/smf-sav ${PREFIX}/sbin/smfsav
+ ${INSTALL_DATA} ${WRKSRC}/smf-sav.conf ${PREFIX}/etc/smfsav.conf-dist
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}/COPYING
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}/CHANGES
+ ${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}/README
+.endif
+
+ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>