aboutsummaryrefslogtreecommitdiffstats
path: root/mail/spamilter
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2018-10-20 03:27:11 +0800
committerdinoex <dinoex@FreeBSD.org>2018-10-20 03:27:11 +0800
commit76349b3a2cec697a9d79062b9c7aec1998880379 (patch)
tree1465fe352005cf66cc8543c23aa9ddfbebb6ca81 /mail/spamilter
parent79c83202a78ffe9fe6e9294a8fcc60abfa239aa2 (diff)
downloadfreebsd-ports-gnome-76349b3a2cec697a9d79062b9c7aec1998880379.tar.gz
freebsd-ports-gnome-76349b3a2cec697a9d79062b9c7aec1998880379.tar.zst
freebsd-ports-gnome-76349b3a2cec697a9d79062b9c7aec1998880379.zip
- make ipfwmtad optional
- fix build on FreeBSD-12
Diffstat (limited to 'mail/spamilter')
-rw-r--r--mail/spamilter/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/mail/spamilter/Makefile b/mail/spamilter/Makefile
index f3ff3e2ce08b..0b4ae6b80ae4 100644
--- a/mail/spamilter/Makefile
+++ b/mail/spamilter/Makefile
@@ -26,15 +26,15 @@ DOCSFILES= Changelog INSTALL LICENSE docs/docs.html docs/docs.txt \
conf/db.rcpt conf/db.rdnsbl conf/db.sndr \
conf/policy.html conf/spamilter.rc
-PLIST_FILES+= bin/dnsblchk bin/dnsblupd bin/ipfwmtad bin/mxlookup \
- bin/spamilter \
+PLIST_FILES+= bin/dnsblchk bin/dnsblupd bin/mxlookup bin/spamilter \
bin/spamilter-system-report bin/spamilter-user-report
PORTDOCS= Changelog INSTALL LICENSE docs.html docs.txt db.rcpt \
db.rdnsbl db.sndr policy.html spamilter.rc
-OPTIONS_DEFINE= SMTP_AFTER_POP3 PAM LIBSPF DOCS
+OPTIONS_DEFINE= SMTP_AFTER_POP3 PAM LIBSPF IPFWMTAD DOCS
SMTP_AFTER_POP3_DESC= SMTP after POP3
LIBSPF_DESC= build with libspf
+IPFWMTAD_DESC= build ipfwmtad (requires openssl)
SMTP_AFTER_POP3_CONFIGURE_ON= --with-popauth
PAM_CONFIGURE_ON= --with-pam
@@ -42,9 +42,15 @@ LIBSPF_BUILD_DEPENDS= ${LOCALBASE}/lib/libspf.a:mail/libspf
LIBSPF_CONFIGURE_ON= --with-libspf ${LOCALBASE}
LIBSPF_CFLAGS= -I${LOCALBASE}/include
LIBSPF_LDFLAGS= -L${LOCALBASE}/lib
+IPFWMTAD_PLIST_FILES= bin/ipfwmtad
+IPFWMTAD_USES= ssl
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MIPFWMTAD}
+BROKEN_FreeBSD_12= option IPFWMTAD needs old openssl
+.endif
+
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
CONFIGURE_ARGS+= --sendmail-dir "${MILTERBASE}"
@@ -61,6 +67,14 @@ pre-configure:
-e "s=/usr/local/=${PREFIX}/=" \
${WRKSRC}/Makefile.tmpl
+.if ! ${PORT_OPTIONS:MIPFWMTAD}
+post-configure:
+ ${REINPLACE_CMD} \
+ -e 's| install-ipfwmtad $$| |' \
+ -e 's| ipfwmtad $$| |' \
+ ${WRKSRC}/Makefile
+.endif
+
post-install:
.for i in ${BINFILES}
${INSTALL_SCRIPT} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin/