aboutsummaryrefslogtreecommitdiffstats
path: root/mail/squirrelmail-websearch-plugin
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-08-11 03:48:06 +0800
committermiwi <miwi@FreeBSD.org>2006-08-11 03:48:06 +0800
commit3326f5e9823a677184480704e1288cf1fe275d69 (patch)
tree2ff36197203555cb06350c3a1c6308544fa2c338 /mail/squirrelmail-websearch-plugin
parent5c82edef6cdab4a8572a1d1ab24006d2227c3003 (diff)
downloadfreebsd-ports-gnome-3326f5e9823a677184480704e1288cf1fe275d69.tar.gz
freebsd-ports-gnome-3326f5e9823a677184480704e1288cf1fe275d69.tar.zst
freebsd-ports-gnome-3326f5e9823a677184480704e1288cf1fe275d69.zip
Puts a web search box in the left frame that can use a variety of
search engines. Currently supported: * Google * Google Adsense for Search * Yahoo! WWW: http://www.squirrelmail.org Approved by: krion (mentor)
Diffstat (limited to 'mail/squirrelmail-websearch-plugin')
-rw-r--r--mail/squirrelmail-websearch-plugin/Makefile75
-rw-r--r--mail/squirrelmail-websearch-plugin/distinfo3
-rw-r--r--mail/squirrelmail-websearch-plugin/files/pkg-message.in5
-rw-r--r--mail/squirrelmail-websearch-plugin/pkg-descr8
-rw-r--r--mail/squirrelmail-websearch-plugin/pkg-plist9
5 files changed, 100 insertions, 0 deletions
diff --git a/mail/squirrelmail-websearch-plugin/Makefile b/mail/squirrelmail-websearch-plugin/Makefile
new file mode 100644
index 000000000000..80c0954a2e84
--- /dev/null
+++ b/mail/squirrelmail-websearch-plugin/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: squirrelmail-websearch-plugin
+# Date created: 10 August
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 0.1.6
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Plugin for Websearch
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= web_search
+
+SUB_FILES= pkg-message
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+. ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+. else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+. endif
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-websearch-plugin/distinfo b/mail/squirrelmail-websearch-plugin/distinfo
new file mode 100644
index 000000000000..588c04a79ec3
--- /dev/null
+++ b/mail/squirrelmail-websearch-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/web_search-0.1.6.tar.gz) = 71561a5747eecd74adc490595c03d957
+SHA256 (squirrelmail/web_search-0.1.6.tar.gz) = 30acdcc02ece6b91aea41a3cf0bd5ac125b6dd67118326380ad193ebd80de8de
+SIZE (squirrelmail/web_search-0.1.6.tar.gz) = 3202
diff --git a/mail/squirrelmail-websearch-plugin/files/pkg-message.in b/mail/squirrelmail-websearch-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..fa109fa20163
--- /dev/null
+++ b/mail/squirrelmail-websearch-plugin/files/pkg-message.in
@@ -0,0 +1,5 @@
+For the port to work properly you must copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/web_search/web_search.conf.php.dist
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/web_search/config.php
+and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-websearch-plugin/pkg-descr b/mail/squirrelmail-websearch-plugin/pkg-descr
new file mode 100644
index 000000000000..f514b75fede4
--- /dev/null
+++ b/mail/squirrelmail-websearch-plugin/pkg-descr
@@ -0,0 +1,8 @@
+Puts a web search box in the left frame that can use a variety of
+search engines. Currently supported:
+
+ * Google
+ * Google Adsense for Search
+ * Yahoo!
+
+WWW: http://www.squirrelmail.org
diff --git a/mail/squirrelmail-websearch-plugin/pkg-plist b/mail/squirrelmail-websearch-plugin/pkg-plist
new file mode 100644
index 000000000000..1ae0dd952326
--- /dev/null
+++ b/mail/squirrelmail-websearch-plugin/pkg-plist
@@ -0,0 +1,9 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin web_search; fi
+%%SQUIRRELDIR%%/plugins/web_search/README
+%%SQUIRRELDIR%%/plugins/web_search/api.php
+%%SQUIRRELDIR%%/plugins/web_search/hooks.php
+%%SQUIRRELDIR%%/plugins/web_search/setup.php
+%%SQUIRRELDIR%%/plugins/web_search/version
+%%SQUIRRELDIR%%/plugins/web_search/web_search.conf.php.dist
+@dirrm %%SQUIRRELDIR%%/plugins/web_search/
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin web_search; fi