aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sqwebmail
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2004-07-24 02:39:03 +0800
committeroliver <oliver@FreeBSD.org>2004-07-24 02:39:03 +0800
commitaa56d891b54b2604e201e2b13ac5a7ed32c0222a (patch)
tree5bf07938421787fb11cc317ef317593041636e1e /mail/sqwebmail
parented2dda819a1d9dbf28f0d2c714e99be818a167c2 (diff)
downloadfreebsd-ports-gnome-aa56d891b54b2604e201e2b13ac5a7ed32c0222a.tar.gz
freebsd-ports-gnome-aa56d891b54b2604e201e2b13ac5a7ed32c0222a.tar.zst
freebsd-ports-gnome-aa56d891b54b2604e201e2b13ac5a7ed32c0222a.zip
setting USE_LIBTOOL_VER forces USE_GNU_CONFIGURE which modifies CONFIGURE_ARGS
and by adding --prefix to it, the port gets installed into a wrong directory. Thats fixed now. Noted by: ale
Diffstat (limited to 'mail/sqwebmail')
-rw-r--r--mail/sqwebmail/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index 234c017d0f71..3d8d4a3a9f69 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -77,7 +77,6 @@ CONFIGURE_ARGS= \
--enable-imagedir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR} \
--libexecdir=${PREFIX}/libexec/sqwebmail \
--mandir=${PREFIX}/man \
- --prefix=${PREFIX}/share/sqwebmail \
--enable-imageurl=/${IMAGEURL} \
--with-locking-method=fcntl \
--with-libintl-prefix=${LOCALBASE} \
@@ -223,6 +222,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|^case x$$lockmethod in|${TEST} \&\& &|g' \
${WRKSRC}/liblock/configure
+ @${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|prefix=\$$ac_optarg|&/share/sqwebmail|g'
+
@${REINPLACE_CMD} -e 's|mkdir -p|${MKDIR}|g' ${WRKSRC}/pcp/configure
@${REINPLACE_CMD} -e 's|@LIBTOOL@|${LIBTOOL}|' \
@@ -244,5 +246,4 @@ post-install:
install-configure:
cd ${WRKSRC} && ${GMAKE} install-configure
-
.include <bsd.port.mk>