aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sqwebmail
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2003-01-09 22:28:40 +0800
committernbm <nbm@FreeBSD.org>2003-01-09 22:28:40 +0800
commitba5df6df470d40060cc13cd672dfb4fbef335890 (patch)
tree8af882d8351cec983bed91ef5983f68987e904d9 /mail/sqwebmail
parent8a6595ee7a1a37e500aa8014b20b720f1304a61e (diff)
downloadfreebsd-ports-gnome-ba5df6df470d40060cc13cd672dfb4fbef335890.tar.gz
freebsd-ports-gnome-ba5df6df470d40060cc13cd672dfb4fbef335890.tar.zst
freebsd-ports-gnome-ba5df6df470d40060cc13cd672dfb4fbef335890.zip
New user config options for sqwebmail
PR: 44888 Submitted by: Scott Lampert <scott@lampert.org>
Diffstat (limited to 'mail/sqwebmail')
-rw-r--r--mail/sqwebmail/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index 1f0633a0f34d..dacaa0f8a33a 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -43,6 +43,11 @@ IMAGEURL?= ${WEBDATASUBDIR}
# set WITH_TIMEOUTSOFT to something other than 1200 seconds (20m)
# set VCHKPW to the home of the vpopmail user, if necessary
#
+# The following settings are in bytes:
+# set WITH_MAXMSGSIZE to max size of messages (including attachments)
+# set WITH_MAXARGSIZE to max size of a text message (excluding attachments)
+# set WITH_MAXFORMARGSIZE to max size of attachments
+
CACHEDIR?= /var/sqwebmail/cache
CACHEOWNER?= bin
@@ -128,6 +133,18 @@ CONFIGURE_ARGS+= --enable-hardtimeout=${WITH_TIMEOUTHARD}
CONFIGURE_ARGS+= --enable-softtimeout=${WITH_TIMEOUTSOFT}
.endif
+.if defined(WITH_MAXMSGSIZE)
+CONFIGURE_ARGS+= --with-maxmsgsize=${WITH_MAXMSGSIZE}
+.endif
+
+.if defined(WITH_MAXARGSIZE)
+CONFIGURE_ARGS+= --with-maxargsize=${WITH_MAXARGSIZE}
+.endif
+
+.if defined(WITH_MAXFORMARGSIZE)
+CONFIGURE_ARGS+= --with-maxformargsize=${WITH_MAXFORMARGSIZE}
+.endif
+
MANPREFIX= ${PREFIX}/share/sqwebmail
MAN1= maildirmake.1
MAN7= authlib.7