aboutsummaryrefslogtreecommitdiffstats
path: root/mail/thunderbird/Makefile
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-08-17 02:23:05 +0800
committerflo <flo@FreeBSD.org>2011-08-17 02:23:05 +0800
commit4cc74dd9dee243258927fdd90604448717e4bf7e (patch)
treeb89bfc78f312cf0d38eea131025ca38d972fdc7c /mail/thunderbird/Makefile
parentb7303fd3efccb797c89028a30cdcdf6a1d4b6035 (diff)
downloadfreebsd-ports-gnome-4cc74dd9dee243258927fdd90604448717e4bf7e.tar.gz
freebsd-ports-gnome-4cc74dd9dee243258927fdd90604448717e4bf7e.tar.zst
freebsd-ports-gnome-4cc74dd9dee243258927fdd90604448717e4bf7e.zip
update to 6.0
Security: http://www.vuxml.org/freebsd/834591a9-c82f-11e0-897d-6c626dd55a41.html
Diffstat (limited to 'mail/thunderbird/Makefile')
-rw-r--r--mail/thunderbird/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 5e158618fd7a..e87b1252ce57 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= thunderbird
-DISTVERSION= 5.0
+DISTVERSION= 6.0
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
@@ -36,7 +36,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GL= gl
-MOZ_PROTOCOLS= http,ftp,file,viewsource,res,data,wyciwyg
+MOZ_PROTOCOLS= http,ftp,file,viewsource,res,data,wyciwyg,websocket
MOZ_GRAPHICS= default,-xbm
MOZ_OPTIONS= --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
--enable-single-profile --disable-profilesharing \
@@ -59,7 +59,7 @@ OPTIONS= LIGHTNING "Enable calendar extension" off
.include <bsd.port.pre.mk>
-WRKSRC= ${WRKDIR}/comm-miramar
+WRKSRC= ${WRKDIR}/comm-release
MOZSRC:= ${WRKSRC}/mozilla
.if ${ARCH} == powerpc64
@@ -71,8 +71,6 @@ CFLAGS+= -mminimal-toc
.endif
.endif
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-
.if ${HAVE_GNOME:Mlibgnomeui}!=""
USE_GNOME+= libgnomeui
MOZ_OPTIONS+= --enable-gnomeui
@@ -101,7 +99,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
MOZ_OPTIONS+= --disable-calendar
.endif
-post-extract::
+post-extract:
${SED} -e 's|@PORTNAME_ICON@|${PORTNAME_ICON}|' \
<${FILESDIR}/thunderbird.desktop.in >${WRKDIR}/${MOZILLA_EXEC_NAME}.desktop
@@ -109,7 +107,7 @@ post-patch:
@${GREP} -Flr \"/proc ${MOZSRC}/ipc/chromium/src/base | ${XARGS} ${REINPLACE_CMD} \
-e 's|/proc/self/fd|/dev/fd|' \
-e 's|/proc["/]|/compat/linux&|'
- ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
${MOZSRC}/storage/build/Makefile.in \
${MOZSRC}/toolkit/library/Makefile.in \
${MOZSRC}/db/sqlite3/src/Makefile.in