aboutsummaryrefslogtreecommitdiffstats
path: root/mail/thunderbird/files/patch-bug981348
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-07-19 07:44:21 +0800
committerjbeich <jbeich@FreeBSD.org>2018-07-19 07:44:21 +0800
commitd785e5da874aa3c331cf1836fc5ffca3364f7f63 (patch)
tree25470098899348b52b879360dae665e7d4b833ee /mail/thunderbird/files/patch-bug981348
parent471bc41ebb3c0c282307262f55bf138ca1b1b498 (diff)
downloadfreebsd-ports-gnome-d785e5da874aa3c331cf1836fc5ffca3364f7f63.tar.gz
freebsd-ports-gnome-d785e5da874aa3c331cf1836fc5ffca3364f7f63.tar.zst
freebsd-ports-gnome-d785e5da874aa3c331cf1836fc5ffca3364f7f63.zip
mail/thunderbird: drop patches in preparation for update
$ svn commit Sending Mk/Uses/gecko.mk Sending mail/thunderbird/Makefile Sending mail/thunderbird/distinfo Sending mail/thunderbird/files/patch-addon-search Replacing mail/thunderbird/files/patch-bug1021761 Adding mail/thunderbird/files/patch-bug1144632 Deleting mail/thunderbird/files/patch-bug1186967 [...] Transmitting file data ..........done Committing transaction... svn: E165001: Commit failed (details follow): svn: E165001: Commit blocked by pre-commit hook (exit code 1) with output: Do not replace a file. This can lose history. Path: "/head/mail/thunderbird/files/patch-bug702179" == Additional errors may compound and may not be accurate == Do not replace a file. This can lose history. Path: "/head/mail/thunderbird/files/patch-bug1021761" Do not replace a file. This can lose history. Path: "/head/mail/thunderbird/files/patch-bug1288587" Do not replace a file. This can lose history. Path: "/head/mail/thunderbird/files/patch-bug847568" Do not replace a file. This can lose history. Path: "/head/mail/thunderbird/files/patch-env-api-keys" [...] Pointy hat to: portmgr (multi-steps are error prone)
Diffstat (limited to 'mail/thunderbird/files/patch-bug981348')
-rw-r--r--mail/thunderbird/files/patch-bug98134861
1 files changed, 0 insertions, 61 deletions
diff --git a/mail/thunderbird/files/patch-bug981348 b/mail/thunderbird/files/patch-bug981348
deleted file mode 100644
index 3e8848868cd9..000000000000
--- a/mail/thunderbird/files/patch-bug981348
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git dom/system/OSFileConstants.cpp dom/system/OSFileConstants.cpp
-index 88bba9baa401..99f240952dfe 100644
---- mozilla/dom/system/OSFileConstants.cpp
-+++ mozilla/dom/system/OSFileConstants.cpp
-@@ -16,14 +16,17 @@
- #include "dirent.h"
- #include "poll.h"
- #include "sys/stat.h"
--#if defined(ANDROID)
-+#if defined(XP_LINUX)
- #include <sys/vfs.h>
- #define statvfs statfs
-+#define f_frsize f_bsize
- #else
- #include "sys/statvfs.h"
-+#endif // defined(XP_LINUX)
-+#if !defined(ANDROID)
- #include "sys/wait.h"
- #include <spawn.h>
--#endif // defined(ANDROID)
-+#endif // !defined(ANDROID)
- #endif // defined(XP_UNIX)
-
- #if defined(XP_LINUX)
-@@ -699,7 +702,7 @@ static const dom::ConstantSpec gLibcProperties[] =
-
- { "OSFILE_SIZEOF_STATVFS", JS::Int32Value(sizeof (struct statvfs)) },
-
-- { "OSFILE_OFFSETOF_STATVFS_F_BSIZE", JS::Int32Value(offsetof (struct statvfs, f_bsize)) },
-+ { "OSFILE_OFFSETOF_STATVFS_F_FRSIZE", JS::Int32Value(offsetof (struct statvfs, f_frsize)) },
- { "OSFILE_OFFSETOF_STATVFS_F_BAVAIL", JS::Int32Value(offsetof (struct statvfs, f_bavail)) },
-
- #endif // defined(XP_UNIX)
-diff --git toolkit/components/osfile/modules/osfile_unix_back.jsm toolkit/components/osfile/modules/osfile_unix_back.jsm
-index a028dda7d5ec..f5c632e3d7e5 100644
---- mozilla/toolkit/components/osfile/modules/osfile_unix_back.jsm
-+++ mozilla/toolkit/components/osfile/modules/osfile_unix_back.jsm
-@@ -228,8 +228,8 @@
- let statvfs = new SharedAll.HollowStructure("statvfs",
- Const.OSFILE_SIZEOF_STATVFS);
-
-- statvfs.add_field_at(Const.OSFILE_OFFSETOF_STATVFS_F_BSIZE,
-- "f_bsize", Type.unsigned_long.implementation);
-+ statvfs.add_field_at(Const.OSFILE_OFFSETOF_STATVFS_F_FRSIZE,
-+ "f_frsize", Type.unsigned_long.implementation);
- statvfs.add_field_at(Const.OSFILE_OFFSETOF_STATVFS_F_BAVAIL,
- "f_bavail", Type.fsblkcnt_t.implementation);
-
-diff --git toolkit/components/osfile/modules/osfile_unix_front.jsm toolkit/components/osfile/modules/osfile_unix_front.jsm
-index bd60d4d8419c..a8cd6b546b0e 100644
---- mozilla/toolkit/components/osfile/modules/osfile_unix_front.jsm
-+++ mozilla/toolkit/components/osfile/modules/osfile_unix_front.jsm
-@@ -399,7 +399,7 @@
- throw_on_negative("statvfs", (UnixFile.statvfs || UnixFile.statfs)(sourcePath, fileSystemInfoPtr));
-
- let bytes = new Type.uint64_t.implementation(
-- fileSystemInfo.f_bsize * fileSystemInfo.f_bavail);
-+ fileSystemInfo.f_frsize * fileSystemInfo.f_bavail);
-
- return bytes.value;
- };