aboutsummaryrefslogtreecommitdiffstats
path: root/mail/tpop3d
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-03-31 02:00:38 +0800
committerpawel <pawel@FreeBSD.org>2015-03-31 02:00:38 +0800
commit59a5f73a7faefd4099faaa1ce24a394f40439246 (patch)
tree50253bd91c46a8bf91a9ee98ad1670ba5a7a200e /mail/tpop3d
parent2bcd89b0eb2c681e5d2b68fab81e2e3ab9f6db50 (diff)
downloadfreebsd-ports-gnome-59a5f73a7faefd4099faaa1ce24a394f40439246.tar.gz
freebsd-ports-gnome-59a5f73a7faefd4099faaa1ce24a394f40439246.tar.zst
freebsd-ports-gnome-59a5f73a7faefd4099faaa1ce24a394f40439246.zip
- Fix build when GDBMAUTH=on [1]
- Use options helpers - Correct CFLAGS handling - don't append "-g -O2" to our flags - Remove optional installation of DOCS, staging takes care of that PR: 198918 [1] Reported by: vas@mpeks.tomsk.su [1]
Diffstat (limited to 'mail/tpop3d')
-rw-r--r--mail/tpop3d/Makefile41
1 files changed, 10 insertions, 31 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index b15ba5f6a41e..ca69212ba6c1 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -41,39 +41,20 @@ PASSWDAUTH_CONFIGURE_ENABLE= auth-passwd
MBOXINDICES_CONFIGURE_ENABLE= mbox-bsd-save-indices
DRAC_BUILD_DEPENDS= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
+GDBMAUTH_CPPFLAGS= -I${LOCALBASE}/include
GDBMAUTH_LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm
-
-.include <bsd.port.options.mk>
-
-# MySQL authentication
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-CONFIGURE_ARGS+= --enable-auth-mysql \
+MYSQL_USE= MYSQL=yes
+MYSQL_CONFIGURE_ON= --enable-auth-mysql \
--with-mysql-lib-dir=${LOCALBASE}/lib/mysql \
--with-mysql-include-dir=${LOCALBASE}/include/mysql
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USES+= pgsql
-DEFAULT_PGSQL_VER= 80
-CONFIGURE_ARGS+= --enable-auth-pgsql \
+PGSQL_USES= pgsql
+PGSQL_CONFIGURE_ON= --enable-auth-pgsql \
--with-pgsql-lib-dir=${LOCALBASE}/lib \
--with-pgsql-include-dir=${LOCALBASE}/include
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_OPENLDAP= yes
-CONFIGURE_ARGS+= --enable-auth-ldap --with-openldap-root=${LOCALBASE}
-.endif
-
-# Perl authentication
-.if ${PORT_OPTIONS:MPERLAUTH}
-USES+= perl5
-.endif
-
-.if ${PORT_OPTIONS:MFIX_PERLAUTH}
-EXTRA_PATCHES+=${PATCHDIR}/extra-patch-auth_perl.c
-.endif
+LDAP_USE= OPENLDAP=yes
+LDAP_CONFIGURE_ON= --enable-auth-ldap --with-openldap-root=${LOCALBASE}
+PERLAUTH_USES= perl5
+FIX_PERLAUTH_EXTRA_PATCHES=${PATCHDIR}/extra-patch-auth_perl.c
USE_RC_SUBR= tpop3d
DEFAULT_CONFIG= ${PREFIX}/etc/tpop3d.conf.sample
@@ -82,7 +63,7 @@ PORTDOCS= CHANGES CREDITS FAQ HACKING INSTALL PORTABILITY \
README README.POP-before-SMTP README.auth_mysql TODO
post-patch:
- @${REINPLACE_CMD} 's,^CFLAGS =, CFLAGS = \@CFLAGS\@,' \
+ @${REINPLACE_CMD} '/^CFLAGS/ s, -g -O2,,' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} 's,/etc/tpop3d,${PREFIX}/etc/tpop3d,g' \
${WRKSRC}/tpop3d.conf.5 ${WRKSRC}/tpop3d.8
@@ -93,9 +74,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/tpop3d.conf.5 ${STAGEDIR}${MANPREFIX}/man/man5
${INSTALL_MAN} ${WRKSRC}/tpop3d.8 ${STAGEDIR}${MANPREFIX}/man/man8
${INSTALL_PROGRAM} ${WRKSRC}/tpop3d ${STAGEDIR}${PREFIX}/sbin
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>