aboutsummaryrefslogtreecommitdiffstats
path: root/mail/tpop3d
diff options
context:
space:
mode:
authorlaszlof <laszlof@FreeBSD.org>2006-12-06 02:40:12 +0800
committerlaszlof <laszlof@FreeBSD.org>2006-12-06 02:40:12 +0800
commitc5ded6d50964eb6a6c3817b64885013e1d368ddd (patch)
tree69acffd352ae3b33d42120f8c36598c18a3aed7a /mail/tpop3d
parent83c53eb2a2655cd8903c0cf9ef9d758e37bcd890 (diff)
downloadfreebsd-ports-gnome-c5ded6d50964eb6a6c3817b64885013e1d368ddd.tar.gz
freebsd-ports-gnome-c5ded6d50964eb6a6c3817b64885013e1d368ddd.tar.zst
freebsd-ports-gnome-c5ded6d50964eb6a6c3817b64885013e1d368ddd.zip
This update contains extra patch which is not approved by Chris Lightfoot
(the tpop3d author) as he is unreachable for a long time period. Indeed this patch may help people who have coredumps with auth-perl and multithreaded perl. Big thanks to George A Eliseeff <kuzmich at inbox.ru>. PR: ports/106365 Submitted by: Boris Kovalenko <boris@tagnet.ru> (maintainer)
Diffstat (limited to 'mail/tpop3d')
-rw-r--r--mail/tpop3d/Makefile7
-rw-r--r--mail/tpop3d/files/extra-patch-auth_perl.c16
2 files changed, 22 insertions, 1 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index 1924d4132511..79f2ae344cbb 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -28,7 +28,8 @@ OPTIONS= MYSQL "Use MySQL authentication" off \
PERLAUTH "Use Perl authentication" off \
FLATAUTH "Enable /etc/passwd-style authentication" off \
MAILDIR "Compile Maildir support" on \
- DRAC "Enable DRAC RFC for POP-before-SMTP relaying" off
+ DRAC "Enable DRAC RFC for POP-before-SMTP relaying" off \
+ FIX_PERLAUTH "Only try it if perl-auth coredumps" off
.include <bsd.port.pre.mk>
@@ -76,6 +77,10 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
LDFLAGS+= -L${LOCALBASE}/lib
.endif
+.if defined(WITH_FIX_PERLAUTH)
+EXTRA_PATCHES+=${PATCHDIR}/extra-patch-auth_perl.c
+.endif
+
USE_RC_SUBR= tpop3d.sh
DEFAULT_CONFIG= ${PREFIX}/etc/tpop3d.conf.dist
diff --git a/mail/tpop3d/files/extra-patch-auth_perl.c b/mail/tpop3d/files/extra-patch-auth_perl.c
new file mode 100644
index 000000000000..37b8d8179f04
--- /dev/null
+++ b/mail/tpop3d/files/extra-patch-auth_perl.c
@@ -0,0 +1,16 @@
+--- auth_perl.c.orig Mon Aug 25 21:51:25 2003
++++ auth_perl.c Mon Dec 4 14:23:46 2006
+@@ -72,5 +72,5 @@
+
+ int auth_perl_init(void) {
+- dSP;
++// dSP;
+ int argc = 2;
+ char *argv[3] = {"auth_perl", "/dev/null", NULL};
+@@ -106,4 +106,6 @@
+ perl_parse(perl_interp, xs_init, argc, argv, 0);
+ perl_run(perl_interp);
++
++ dSP;
+
+ /* Try to execute the startup code. */