aboutsummaryrefslogtreecommitdiffstats
path: root/mail/vpopmail-devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2006-01-22 01:37:14 +0800
committerkrion <krion@FreeBSD.org>2006-01-22 01:37:14 +0800
commit6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac (patch)
treedca11c502d0bd243534b867dc91d5cb34bdb1adb /mail/vpopmail-devel
parent858c4e0ba24549dd475d1151d3982145bd8a83ff (diff)
downloadfreebsd-ports-gnome-6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac.tar.gz
freebsd-ports-gnome-6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac.tar.zst
freebsd-ports-gnome-6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac.zip
- Fix 'all-depends-list' target in cases if dependencies list is
very long and if some dependencies can't be added into the list. [1] - Fix FAM support. Make gamin the default FAM system. [2] - Introduce new 'quicksearch' target to show only port, path and info section of the matching ports. [3] - Introduce new category - rubygems. [4] - Fix stale dependencies while installing qmail slaveport and another port that depends on qmail. [5] - Add commentary for describes target in bsd.port.mk. [6] - Fix warning issued during make index on archs !368. [7] - Add USE_DOS2UNIX variable. If set to "YES", remove the ^M from all files under ${WRKSRC}. If set to a string, remove in all files under ${WRKSRC} with one of these names the ^Ms. [8] - Add new variables PERL_RUN_DEPENDS and PERL_BUILD_DEPENDS by checking the existance of the Perl modules with the "perl -e 'use module;'" command. [9] - Fix bsd.port.mk variable quoting issues. No quoting is necessary anymore either in the Makefile or on the command line. Affected variables include: BROKEN FORBIDDEN IGNORE MANUAL_PACKAGE_BUILD NO_CDROM NO_PACKAGE RESTRICTED [10] - Add NOFETCHFILES variable. If set, don't download these files from the ${MASTER_SITES} or ${MASTER_SITE_BACKUP} (but do from ${MASTER_SITE_OVERRIDE}). [11] - Improve 'search' target output. [12] - Add a new virtual category for Amateur Radio - hamradio. [13] - Cleanup some old/unused pathes in bsd.port.mk. [14] - Add @dirrmtry for plists which does the same as: "@unexec rmdir %D/foo 2>/dev/null || true" [15] - Remove virtual category - offix. [16] - Use portsnap instead of cvsup or cvs on "make update" in /usr/ports. [17] - Move location of bsd.autotools.mk within bsd.port.mk [18] - Add bsd.linux-rpm.mk, fix INSTALLS_SHLIB for Linux ports [19] - Use new USE_RC_SUBR format for FreeBSD version >= 700007 [20] - Replace the string "FreeBSD" by "The FreeBSD Project" in the security warning [21] - Add bsd.local.mk for local modification to ports framework. [22] - Replace rcNG spelling by rc.d [23] - Remove superfluous USE_REINPLACE. [24] Special thanks to: linimon for spending hours with all these patches clement for fixes kris for help with pointyhat PR: ports/86310 [1], ports/89498 [2], ports/83530 [3], ports/83789 [4], ports/84053 [5], ports/86281 [6], ports/87214 [7], ports/87234 [8], ports/87318 [9], ports/87396 [10], ports/87605 [11], ports/87840 [12], ports/88230 [13], ports/88493 [14], ports/88711 [15], ports/88751 [16], ports/89281 [17], ports/89999 [18], ports/90031 [19], ports/90150 [20], ports/90668 [21], ports/91433 [23], ports/88754 [24] Submitted by: mi [1], marcus [2], Lars Engels <lars.engels@0x20.net> [3], pav [4, 16, 20, 24], garga [5], cperciva [6], vd [7], edwin [8, 9, 11, 15, 21], fenner [10], Arseny Nasokin <tarc.po.cs.msu.su@tarc.po.cs.msu.su> [12], Carl Makin <carl@stagecraft.cx> [13], arved [14], NIIMI Satoshi <sa2c@sa2c.net> [17], thierry [18], jylefort [19], linimon [22], dougb [23]
Diffstat (limited to 'mail/vpopmail-devel')
-rw-r--r--mail/vpopmail-devel/Makefile26
-rw-r--r--mail/vpopmail-devel/pkg-plist4
2 files changed, 13 insertions, 17 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
index e4dab9ec5028..baefa5e5f2c1 100644
--- a/mail/vpopmail-devel/Makefile
+++ b/mail/vpopmail-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vpopmail
PORTVERSION= 5.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,23 +16,22 @@ PKGNAMESUFFIX= -devel
MAINTAINER= ale@FreeBSD.org
COMMENT= Easy virtual domain and authentication package for use with qmail
-BUILD_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
- ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
-RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
- ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
+BUILD_DEPENDS= ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
+RUN_DEPENDS= ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
+USE_QMAIL= yes
CONFLICTS= vpopmail-5.*
GNU_CONFIGURE= YES
USE_GMAKE= YES
USE_REINPLACE= YES
-USE_PERL5_BUILD= YES
+USE_PERL5= YES
VCFGDIR?= ${WRKDIR}/vcfg
VCFGFILES?= inc_deps lib_deps tcp.smtp
CONFIGURE_ENV+= VCFGDIR="${VCFGDIR}"
-CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
+CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_PREFIX} \
--enable-tcprules-prog=${LOCALBASE}/bin/tcprules \
--enable-tcpserver-file=${PREFIX}/vpopmail/etc/tcp.smtp
@@ -74,7 +73,7 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
# WITHOUT_AUTH_LOG - disables authentication logging
# WITH_MYSQL_LOG - enable logging to a MySQL database
# WITH_PGSQL_LOG - enable logging to a PostgreSQL database
-# QMAIL_DIR - location of qmail directory
+# QMAIL_PREFIX - location of qmail directory
# PREFIX - installation area for vpopmail (see comment below)
# VCHKPW_GID - the group ID of the new vchkpw group (89)
# VPOPMAIL_UID - the user ID of the new vpopmail user (89)
@@ -170,12 +169,6 @@ CONFIGURE_ARGS+= --enable-pgsql-logging
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/qmail/bin/qmail-send)
-QMAIL_DIR?= ${LOCALBASE}/qmail
-.else
-QMAIL_DIR?= /var/qmail
-.endif
-
# Uncomment this, or set PREFIX to /home if you have an existing
# vpopmail install with the vpopmail users' home directory set to
# /home/vpopmail - package rules dictate we default to /usr/local/vpopmail
@@ -327,10 +320,11 @@ post-install:
${MKDIR} ${PREFIX}/vpopmail/etc
if [ ! -e "${PREFIX}/vpopmail/etc/tcp.smtp" ]; then \
if [ -e "${VCFGDIR}/tcp.smtp" ]; then \
- ${INSTALL_DATA} ${VCFGDIR}/tcp.smtp ${PREFIX}/vpopmail/etc/; \
+ ${INSTALL_DATA} ${VCFGDIR}/tcp.smtp ${PREFIX}/vpopmail/etc/tcp.smtp-dist; \
else \
- ${TOUCH} ${PREFIX}/vpopmail/etc/tcp.smtp; \
+ ${TOUCH} ${PREFIX}/vpopmail/etc/tcp.smtp-dist; \
fi; \
+ ${CP} -p ${PREFIX}/vpopmail/etc/tcp.smtp-dist ${PREFIX}/vpopmail/etc/tcp.smtp; \
fi
.if defined(DEFAULT_DOMAIN)
${ECHO_CMD} ${DEFAULT_DOMAIN} > ${PREFIX}/vpopmail/etc/defaultdomain
diff --git a/mail/vpopmail-devel/pkg-plist b/mail/vpopmail-devel/pkg-plist
index 2f113a2e8d2d..98ff8626c947 100644
--- a/mail/vpopmail-devel/pkg-plist
+++ b/mail/vpopmail-devel/pkg-plist
@@ -41,7 +41,9 @@ vpopmail/doc/man_html/vsetuserquota.html
@unexec if [ -f %D/vpopmail/etc/defaultdomain ]; then rm -f %D/vpopmail/etc/defaultdomain; fi
vpopmail/etc/inc_deps
vpopmail/etc/lib_deps
-@unexec if [ -f %D/vpopmail/etc/tcp.smtp -a ! -s %D/vpopmail/etc/tcp.smtp ]; then rm -f %D/vpopmail/etc/tcp.smtp; fi
+@unexec if cmp -s %D/vpopmail/etc/tcp.smtp %D/vpopmail/etc/tcp.smtp-dist; then rm -f %D/vpopmail/etc/tcp.smtp; fi
+vpopmail/etc/tcp.smtp-dist
+@exec if [ ! -f %D/vpopmail/etc/tcp.smtp ] ; then cp -p %D/%F %B/tcp.smtp; fi
@unexec if cmp -s %D/vpopmail/etc/vlimits.default %D/vpopmail/etc/vlimits.default-dist; then rm -f %D/vpopmail/etc/vlimits.default; fi
vpopmail/etc/vlimits.default-dist
@unexec if [ -f %D/vpopmail/etc/vpopmail.mysql ]; then rm -f %D/vpopmail/etc/vpopmail.mysql; fi