aboutsummaryrefslogtreecommitdiffstats
path: root/mail/x-face-e21
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2018-02-02 02:03:09 +0800
committerjrm <jrm@FreeBSD.org>2018-02-02 02:03:09 +0800
commit8e8d43ac5d573ba0718403b8beae8b36fa9baf37 (patch)
tree4a6b8513515fb032f2183d945863a1d39dbcd0c1 /mail/x-face-e21
parent48204ec74d19374b66c2d2475473f797a292c193 (diff)
downloadfreebsd-ports-gnome-8e8d43ac5d573ba0718403b8beae8b36fa9baf37.tar.gz
freebsd-ports-gnome-8e8d43ac5d573ba0718403b8beae8b36fa9baf37.tar.zst
freebsd-ports-gnome-8e8d43ac5d573ba0718403b8beae8b36fa9baf37.zip
Flavorize and modernize Emacs ports
- Convert USE_EMACS to USES=emacs - Remove editors/emacs-nox11 (refer to nox flavors of editors/emacs and editors/emacs-devel) - Permit default Emacs flavor to be specified in make.conf - Rename japanese/migemo-emacs23 to japanese/migemo-emacs - Update and simplify audio/emms and fix build on FreeBSD 10 [1] - Update databases/bbdd and fix build on FreeBSD 10 [1] - Update editors/emacs-devel - Ensure Makefile shell commands that change directory are executed in a subshell - Silence some portlint warnings [1] By not depending on base texinfo PR: 225404 Reviewed by: antoine Approved by: portmgr (mat) ashish (maintainer) Differential Revision: https://reviews.freebsd.org/D13506
Diffstat (limited to 'mail/x-face-e21')
-rw-r--r--mail/x-face-e21/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/mail/x-face-e21/Makefile b/mail/x-face-e21/Makefile
index d89e3081a664..4ea04e547211 100644
--- a/mail/x-face-e21/Makefile
+++ b/mail/x-face-e21/Makefile
@@ -3,21 +3,19 @@
PORTNAME= x-face-e21
PORTVERSION= 20070306
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= mail elisp
MASTER_SITES= http://www.jpl.org/elips/
-PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
DISTNAME= ${PORTNAME}.el
EXTRACT_SUFX= .gz
MAINTAINER= ume@FreeBSD.org
-COMMENT= X-Face utilities for Emacs 21 (and possibly 22)
+COMMENT= X-Face utilities for Emacs
RUN_DEPENDS= uncompface:mail/faces
-USE_EMACS= yes
-
-.include <bsd.port.pre.mk>
+USES= emacs
NO_WRKSUBDIR= yes
EXTRACT_CMD= ${GZCAT}
@@ -28,14 +26,14 @@ PLIST_FILES= ${EMACS_VERSION_SITE_LISPDIR}/${DISTNAME} \
${EMACS_VERSION_SITE_LISPDIR}/${DISTNAME}c
do-build:
- @cd ${WRKSRC} && ${EMACS_CMD} -batch -q -no-site-file -no-init-file \
- -f batch-byte-compile ${DISTNAME}
+ @(cd ${WRKSRC} && ${EMACS_CMD} -batch -q -no-site-file -no-init-file \
+ -f batch-byte-compile ${DISTNAME})
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
- @${INSTALL_DATA} ${WRKSRC}/${DISTNAME} \
+ ${INSTALL_DATA} ${WRKSRC}/${DISTNAME} \
${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
- @${INSTALL_DATA} ${WRKSRC}/${DISTNAME}c \
+ ${INSTALL_DATA} ${WRKSRC}/${DISTNAME}c \
${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>