aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-13 16:49:43 +0800
committermiwi <miwi@FreeBSD.org>2009-05-13 16:49:43 +0800
commit005c9e2a7947ba4ac4077c811052dcf8ccd1c8eb (patch)
treec28843c3cb6a5cccd08c7ee4a16ffb518f451205 /mail
parent0c0ffe6c1070703969940c202934d01139a77864 (diff)
downloadfreebsd-ports-gnome-005c9e2a7947ba4ac4077c811052dcf8ccd1c8eb.tar.gz
freebsd-ports-gnome-005c9e2a7947ba4ac4077c811052dcf8ccd1c8eb.tar.zst
freebsd-ports-gnome-005c9e2a7947ba4ac4077c811052dcf8ccd1c8eb.zip
- Update to 1.2.0, resetting PORTREVISION where set.
- use bsd.database.mk framework (USE_BDB/USE_SQLITE) - set MAKE_JOBS_SAFE for parallel builds PR: 134323 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/bogofilter-sqlite/Makefile2
-rw-r--r--mail/bogofilter-tc/Makefile1
-rw-r--r--mail/bogofilter/Makefile20
-rw-r--r--mail/bogofilter/distinfo6
-rw-r--r--mail/bogofilter/files/patch-src-tests-tframe8
5 files changed, 21 insertions, 16 deletions
diff --git a/mail/bogofilter-sqlite/Makefile b/mail/bogofilter-sqlite/Makefile
index 239b17dda982..6351f291fbf8 100644
--- a/mail/bogofilter-sqlite/Makefile
+++ b/mail/bogofilter-sqlite/Makefile
@@ -11,7 +11,7 @@ PKGNAMESUFFIX= -sqlite
MAINTAINER= matthias.andree@gmx.de
-LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
+USE_SQLITE= 3
CONFLICTS= bogofilter-[0-9]* bogofilter-qdbm-[0-9]* bogofilter-tc-[0-9]* [a-z][a-z]-bogofilter-[0-9]*
diff --git a/mail/bogofilter-tc/Makefile b/mail/bogofilter-tc/Makefile
index 8b2954931d4c..d2d3a2f6510b 100644
--- a/mail/bogofilter-tc/Makefile
+++ b/mail/bogofilter-tc/Makefile
@@ -6,7 +6,6 @@
#
PORTNAME= bogofilter
-PORTREVISION= 5
CATEGORIES= mail
PKGNAMESUFFIX= -tc
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 4e22ab0d4dd4..8622241bce59 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= bogofilter
-PORTVERSION= 1.1.7
-PORTREVISION?= 2
+PORTVERSION= 1.2.0
+PORTREVISION?= 0
CATEGORIES?= mail
MASTER_SITES= SF
MAINTAINER?= matthias.andree@gmx.de
COMMENT= Fast, teachable, learning spam detector
-# cannot switch to USE_BDB here, as we want slave ports
-# to override this easily
-LIB_DEPENDS?= db-4.3:${PORTSDIR}/databases/db43
+.if !defined(MASTERDIR) || ${MASTERDIR} == ${.CURDIR}
+# building master port
+USE_BDB= 41+
+.endif
OPTIONS= GSL "Link with system-wide GSL dynamically (recommended)" on
OPTIONS+= UNICODE "Normalize tokens to Unicode (UTF-8)" on
@@ -27,15 +28,12 @@ USE_BZIP2= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
PATCH_STRIP= -p1
+MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Fails to install on sparc64
-.endif
-
-BF_LIBS?= -ldb-4.3
-BF_CPPFLAGS?= -I${LOCALBASE}/include/db43 -I${LOCALBASE}/include
+BF_LIBS?= -l${BDB_LIB_NAME}
+BF_CPPFLAGS?= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
.if !defined(WITHOUT_UNICODE)
CONFIGURE_ARGS+= --enable-unicode
diff --git a/mail/bogofilter/distinfo b/mail/bogofilter/distinfo
index e5fb4e6a6ba6..af481a9942e3 100644
--- a/mail/bogofilter/distinfo
+++ b/mail/bogofilter/distinfo
@@ -1,3 +1,3 @@
-MD5 (bogofilter-1.1.7.tar.bz2) = 0ece697e8b54fcc069dba1af55c6015a
-SHA256 (bogofilter-1.1.7.tar.bz2) = d56a9236cc422309b0419d65a8676c923002993b1d64efae94deecb4fb1d112a
-SIZE (bogofilter-1.1.7.tar.bz2) = 839687
+MD5 (bogofilter-1.2.0.tar.bz2) = ed1a0a4609fa0c7dc1cddba1b9d37067
+SHA256 (bogofilter-1.2.0.tar.bz2) = 208fc5f156c2cf3ea4dcfe9fdebe5aaea8b648bbd5e1ee49f45c4c84d8652e7c
+SIZE (bogofilter-1.2.0.tar.bz2) = 885463
diff --git a/mail/bogofilter/files/patch-src-tests-tframe b/mail/bogofilter/files/patch-src-tests-tframe
new file mode 100644
index 000000000000..e59e1b488cbd
--- /dev/null
+++ b/mail/bogofilter/files/patch-src-tests-tframe
@@ -0,0 +1,8 @@
+--- ./src/tests/t.frame
++++ ./src/tests/t.frame
+@@ -41,4 +41,4 @@
+ # Obtain data base file suffix
+-DB_NAME=$("$BOGOFILTER" -C -V 2>&1 | sed -n '/Database:/ { p;q }')
++DB_NAME=$("$BOGOFILTER" -C -V 2>&1 | sed -n '/Database:/ {p;q;}')
+ case $DB_NAME in
+ *BerkeleyDB*|*"Berkeley DB"*)