aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-23 04:06:14 +0800
committermakc <makc@FreeBSD.org>2013-03-23 04:06:14 +0800
commit071186fd6d22f1abd16554cae92bf26af9d1cb4e (patch)
treeb368198f913179c06dafd19ac72527fcf9836f6d /mail
parenteda1ae8e7cf50659cf0b55fefdcae532e6ad0405 (diff)
downloadfreebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.tar.gz
freebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.tar.zst
freebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.zip
- convert USE_CMAKE to USES
- while here clean up some ports from CMAKE_VERBOSE, which is intended for users Approved by: portmgr (miwi)
Diffstat (limited to 'mail')
-rw-r--r--mail/kbiff/Makefile2
-rw-r--r--mail/kshowmail/Makefile2
-rw-r--r--mail/rspamd/Makefile2
-rw-r--r--mail/spmfilter-clamav/Makefile2
-rw-r--r--mail/spmfilter-spamassassin/Makefile2
-rw-r--r--mail/spmfilter/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/mail/kbiff/Makefile b/mail/kbiff/Makefile
index 97c3ab757730..a2b7a4ebf175 100644
--- a/mail/kbiff/Makefile
+++ b/mail/kbiff/Makefile
@@ -22,7 +22,7 @@ USE_QT4= corelib dbus gui network svg xml \
qmake_build uic_build rcc_build
USE_PERL5_BUILD=yes
USE_GETTEXT= yes
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
MAN1= kbiff.1
diff --git a/mail/kshowmail/Makefile b/mail/kshowmail/Makefile
index edd722cf144d..c374556a3522 100644
--- a/mail/kshowmail/Makefile
+++ b/mail/kshowmail/Makefile
@@ -20,7 +20,7 @@ USE_QT4= corelib dbus gui network svg xml \
qmake_build uic_build rcc_build
USE_PERL5_BUILD=yes
USE_GETTEXT= yes
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/mail/rspamd/Makefile b/mail/rspamd/Makefile
index 6489fd6d6748..6ffe79e58ffa 100644
--- a/mail/rspamd/Makefile
+++ b/mail/rspamd/Makefile
@@ -25,7 +25,7 @@ PLIST_SUB+= ETCDIR=etc/rspamd \
CMAKE_ARGS+= -DETC_PREFIX=${PREFIX}/etc -DPREFIX=${PREFIX} \
-DBUILD_PORT=yes
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
USE_GNOME= glib20
diff --git a/mail/spmfilter-clamav/Makefile b/mail/spmfilter-clamav/Makefile
index 2f4e08cd7326..ef5468510e14 100644
--- a/mail/spmfilter-clamav/Makefile
+++ b/mail/spmfilter-clamav/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= spmfilter>=0.4:${PORTSDIR}/mail/spmfilter
RUN_DEPENDS= spmfilter>=0.4:${PORTSDIR}/mail/spmfilter
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
-DCMAKE_LIBRARY_PATH="${LOCALBASE}/lib"
diff --git a/mail/spmfilter-spamassassin/Makefile b/mail/spmfilter-spamassassin/Makefile
index cab3c523d223..5f1de1fbacd5 100644
--- a/mail/spmfilter-spamassassin/Makefile
+++ b/mail/spmfilter-spamassassin/Makefile
@@ -17,7 +17,7 @@ COMMENT= Spamassassin plugin for spmfilter
BUILD_DEPENDS= spmfilter>=0.4:${PORTSDIR}/mail/spmfilter
RUN_DEPENDS= spmfilter>=0.4:${PORTSDIR}/mail/spmfilter
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
-DCMAKE_LIBRARY_PATH="${LOCALBASE}/lib"
diff --git a/mail/spmfilter/Makefile b/mail/spmfilter/Makefile
index a466eee109cc..4f9b57579d98 100644
--- a/mail/spmfilter/Makefile
+++ b/mail/spmfilter/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= gmime-24>=2.4:${PORTSDIR}/mail/gmime24 \
LICENSE= LGPL3
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
-DCMAKE_LIBRARY_PATH="${LOCALBASE}/lib"
USE_PKGCONFIG= build