aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-19 20:40:53 +0800
committertijl <tijl@FreeBSD.org>2014-09-19 20:40:53 +0800
commit0796737af5636350e29f441beb16a8e1dda95f06 (patch)
treebe003283f4d6d47d28fc77ec937cea8ca2403ca2 /mail
parent6fca896f0c9812f95c685a45806d5b28f418854f (diff)
downloadfreebsd-ports-gnome-0796737af5636350e29f441beb16a8e1dda95f06.tar.gz
freebsd-ports-gnome-0796737af5636350e29f441beb16a8e1dda95f06.tar.zst
freebsd-ports-gnome-0796737af5636350e29f441beb16a8e1dda95f06.zip
- Drop dependency on autoconf and automake
- Use correct form of OPTIONS_SUB - Remove FreeBSD 7 support - Remove post-deinstall (handled by pkg)
Diffstat (limited to 'mail')
-rw-r--r--mail/opensmtpd/Makefile16
1 files changed, 2 insertions, 14 deletions
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index a0be309f12ea..500f3c57833c 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -24,7 +24,7 @@ OPTIONS_DEFAULT= CA_BUNDLE PAM
CA_BUNDLE_DESC= Install CA bundle for OpenSSL
USES= libtool
-USE_AUTOTOOLS= autoconf:env automake:env
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libevent-dir=${LOCALBASE} --sysconfdir=${PREFIX}/etc/mail/ \
--with-mailwrapper
@@ -37,7 +37,7 @@ CONFLICTS_INSTALL= postfix-[0-9]* sendmail-[0-9]* opensmtpd-devel-[0-9]*
USERS= _smtpd _smtpq
GROUPS= _smtpd
-OPTIONS_SUB= MYSQL SQLITE PGSQL LDAP REDIS
+OPTIONS_SUB= yes
CA_BUNDLE_CONFIGURE_ON= --with-ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
@@ -62,16 +62,4 @@ PAM_CONFIGURE_ON= --with-pam --with-pam-service=smtpd
REDIS_LIB_DEPENDS= libhiredis.so:${PORTSDIR}/databases/hiredis
REDIS_CONFIGURE_ON= --with-experimental-redis
-.include <bsd.port.options.mk>
-
-USE_OPENSSL= yes
-
-# FreeBSD 7.3 and earlier need to use OpenSSL from ports
-.if ${OSVERSION} < 704000
-WITH_OPENSSL_PORT= yes
-.endif
-
-post-deinstall:
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-DEINSTALL
-
.include <bsd.port.mk>