aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2003-08-23 03:27:55 +0800
committernbm <nbm@FreeBSD.org>2003-08-23 03:27:55 +0800
commit1176c7b79c4bdfda360ca9a157972fadb6c7e2a7 (patch)
tree1545dd92e6730152ebb12c1008382bfa85e49fd7 /mail
parent877fe5c1a8bded4e0d10bc5143231563cfbef5a8 (diff)
downloadfreebsd-ports-gnome-1176c7b79c4bdfda360ca9a157972fadb6c7e2a7.tar.gz
freebsd-ports-gnome-1176c7b79c4bdfda360ca9a157972fadb6c7e2a7.tar.zst
freebsd-ports-gnome-1176c7b79c4bdfda360ca9a157972fadb6c7e2a7.zip
Add msmtp 0.4.2, an SMTP "plugin" for MUAs.
PR: 55877 Submitted by: R.I.Pienaar <rip@devco.net>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/msmtp/Makefile25
-rw-r--r--mail/msmtp/distinfo1
-rw-r--r--mail/msmtp/files/patch-aa37
-rw-r--r--mail/msmtp/pkg-descr18
-rw-r--r--mail/msmtp/pkg-plist1
6 files changed, 83 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index ce105201cd93..0a6a2b8b54a4 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -158,6 +158,7 @@
SUBDIR += movemail
SUBDIR += mreport
SUBDIR += msgconvert
+ SUBDIR += msmtp
SUBDIR += mulberry
SUBDIR += mutt
SUBDIR += mutt-devel
diff --git a/mail/msmtp/Makefile b/mail/msmtp/Makefile
new file mode 100644
index 000000000000..bf65b15b4d94
--- /dev/null
+++ b/mail/msmtp/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: msmtp
+# Date created: 22 Aug 2003
+# Whom: R.I.Pienaar <rip@devco.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= msmtp
+PORTVERSION= 0.4.2
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= msmtp
+
+MAINTAINER= rip@devco.net
+COMMENT= SMTP \"plugin\" for MUAs
+
+USE_GETOPT_LONG= yes
+
+MAN1= msmtp.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/msmtp ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/msmtp.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/mail/msmtp/distinfo b/mail/msmtp/distinfo
new file mode 100644
index 000000000000..f5a03795fed9
--- /dev/null
+++ b/mail/msmtp/distinfo
@@ -0,0 +1 @@
+MD5 (msmtp-0.4.2.tar.gz) = 050b077df6f5dca3067f34c8069744df
diff --git a/mail/msmtp/files/patch-aa b/mail/msmtp/files/patch-aa
new file mode 100644
index 000000000000..1b3eb4e9b22a
--- /dev/null
+++ b/mail/msmtp/files/patch-aa
@@ -0,0 +1,37 @@
+*** Makefile.orig Thu Aug 21 22:28:13 2003
+--- Makefile Thu Aug 21 22:28:44 2003
+***************
+*** 3,18 ****
+ #
+
+ # GNU/Linux and GNU/Hurd
+- CC = gcc
+- CFLAGS = -DHAVE_VASPRINTF -DHAVE_GETOPT_LONG -D_GNU_SOURCE -Wall -O2
+- LFLAGS = -lssl -lcrypto -s
+- EXTRAOBJS =
+-
+- # FreeBSD, NetBSD, OpenBSD
+ #CC = gcc
+! #CFLAGS = -DHAVE_VASPRINTF -DHAVE_GETOPT_LONG -Wall -O2
+ #LFLAGS = -lssl -lcrypto -s
+ #EXTRAOBJS =
+
+ # SunOS
+ #CC = cc
+--- 3,18 ----
+ #
+
+ # GNU/Linux and GNU/Hurd
+ #CC = gcc
+! #CFLAGS = -DHAVE_VASPRINTF -DHAVE_GETOPT_LONG -D_GNU_SOURCE -Wall -O2
+ #LFLAGS = -lssl -lcrypto -s
+ #EXTRAOBJS =
++
++ # FreeBSD, NetBSD, OpenBSD
++ CC = gcc
++ CFLAGS = -DHAVE_VASPRINTF -DHAVE_GETOPT_LONG -Wall -O2 -I${LOCALBASE}/include
++ LFLAGS = -lssl -lcrypto -s -L${LOCALBASE}/lib
++ EXTRAOBJS = getopt.o getopt1.o
+
+ # SunOS
+ #CC = cc
diff --git a/mail/msmtp/pkg-descr b/mail/msmtp/pkg-descr
new file mode 100644
index 000000000000..1267b722b24b
--- /dev/null
+++ b/mail/msmtp/pkg-descr
@@ -0,0 +1,18 @@
+msmtp -- SMTP plugin for MUAs
+
+This is a simple program that works as an "SMTP plugin" for Mutt and probably
+other MUAs (mail user agents). msmtp forwards mails to an SMTP server (for
+example at a free mail provider) which does the delivery.
+
+Features include:
+ * SMTP AUTH methods PLAIN, LOGIN and CRAM-MD5
+ * TLS encrypted connections
+ * IPv6 support
+ * robustness
+ * detailed error messages (including the full answer of the SMTP server)
+ if something goes wrong
+ * sendmail compatible exit codes (which most MUAs understand).
+
+Simply tell your MUA to call msmtp instead of /usr/sbin/sendmail
+
+WWW: http://msmtp.sourceforge.net/
diff --git a/mail/msmtp/pkg-plist b/mail/msmtp/pkg-plist
new file mode 100644
index 000000000000..7444eda35175
--- /dev/null
+++ b/mail/msmtp/pkg-plist
@@ -0,0 +1 @@
+bin/msmtp