aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-11-08 22:18:06 +0800
committertobik <tobik@FreeBSD.org>2019-11-08 22:18:06 +0800
commit1308ca305603557ab483f9a100dc1d36a2f79b76 (patch)
treef1c1efa2a199bb84af5a7902b25a8716e4db90e0 /mail
parent73ed45b6eda6efde67df120b977292b5af9fcf21 (diff)
downloadfreebsd-ports-gnome-1308ca305603557ab483f9a100dc1d36a2f79b76.tar.gz
freebsd-ports-gnome-1308ca305603557ab483f9a100dc1d36a2f79b76.tar.zst
freebsd-ports-gnome-1308ca305603557ab483f9a100dc1d36a2f79b76.zip
mail: Add missing USES={gnome,php}
Diffstat (limited to 'mail')
-rw-r--r--mail/balsa/Makefile4
-rw-r--r--mail/claws-mail-python/Makefile1
-rw-r--r--mail/cone/Makefile5
-rw-r--r--mail/gmime2/Makefile3
-rw-r--r--mail/gmime24-sharp/Makefile2
-rw-r--r--mail/gmime24/Makefile3
-rw-r--r--mail/gmime30/Makefile3
-rw-r--r--mail/gnubiff/Makefile2
-rw-r--r--mail/horde-ingo/Makefile2
-rw-r--r--mail/horde-turba/Makefile2
-rw-r--r--mail/masqmail/Makefile2
-rw-r--r--mail/pear-Horde_Imap_Client/Makefile2
-rw-r--r--mail/pear-Horde_Kolab_Storage/Makefile2
-rw-r--r--mail/pear-Horde_Mapi/Makefile2
-rw-r--r--mail/pear-Horde_Mime_Viewer/Makefile2
-rw-r--r--mail/policyd2/Makefile3
-rw-r--r--mail/rmilter/Makefile2
-rw-r--r--mail/sylpheed/Makefile4
-rw-r--r--mail/trojita/Makefile4
19 files changed, 29 insertions, 21 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index 32de32011d53..c98c8f54021d 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -22,8 +22,8 @@ RUN_DEPENDS= gnome-keyring:security/gnome-keyring
# Depends on gtkhtml4 (which is being abandonend). When our webkitgtk3
# in ports gets updated to > 1.10.x, balsa should depend on it.
-USES= desktop-file-utils gettext gmake iconv pathfix \
- perl5 pkgconfig tar:bzip2 ssl
+USES= desktop-file-utils gettext gmake gnome iconv pathfix perl5 \
+ pkgconfig ssl tar:bzip2
USE_GNOME= gnomeprefix gtkhtml4 intlhack libxslt
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/mail/claws-mail-python/Makefile b/mail/claws-mail-python/Makefile
index 830ac7c83c44..127ae19ef3cd 100644
--- a/mail/claws-mail-python/Makefile
+++ b/mail/claws-mail-python/Makefile
@@ -6,6 +6,7 @@ PORTREVISION= 0
COMMENT= Python scripting plugin for Claws Mail
+USES+= gnome
USE_GNOME= pygtk2
CLAWS_PLUGINS_BUILD= python
diff --git a/mail/cone/Makefile b/mail/cone/Makefile
index 1aef2aa8c7fe..dac5edc22fd7 100644
--- a/mail/cone/Makefile
+++ b/mail/cone/Makefile
@@ -23,8 +23,9 @@ LIB_DEPENDS= libaspell.so:textproc/aspell \
BUILD_DEPENDS= gpgv:security/gnupg1
RUN_DEPENDS= gpgv:security/gnupg1
-USES= compiler:c++11-lang fam gettext gmake iconv localbase:ldflags \
- ncurses perl5 pkgconfig shebangfix ssl tar:bzip2
+USES= compiler:c++11-lang fam gettext gmake gnome iconv \
+ localbase:ldflags ncurses perl5 pkgconfig shebangfix ssl \
+ tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-certdb=${PREFIX}/share/cone/rootcerts --exec-prefix=${PREFIX} \
--with-notice=unicode
diff --git a/mail/gmime2/Makefile b/mail/gmime2/Makefile
index d9fefa62b8b3..9dfa9e8e5870 100644
--- a/mail/gmime2/Makefile
+++ b/mail/gmime2/Makefile
@@ -19,8 +19,9 @@ CONFLICTS= gmime-1.0.* gmime-2.4.*
SLAVEDIRS= mail/gmime2-sharp
USE_GNOME?= glib20
-USES+= gmake iconv libtool pathfix pkgconfig
+USES+= gmake gnome iconv libtool pathfix pkgconfig
USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
# www.freebsd.org/cgi/query-pr.cgi?pr=118092
# Rename uudecode and uuencode to gmime-* to not conflict with userland
diff --git a/mail/gmime24-sharp/Makefile b/mail/gmime24-sharp/Makefile
index 4e7307ddf775..d5808f5f365c 100644
--- a/mail/gmime24-sharp/Makefile
+++ b/mail/gmime24-sharp/Makefile
@@ -16,7 +16,7 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
-USES= mono
+USES= gnome mono
USE_GNOME= glib20 gtksharp20
CONFIGURE_ARGS= --enable-mono=yes
diff --git a/mail/gmime24/Makefile b/mail/gmime24/Makefile
index b0a68050c503..cca1b23d76c4 100644
--- a/mail/gmime24/Makefile
+++ b/mail/gmime24/Makefile
@@ -18,9 +18,10 @@ CONFLICTS= gmime-1.0.*
SLAVEDIRS= mail/gmime2-sharp
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}24
-USES+= gmake iconv libtool pathfix pkgconfig tar:xz
+USES+= gmake gnome iconv libtool pathfix pkgconfig tar:xz
USE_GNOME?= glib20
USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
# www.freebsd.org/cgi/query-pr.cgi?pr=118092
# Rename uudecode and uuencode to gmime-* to not conflict with userland
diff --git a/mail/gmime30/Makefile b/mail/gmime30/Makefile
index a6892faf3c34..2afc165a0d56 100644
--- a/mail/gmime30/Makefile
+++ b/mail/gmime30/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS= libgpgme.so:security/gpgme \
libgpg-error.so:security/libgpg-error
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}30
-USES= gettext-runtime gmake iconv libtool localbase pathfix pkgconfig tar:xz
+USES= gettext-runtime gmake gnome iconv libtool localbase pathfix \
+ pkgconfig tar:xz
USE_GNOME= glib20 introspection:build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/mail/gnubiff/Makefile b/mail/gnubiff/Makefile
index 0e4365d0da9f..62cd0927e53b 100644
--- a/mail/gnubiff/Makefile
+++ b/mail/gnubiff/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libpopt.so:devel/popt
OPTIONS_DEFINE= NLS
-USES= compiler:c++11-lang cpe fam gmake pathfix pkgconfig
+USES= compiler:c++11-lang cpe fam gmake gnome pathfix pkgconfig
USE_GNOME= intlhack libglade2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/mail/horde-ingo/Makefile b/mail/horde-ingo/Makefile
index 8cfee583c37d..1e0098614903 100644
--- a/mail/horde-ingo/Makefile
+++ b/mail/horde-ingo/Makefile
@@ -11,7 +11,7 @@ COMMENT= Horde email filter rules manager
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= horde cpe
+USES= cpe horde php
USE_PHP= gettext
USE_HORDE_BUILD= Horde_Role
USE_HORDE_RUN= Horde_Role \
diff --git a/mail/horde-turba/Makefile b/mail/horde-turba/Makefile
index 7b68bbdc2bab..f37a69c6ad1f 100644
--- a/mail/horde-turba/Makefile
+++ b/mail/horde-turba/Makefile
@@ -16,7 +16,7 @@ FACEBOOK_DESC= Support connections with Facebook
IMSP_DSC= Support IMSP addressbooks
LDAP_DESC= Support LDAP Addressbooks
-USES= horde cpe
+USES= cpe horde php
USE_PHP= gettext hash json
USE_HORDE_BUILD= Horde_Role
USE_HORDE_RUN= Horde_Role \
diff --git a/mail/masqmail/Makefile b/mail/masqmail/Makefile
index 8fffd44325c9..48619970f97c 100644
--- a/mail/masqmail/Makefile
+++ b/mail/masqmail/Makefile
@@ -12,7 +12,7 @@ COMMENT= Mail server for hosts, not permanently connected to the internet
LICENSE= GPLv2
USE_GNOME= glib20
-USES= pkgconfig
+USES= gnome pkgconfig
USE_RC_SUBR= masqmail
GNU_CONFIGURE= yes
CFLAGS+= -Wno-trigraphs
diff --git a/mail/pear-Horde_Imap_Client/Makefile b/mail/pear-Horde_Imap_Client/Makefile
index 864aa0a09960..ff9bfc1ef66f 100644
--- a/mail/pear-Horde_Imap_Client/Makefile
+++ b/mail/pear-Horde_Imap_Client/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= ${PEAR_PKGNAMEPREFIX}
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde IMAP abstraction interface
-USES= horde
+USES= horde php
USE_PHP= hash
USE_HORDE_RUN= Horde_Exception \
Horde_Mail \
diff --git a/mail/pear-Horde_Kolab_Storage/Makefile b/mail/pear-Horde_Kolab_Storage/Makefile
index a4371cce2f78..7af8120c7548 100644
--- a/mail/pear-Horde_Kolab_Storage/Makefile
+++ b/mail/pear-Horde_Kolab_Storage/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= mail www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde library for handling Kolab data stored on an IMAP server
-USES= horde
+USES= horde php
USE_HORDE_RUN= Horde_Cache \
Horde_Exception \
Horde_Kolab_Format \
diff --git a/mail/pear-Horde_Mapi/Makefile b/mail/pear-Horde_Mapi/Makefile
index 74c82b1b80bb..b717fabc065d 100644
--- a/mail/pear-Horde_Mapi/Makefile
+++ b/mail/pear-Horde_Mapi/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= ${PEAR_PKGNAMEPREFIX}
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde MAPI utility library
-USES= horde
+USES= horde php
USE_HORDE_RUN= Horde_Date \
Horde_Exception
diff --git a/mail/pear-Horde_Mime_Viewer/Makefile b/mail/pear-Horde_Mime_Viewer/Makefile
index 8fa468dae6c2..c4eb79341f4f 100644
--- a/mail/pear-Horde_Mime_Viewer/Makefile
+++ b/mail/pear-Horde_Mime_Viewer/Makefile
@@ -12,7 +12,7 @@ CONFLICTS= horde-3*
USE_HORDE_BUILD= Horde_Role
-USES= horde
+USES= horde php
USE_HORDE_RUN= Horde_Role \
Horde_Browser \
Horde_Compress \
diff --git a/mail/policyd2/Makefile b/mail/policyd2/Makefile
index 599d76d131de..42f3485150e2 100644
--- a/mail/policyd2/Makefile
+++ b/mail/policyd2/Makefile
@@ -47,12 +47,15 @@ PGSQL_RUN_DEPENDS= p5-DBD-Pg>=0:databases/p5-DBD-Pg
.if ${PORT_OPTIONS:MWEBUI}
. if ${PORT_OPTIONS:MMYSQL}
+USES+= php
USE_PHP= pdo_mysql
. endif
. if ${PORT_OPTIONS:MSQLITE}
+USES+= php
USE_PHP= pdo_sqlite
. endif
. if ${PORT_OPTIONS:MPGSQL}
+USES+= php
USE_PHP= pdo_pgsql
. endif
.endif
diff --git a/mail/rmilter/Makefile b/mail/rmilter/Makefile
index b22e42b803d1..3890d0c30adb 100644
--- a/mail/rmilter/Makefile
+++ b/mail/rmilter/Makefile
@@ -17,7 +17,7 @@ NOT_FOR_ARCHS_REASON= fails to compile: error: Unsupported word size
USE_GITHUB= yes
GH_ACCOUNT= vstakhov
-USES= cmake compiler:c11 bison pkgconfig ssl
+USES= bison cmake compiler:c11 gnome pkgconfig ssl
USE_GNOME= glib20
USERS= _rmilter
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 1dbd209dd03d..936ff2837b23 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -18,8 +18,8 @@ RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:misc/mime-support
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= gettext iconv gmake pkgconfig tar:bzip2 desktop-file-utils \
- libtool
+USES= desktop-file-utils gettext gmake gnome iconv libtool pkgconfig \
+ tar:bzip2
USE_GNOME= gtk20 cairo gdkpixbuf2
USE_LDCONFIG= yes
diff --git a/mail/trojita/Makefile b/mail/trojita/Makefile
index 1aae2c5e5628..794641434ebe 100644
--- a/mail/trojita/Makefile
+++ b/mail/trojita/Makefile
@@ -25,8 +25,8 @@ CMAKE_ARGS+= -DWITH_CLEARTEXT_PLUGIN:STRING=ON -DWITH_DBUS:STRING=ON \
-DWITH_SHARED_PLUGINS:STRING=ON -DWITH_TESTS:STRING=OFF \
-DWITH_ZLIB:STRING=ON \
-DWITH_QT5:STRING=ON
-USES= cmake compiler:c++11-lib cpe desktop-file-utils localbase:ldflags \
- qt:5 tar:xz
+USES= cmake compiler:c++11-lib cpe desktop-file-utils gnome \
+ localbase:ldflags qt:5 tar:xz
USE_QT= buildtools_build linguisttools_build qmake_build \
core dbus gui network sql sql-sqlite3 svg webkit widgets