aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjoneum <joneum@FreeBSD.org>2018-05-31 22:05:05 +0800
committerjoneum <joneum@FreeBSD.org>2018-05-31 22:05:05 +0800
commit1430c6a49804012bbba4f9304b6242157030ee53 (patch)
tree4c548d91909636be71ef50420611d7f3dc2a4022 /mail
parent6c20ffb6b9145e2bdcffb57c66ed107ccf3e035d (diff)
downloadfreebsd-ports-gnome-1430c6a49804012bbba4f9304b6242157030ee53.tar.gz
freebsd-ports-gnome-1430c6a49804012bbba4f9304b6242157030ee53.tar.zst
freebsd-ports-gnome-1430c6a49804012bbba4f9304b6242157030ee53.zip
Add mail/phpmailer6
PHP email transport class featuring multiple file attachments, SMTP servers, CCs, BCCs, HTML messages, and word wrap, and more. It can send email via sendmail, PHP mail(), or with SMTP. Methods are based on the popular AspEmail active server component.
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/phpmailer6/Makefile43
-rw-r--r--mail/phpmailer6/distinfo3
-rw-r--r--mail/phpmailer6/files/pkg-message.in6
-rw-r--r--mail/phpmailer6/pkg-descr6
-rw-r--r--mail/phpmailer6/pkg-plist52
6 files changed, 111 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 588548fa77f5..ba10dcce217a 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -496,6 +496,7 @@
SUBDIR += php72-imap
SUBDIR += phplist
SUBDIR += phpmailer
+ SUBDIR += phpmailer6
SUBDIR += pine-pgp-filters
SUBDIR += pm-lib
SUBDIR += policyd2
diff --git a/mail/phpmailer6/Makefile b/mail/phpmailer6/Makefile
new file mode 100644
index 000000000000..ced9efb8bed3
--- /dev/null
+++ b/mail/phpmailer6/Makefile
@@ -0,0 +1,43 @@
+# $FreeBSD$
+
+PORTNAME= phpmailer
+PORTVERSION= 6.0.5
+DISTVERSIONPREFIX= v
+CATEGORIES= mail
+PKGNAMESUFFIX= 6
+
+MAINTAINER= joneum@FreeBSD.org
+COMMENT= Full Featured Email Transfer Class for PHP
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+CONFLICTS_INSTALL= phpmailer
+
+PORTSCOUT= limit:^6\.
+
+USES= cpe php
+CPE_VENDOR= phpmailer_project
+
+USE_GITHUB= yes
+GH_ACCOUNT= PHPMailer
+GH_PROJECT= PHPMailer
+
+NO_BUILD= yes
+NO_ARCH= yes
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+.for f in Exception.php PHPMailer.php POP3.php SMTP.php
+ ${INSTALL_DATA} ${WRKSRC}/src/$f ${STAGEDIR}${DATADIR}
+.endfor
+
+post-install-NLS-on:
+ @${MKDIR} ${STAGEDIR}${DATADIR}/language
+ ${INSTALL_DATA} ${WRKSRC}/language/* ${STAGEDIR}${DATADIR}/language
+
+.include <bsd.port.mk>
diff --git a/mail/phpmailer6/distinfo b/mail/phpmailer6/distinfo
new file mode 100644
index 000000000000..6235837281b9
--- /dev/null
+++ b/mail/phpmailer6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527709440
+SHA256 (PHPMailer-PHPMailer-v6.0.5_GH0.tar.gz) = 3b3148182b4f886c2c1eab1936a2c8d2f90f444e73bfbae265e3ed8e2738d21e
+SIZE (PHPMailer-PHPMailer-v6.0.5_GH0.tar.gz) = 88092
diff --git a/mail/phpmailer6/files/pkg-message.in b/mail/phpmailer6/files/pkg-message.in
new file mode 100644
index 000000000000..f1f66090b593
--- /dev/null
+++ b/mail/phpmailer6/files/pkg-message.in
@@ -0,0 +1,6 @@
+You need to adjust php's include_path to contain `%%DATADIR%%'!
+For example, insert
+
+ include_path = ".:%%DATADIR%%"
+
+into `%%LOCALBASE%%/etc/php.ini'.
diff --git a/mail/phpmailer6/pkg-descr b/mail/phpmailer6/pkg-descr
new file mode 100644
index 000000000000..99ef1cad3387
--- /dev/null
+++ b/mail/phpmailer6/pkg-descr
@@ -0,0 +1,6 @@
+PHP email transport class featuring multiple file attachments, SMTP
+servers, CCs, BCCs, HTML messages, and word wrap, and more. It can
+send email via sendmail, PHP mail(), or with SMTP. Methods are based
+on the popular AspEmail active server component.
+
+WWW: https://github.com/PHPMailer/PHPMailer
diff --git a/mail/phpmailer6/pkg-plist b/mail/phpmailer6/pkg-plist
new file mode 100644
index 000000000000..2499b049faf6
--- /dev/null
+++ b/mail/phpmailer6/pkg-plist
@@ -0,0 +1,52 @@
+%%DATADIR%%/Exception.php
+%%DATADIR%%/PHPMailer.php
+%%DATADIR%%/POP3.php
+%%DATADIR%%/SMTP.php
+%%DATADIR%%/language/phpmailer.lang-am.php
+%%DATADIR%%/language/phpmailer.lang-ar.php
+%%DATADIR%%/language/phpmailer.lang-az.php
+%%DATADIR%%/language/phpmailer.lang-ba.php
+%%DATADIR%%/language/phpmailer.lang-be.php
+%%DATADIR%%/language/phpmailer.lang-bg.php
+%%DATADIR%%/language/phpmailer.lang-ca.php
+%%DATADIR%%/language/phpmailer.lang-ch.php
+%%DATADIR%%/language/phpmailer.lang-cs.php
+%%DATADIR%%/language/phpmailer.lang-da.php
+%%DATADIR%%/language/phpmailer.lang-de.php
+%%DATADIR%%/language/phpmailer.lang-el.php
+%%DATADIR%%/language/phpmailer.lang-eo.php
+%%DATADIR%%/language/phpmailer.lang-es.php
+%%DATADIR%%/language/phpmailer.lang-et.php
+%%DATADIR%%/language/phpmailer.lang-fa.php
+%%DATADIR%%/language/phpmailer.lang-fi.php
+%%DATADIR%%/language/phpmailer.lang-fo.php
+%%DATADIR%%/language/phpmailer.lang-fr.php
+%%DATADIR%%/language/phpmailer.lang-gl.php
+%%DATADIR%%/language/phpmailer.lang-he.php
+%%DATADIR%%/language/phpmailer.lang-hi.php
+%%DATADIR%%/language/phpmailer.lang-hr.php
+%%DATADIR%%/language/phpmailer.lang-hu.php
+%%DATADIR%%/language/phpmailer.lang-id.php
+%%DATADIR%%/language/phpmailer.lang-it.php
+%%DATADIR%%/language/phpmailer.lang-ja.php
+%%DATADIR%%/language/phpmailer.lang-ka.php
+%%DATADIR%%/language/phpmailer.lang-ko.php
+%%DATADIR%%/language/phpmailer.lang-lt.php
+%%DATADIR%%/language/phpmailer.lang-lv.php
+%%DATADIR%%/language/phpmailer.lang-ms.php
+%%DATADIR%%/language/phpmailer.lang-nb.php
+%%DATADIR%%/language/phpmailer.lang-nl.php
+%%DATADIR%%/language/phpmailer.lang-pl.php
+%%DATADIR%%/language/phpmailer.lang-pt.php
+%%DATADIR%%/language/phpmailer.lang-pt_br.php
+%%DATADIR%%/language/phpmailer.lang-ro.php
+%%DATADIR%%/language/phpmailer.lang-rs.php
+%%DATADIR%%/language/phpmailer.lang-ru.php
+%%DATADIR%%/language/phpmailer.lang-sk.php
+%%DATADIR%%/language/phpmailer.lang-sl.php
+%%DATADIR%%/language/phpmailer.lang-sv.php
+%%DATADIR%%/language/phpmailer.lang-tr.php
+%%DATADIR%%/language/phpmailer.lang-uk.php
+%%DATADIR%%/language/phpmailer.lang-vi.php
+%%DATADIR%%/language/phpmailer.lang-zh.php
+%%DATADIR%%/language/phpmailer.lang-zh_cn.php