aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-05-28 06:27:52 +0800
committerclsung <clsung@FreeBSD.org>2006-05-28 06:27:52 +0800
commit1a5c053ee63d2c8ca00f7b41f2ac18e01abbcbcb (patch)
tree24f3b089e20be6165f01f155a369272ce84820e0 /mail
parent0ffc3d6d108a947709914594149c6b94d25bf331 (diff)
downloadfreebsd-ports-gnome-1a5c053ee63d2c8ca00f7b41f2ac18e01abbcbcb.tar.gz
freebsd-ports-gnome-1a5c053ee63d2c8ca00f7b41f2ac18e01abbcbcb.tar.zst
freebsd-ports-gnome-1a5c053ee63d2c8ca00f7b41f2ac18e01abbcbcb.zip
- It fixes the the C89 alignment issue encountered when compiling with
gcc-2.95 in addition to the dlerror() problem reported in ports/97671. The patch is not conditionally applied as it will soon be removed, and does no harm in the C99 case. PR: 97565 Submitted by: Rong-En Fan <rafan_AT_infor dot org> Reviewed by: maintainer (Robin Breathe)
Diffstat (limited to 'mail')
-rw-r--r--mail/dovecot-devel/Makefile1
-rw-r--r--mail/dovecot-devel/files/patch-master-settings.c10
-rw-r--r--mail/dovecot-devel/files/patch-module-dir.c12
-rw-r--r--mail/dovecot/Makefile1
-rw-r--r--mail/dovecot/files/patch-master-settings.c10
-rw-r--r--mail/dovecot/files/patch-module-dir.c12
6 files changed, 46 insertions, 0 deletions
diff --git a/mail/dovecot-devel/Makefile b/mail/dovecot-devel/Makefile
index c5d45d570e87..db1f7e6445de 100644
--- a/mail/dovecot-devel/Makefile
+++ b/mail/dovecot-devel/Makefile
@@ -8,6 +8,7 @@
PORTNAME= dovecot
DISTVERSION= 1.0.beta8
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/
diff --git a/mail/dovecot-devel/files/patch-master-settings.c b/mail/dovecot-devel/files/patch-master-settings.c
new file mode 100644
index 000000000000..dcf9fcab82bf
--- /dev/null
+++ b/mail/dovecot-devel/files/patch-master-settings.c
@@ -0,0 +1,10 @@
+--- src/master/master-settings.c.orig Tue Apr 25 10:00:07 2006
++++ src/master/master-settings.c Sun May 28 06:19:01 2006
+@@ -367,6 +367,7 @@
+
+ /* .. */
+ MEMBER(login_uid) 0,
++ MEMBER(imap_generated_capability) NULL,
+ MEMBER(listen_fd) -1,
+ MEMBER(ssl_listen_fd) -1
+ };
diff --git a/mail/dovecot-devel/files/patch-module-dir.c b/mail/dovecot-devel/files/patch-module-dir.c
new file mode 100644
index 000000000000..2673e4964a8b
--- /dev/null
+++ b/mail/dovecot-devel/files/patch-module-dir.c
@@ -0,0 +1,12 @@
+--- src/lib/module-dir.c.orig Sat May 6 10:00:05 2006
++++ src/lib/module-dir.c Sun May 28 06:22:06 2006
+@@ -24,6 +24,9 @@
+ const char *error;
+ void *ret;
+
++ /* reset dlerror */
++ (void)dlerror();
++
+ /* get our init func */
+ ret = dlsym(module->handle, symbol);
+
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index c5d45d570e87..db1f7e6445de 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -8,6 +8,7 @@
PORTNAME= dovecot
DISTVERSION= 1.0.beta8
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/
diff --git a/mail/dovecot/files/patch-master-settings.c b/mail/dovecot/files/patch-master-settings.c
new file mode 100644
index 000000000000..dcf9fcab82bf
--- /dev/null
+++ b/mail/dovecot/files/patch-master-settings.c
@@ -0,0 +1,10 @@
+--- src/master/master-settings.c.orig Tue Apr 25 10:00:07 2006
++++ src/master/master-settings.c Sun May 28 06:19:01 2006
+@@ -367,6 +367,7 @@
+
+ /* .. */
+ MEMBER(login_uid) 0,
++ MEMBER(imap_generated_capability) NULL,
+ MEMBER(listen_fd) -1,
+ MEMBER(ssl_listen_fd) -1
+ };
diff --git a/mail/dovecot/files/patch-module-dir.c b/mail/dovecot/files/patch-module-dir.c
new file mode 100644
index 000000000000..2673e4964a8b
--- /dev/null
+++ b/mail/dovecot/files/patch-module-dir.c
@@ -0,0 +1,12 @@
+--- src/lib/module-dir.c.orig Sat May 6 10:00:05 2006
++++ src/lib/module-dir.c Sun May 28 06:22:06 2006
+@@ -24,6 +24,9 @@
+ const char *error;
+ void *ret;
+
++ /* reset dlerror */
++ (void)dlerror();
++
+ /* get our init func */
+ ret = dlsym(module->handle, symbol);
+