aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-05-19 01:10:05 +0800
committerohauer <ohauer@FreeBSD.org>2014-05-19 01:10:05 +0800
commit243ca6162d9857b412656d009e9448d4ace15f9e (patch)
treeeaae6f4cecea5cbc024a9678b198e6411eaed6e3 /mail
parent1ed24093e8cb16bbf4264ce22714a5c907150fc3 (diff)
downloadfreebsd-ports-gnome-243ca6162d9857b412656d009e9448d4ace15f9e.tar.gz
freebsd-ports-gnome-243ca6162d9857b412656d009e9448d4ace15f9e.tar.zst
freebsd-ports-gnome-243ca6162d9857b412656d009e9448d4ace15f9e.zip
- add stage support
- bump PORTREVISION - add USES=libtool:keepla - add LICENSE - fix pkg-plist (do not try to remove mail/dovecot folders) PR: ports/189079 Submitted by: ohauer Reviewed by: maintainer timeout (3 weeks)
Diffstat (limited to 'mail')
-rw-r--r--mail/dovecot-sieve/Makefile21
-rw-r--r--mail/dovecot-sieve/pkg-plist5
2 files changed, 11 insertions, 15 deletions
diff --git a/mail/dovecot-sieve/Makefile b/mail/dovecot-sieve/Makefile
index ebb2a7a2f025..93631a30ec97 100644
--- a/mail/dovecot-sieve/Makefile
+++ b/mail/dovecot-sieve/Makefile
@@ -4,18 +4,22 @@
PORTNAME= dovecot-sieve
PORTVERSION= ${DOVECOTVERSION}+${DISTVERSION}
DISTVERSION= 0.1.19
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.rename-it.nl/dovecot/${DOVECOTVERSION}/
DISTNAME= ${PORTNAME:C/-/-${DOVECOTVERSION}-/}-${DISTVERSIONPREFIX}${DISTVERSION:C/:(.)/\1/g}${DISTVERSIONSUFFIX}
MAINTAINER= yds@CoolRat.org
-COMMENT= A Sieve plugin for the Dovecot 'deliver' LDA
+COMMENT= Sieve plugin for the Dovecot 'deliver' LDA
+
+LICENSE= LGPL21
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/mail/dovecot:build
RUN_DEPENDS= dovecot>=${DOVECOTVERSION}.*:${PORTSDIR}/mail/dovecot
DOVECOTVERSION= 1.2
+USES= libtool:keepla
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --prefix=${PREFIX} \
@@ -26,15 +30,10 @@ USE_LDCONFIG= ${PREFIX}/lib/dovecot/lda
SUB_FILES= pkg-message
-MAN1= sieve-test.1 sievec.1 sieved.1
-
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/-/\//}
-.if !defined(NOPORTDOCS)
PORTDOCS= AUTHORS COPYING COPYING.LGPL INSTALL NEWS README TODO spamtest-virustest.txt
-.endif
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e '\
s!/doc/$${PACKAGE_TARNAME}!/doc/${PORTNAME:S/-/\//}!g;\
@@ -47,12 +46,8 @@ post-patch:
@${LN} -f ${WRKSRC}/doc/spamtest-virustest.txt ${WRKSRC}/
post-install:
-.if !defined(NOPORTDOCS)
- ${INSTALL} ${_SHROWNGRP} -m ${BINMODE} -d ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/dovecot/lda/lib90_sieve_plugin.so
.include <bsd.port.mk>
diff --git a/mail/dovecot-sieve/pkg-plist b/mail/dovecot-sieve/pkg-plist
index 357b87ecda47..d5f1bab8a8d2 100644
--- a/mail/dovecot-sieve/pkg-plist
+++ b/mail/dovecot-sieve/pkg-plist
@@ -4,5 +4,6 @@ bin/sieved
lib/dovecot/lda/lib90_sieve_plugin.a
lib/dovecot/lda/lib90_sieve_plugin.la
lib/dovecot/lda/lib90_sieve_plugin.so
-@dirrmtry lib/dovecot/lda
-@dirrmtry lib/dovecot
+man/man1/sieve-test.1.gz
+man/man1/sievec.1.gz
+man/man1/sieved.1.gz