aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2014-01-21 09:17:59 +0800
committersahil <sahil@FreeBSD.org>2014-01-21 09:17:59 +0800
commit247cfe45b8f4dd3069d3467e7f1895efa1d24c14 (patch)
tree6af444ac55835d5ccc7ed5cb50de1c4f937e7657 /mail
parent4faaa850a6f64e978846097f594057adfb838304 (diff)
downloadfreebsd-ports-gnome-247cfe45b8f4dd3069d3467e7f1895efa1d24c14.tar.gz
freebsd-ports-gnome-247cfe45b8f4dd3069d3467e7f1895efa1d24c14.tar.zst
freebsd-ports-gnome-247cfe45b8f4dd3069d3467e7f1895efa1d24c14.zip
- Update to 2.9.9
- Adopt new LIB_DEPENDS syntax [1] - Pet portlint(1) on PKGNAMESUFFIX placement [1] - Modify shell command to quiet warnings on 10+ [2] - Respect upstream Makefile's warning suppression [3] PR: [1]: ports/185860 [2]: ports/185857 Submitted by: [1]: Yasuhiro KIMURA <yasu@utahime.org> [2]: adamw [3]: koobs (via email)
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix29/Makefile23
-rw-r--r--mail/postfix29/distinfo4
2 files changed, 14 insertions, 13 deletions
diff --git a/mail/postfix29/Makefile b/mail/postfix29/Makefile
index f696d5481c67..f930549bf0e7 100644
--- a/mail/postfix29/Makefile
+++ b/mail/postfix29/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= postfix
-PORTVERSION= 2.9.8
+PORTVERSION= 2.9.9
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -11,8 +11,8 @@ MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
ftp://ftp.samurai.com/pub/postfix/official/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/mail/postfix/official/&,}
MASTER_SITE_SUBDIR= . old related/postfix
-DIST_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= 29
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= sahil@FreeBSD.org
COMMENT= Secure alternative to widely-used Sendmail
@@ -23,8 +23,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
VDAVERSION= 2.9.6
-CONFLICTS= courier-0.* postfix-1.* postfix2[78]-* \
- postfix-2.10.* postfix-base-2.10.* postfix-current-2.* \
+CONFLICTS= courier-0.* postfix-1.* postfix2[78]-* postfix21?-* \
+ postfix-2.* postfix-base-2.* postfix-current-2.* \
postfix-current-base-2.* sendmail-8.* sendmail+*-8.* \
smail-3.* zmailer-2.* opensmtpd-[0-9]*
@@ -92,7 +92,7 @@ HTML1= body_checks.5.html bounce.5.html postfix-power.png \
scache.8.html tlsmgr.8.html
.if !defined(BATCH) && !defined(PACKAGE_BUILDING) && exists(/etc/mail/mailer.conf)
-OLD_MAILER!= ${GREP} -m 1 '^purgestat' /etc/mail/mailer.conf || true
+OLD_MAILER!= ${GREP} -m 1 '^purgestat' /etc/mail/mailer.conf || ${ECHO_CMD}
.if !empty(OLD_MAILER)
IS_INTERACTIVE= yes
.endif
@@ -108,7 +108,8 @@ MAKEFILEFLAGS+= DEBUG=
MAKEFILEFLAGS+= CC="${CC}" OPT="${CFLAGS}"
-POSTFIX_CCARGS+= -DDEF_CONFIG_DIR=\\\"${ETCDIR}\\\" \
+POSTFIX_CCARGS+= \$$(WARN) \
+ -DDEF_CONFIG_DIR=\\\"${ETCDIR}\\\" \
-DDEF_DAEMON_DIR=\\\"${DAEMONDIR}\\\" \
-DDEF_COMMAND_DIR=\\\"${PREFIX}/sbin\\\" \
-DDEF_SENDMAIL_PATH=\\\"${PREFIX}/sbin/sendmail\\\" \
@@ -126,7 +127,7 @@ POSTFIX_CCARGS+= -DDEF_CONFIG_DIR=\\\"${ETCDIR}\\\" \
_REQUIRE= LOGIN cleanvar
.if ${PORT_OPTIONS:MPCRE}
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
POSTFIX_CCARGS+= -DHAS_PCRE -I${LOCALBASE}/include
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
.else
@@ -134,7 +135,7 @@ POSTFIX_CCARGS+= -DNO_PCRE
.endif
.if ${PORT_OPTIONS:MSASL2}
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
@@ -154,7 +155,7 @@ POSTFIX_AUXLIBS+= -lkrb5 ${KRB5_EXTR} -lcrypto -lcrypt -lcom_err -lasn1 -lroken
.endif
.if ${PORT_OPTIONS:MSASLKMIT}
-LIB_DEPENDS+= krb5:${PORTSDIR}/security/krb5
+LIB_DEPENDS+= libkrb5.so:${PORTSDIR}/security/krb5
POSTFIX_AUXLIBS+= -Wl,--rpath,$${KRB5_HOME:-${LOCALBASE}}/lib -lkrb5 -lcrypto -lcrypt -lcom_err
.endif
@@ -165,7 +166,7 @@ POSTFIX_AUXLIBS+= -L${OPENSSLLIB} ${LDFLAGS} -lssl -lcrypto
.endif
.if ${PORT_OPTIONS:MSPF}
-LIB_DEPENDS+= spf2:${PORTSDIR}/mail/libspf2
+LIB_DEPENDS+= libspf2.so:${PORTSDIR}/mail/libspf2
PATCH_SITES+= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= mm
PATCHFILES+= postfix-2.8.0-libspf2-1.2.x-0.patch.gz
@@ -213,7 +214,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lldap -llber
_REQUIRE+= slapd
.if ${PORT_OPTIONS:MLDAP_SASL}
.if ! ${PORT_OPTIONS:MSASL2}
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
.endif
POSTFIX_CCARGS+= -I${LOCALBASE}/include/sasl -DUSE_LDAP_SASL
.endif
diff --git a/mail/postfix29/distinfo b/mail/postfix29/distinfo
index deb9a6dd78e3..c926bdabe7e8 100644
--- a/mail/postfix29/distinfo
+++ b/mail/postfix29/distinfo
@@ -1,5 +1,5 @@
-SHA256 (postfix/postfix-2.9.8.tar.gz) = 8b67005a9095d68feaf04b50da37545ac1036a2f1cd2c5226f759359fcf46488
-SIZE (postfix/postfix-2.9.8.tar.gz) = 3769844
+SHA256 (postfix/postfix-2.9.9.tar.gz) = 9fbd8d19573e9aa6fd79268b74e5a48764752d878d84d22a0415f6677065ec90
+SIZE (postfix/postfix-2.9.9.tar.gz) = 3770303
SHA256 (postfix/postfix-2.8.0-libspf2-1.2.x-0.patch.gz) = e5c38e5bc226cab109c02a4e530ab1aefd3bb06f2169f3e052bdf83d2727aacc
SIZE (postfix/postfix-2.8.0-libspf2-1.2.x-0.patch.gz) = 8191
SHA256 (postfix/postfix-vda-v11-2.9.6.patch) = 5dc94fca86501351e8c01360aa16c1cf49a363253e4076662d0103d3d431d309