aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-04-09 18:16:50 +0800
committersat <sat@FreeBSD.org>2007-04-09 18:16:50 +0800
commit24c90b4810b9959cdd5b3c9ddd4a41b13dbdc21a (patch)
treef5773e2c7bbcc7c2b335083f76f1faa06b828b80 /mail
parentef9a74947ddd34667f10cb884f45a4c5de227ada (diff)
downloadfreebsd-ports-gnome-24c90b4810b9959cdd5b3c9ddd4a41b13dbdc21a.tar.gz
freebsd-ports-gnome-24c90b4810b9959cdd5b3c9ddd4a41b13dbdc21a.tar.zst
freebsd-ports-gnome-24c90b4810b9959cdd5b3c9ddd4a41b13dbdc21a.zip
Add port mail/horde-forwards:
Forwards is a Horde module for setting user email forwards via the .forward mechanism supported by several popular mailers. Right now, Forwards provides fairly complete support for setting .forward style forwards on Sendmail, Courier, or Qmail mail based systems via an FTP transport. It now also has drivers for Mdaemon, Exim SQL, Exim LDAP, Custom SQL, and SOAP based systems. WWW: http://www.horde.org/forwards/ PR: ports/110886 (based on) Submitted by: Beech Rintoul <beech@alaskaparadise.com>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/horde-forwards/Makefile40
-rw-r--r--mail/horde-forwards/distinfo3
-rw-r--r--mail/horde-forwards/pkg-descr9
-rw-r--r--mail/horde-forwards/pkg-plist109
5 files changed, 162 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 0b9d8eb3bebb..984c2cd4e26c 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -159,6 +159,7 @@
SUBDIR += hashcash
SUBDIR += hbiff
SUBDIR += heirloom-mailx
+ SUBDIR += horde-forwards
SUBDIR += horde-vacation
SUBDIR += hotwayd
SUBDIR += ifile
diff --git a/mail/horde-forwards/Makefile b/mail/horde-forwards/Makefile
new file mode 100644
index 000000000000..d10ed41bc383
--- /dev/null
+++ b/mail/horde-forwards/Makefile
@@ -0,0 +1,40 @@
+# Ports collection makefile for: forwards3
+# Date created: Mon Mar 26, 2007
+# Whom: Beech Rintoul <beech@alaskaparadise.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= forwards
+PORTVERSION= 3.0.1
+CATEGORIES= mail www
+PKGNAMEPREFIX= horde-
+DIST_SUBDIR= horde
+
+MAINTAINER= beech@alaskaparadise.com
+COMMENT= E-mail forward
+
+#-----------------------------------------------------------------------
+# You may define these options:
+#
+# - WITHOUT_LDAP if you do not need OpenLDAP;
+#
+# - WITHOUT_FTP disable FTP support;
+#-----------------------------------------------------------------------
+
+RUN_DEPENDS+= ${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL
+
+. if !defined(WITHOUT_LDAP)
+USE_PHP+= ldap
+. endif
+
+.if !defined(WITHOUT_FTP)
+USE_PHP+= ftp
+.endif
+
+USE_HORDE= base pkg-message
+USE_GETTEXT= yes
+PORTDOCS= README CHANGES CREDITS INSTALL RELEASE_NOTES TODO
+
+.include "${.CURDIR}/../../www/horde-base/bsd.horde.mk"
+.include <bsd.port.mk>
diff --git a/mail/horde-forwards/distinfo b/mail/horde-forwards/distinfo
new file mode 100644
index 000000000000..30074f5cca02
--- /dev/null
+++ b/mail/horde-forwards/distinfo
@@ -0,0 +1,3 @@
+MD5 (horde/forwards-h3-3.0.1.tar.gz) = 0a2c16b1ff7ea80a246610d6e3ce6b50
+SHA256 (horde/forwards-h3-3.0.1.tar.gz) = 10f07f16f9914f43fad8112ea82f9a730b82df5ae9e1b34b0c757fc9df7f04ac
+SIZE (horde/forwards-h3-3.0.1.tar.gz) = 746345
diff --git a/mail/horde-forwards/pkg-descr b/mail/horde-forwards/pkg-descr
new file mode 100644
index 000000000000..766ee03b08d7
--- /dev/null
+++ b/mail/horde-forwards/pkg-descr
@@ -0,0 +1,9 @@
+Forwards is a Horde module for setting user email forwards via the .forward
+mechanism supported by several popular mailers.
+
+Right now, Forwards provides fairly complete support for setting .forward style
+forwards on Sendmail, Courier, or Qmail mail based systems via an FTP transport.
+It now also has drivers for Mdaemon, Exim SQL, Exim LDAP, Custom SQL, and SOAP
+based systems.
+
+WWW: http://www.horde.org/forwards/
diff --git a/mail/horde-forwards/pkg-plist b/mail/horde-forwards/pkg-plist
new file mode 100644
index 000000000000..84e026e869f1
--- /dev/null
+++ b/mail/horde-forwards/pkg-plist
@@ -0,0 +1,109 @@
+%%HORDIR%%/config/.htaccess
+%%HORDIR%%/config/conf.xml
+%%HORDIR%%/index.php
+%%HORDIR%%/lib/.htaccess
+%%HORDIR%%/lib/Block/summary.php
+%%HORDIR%%/lib/Driver/customsql.php
+%%HORDIR%%/lib/Driver/forwards.php
+%%HORDIR%%/lib/Driver/ldap.php
+%%HORDIR%%/lib/Driver/mdaemon.php
+%%HORDIR%%/lib/Driver/qmail.php
+%%HORDIR%%/lib/Driver/soap.php
+%%HORDIR%%/lib/Driver/sql.php
+%%HORDIR%%/lib/Driver.php
+%%HORDIR%%/lib/base.php
+%%HORDIR%%/lib/version.php
+%%HORDIR%%/locale/cs_CZ/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/da_DK/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/de_DE/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/en_US/help.xml
+%%HORDIR%%/locale/es_ES/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/es_ES/help.xml
+%%HORDIR%%/locale/fa_IR/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/fa_IR/help.xml
+%%HORDIR%%/locale/fi_FI/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/fi_FI/help.xml
+%%HORDIR%%/locale/fr_FR/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/gl_ES/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/hu_HU/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/it_IT/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/nn_NO/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/pl_PL/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/pt_BR/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/pt_PT/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/ro_RO/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/ru_RU/LC_MESSAGES/forwards.mo
+%%HORDIR%%/locale/zh_TW/LC_MESSAGES/forwards.mo
+%%HORDIR%%/main.php
+%%HORDIR%%/po/.htaccess
+%%HORDIR%%/po/README
+%%HORDIR%%/po/cs_CZ.po
+%%HORDIR%%/po/da_DK.po
+%%HORDIR%%/po/de_DE.po
+%%HORDIR%%/po/es_ES.po
+%%HORDIR%%/po/fa_IR.po
+%%HORDIR%%/po/fi_FI.po
+%%HORDIR%%/po/forwards.pot
+%%HORDIR%%/po/fr_FR.po
+%%HORDIR%%/po/gl_ES.po
+%%HORDIR%%/po/hu_HU.po
+%%HORDIR%%/po/it_IT.po
+%%HORDIR%%/po/nn_NO.po
+%%HORDIR%%/po/pl_PL.po
+%%HORDIR%%/po/pt_BR.po
+%%HORDIR%%/po/pt_PT.po
+%%HORDIR%%/po/ro_RO.po
+%%HORDIR%%/po/ru_RU.po
+%%HORDIR%%/po/zh_TW.po
+%%HORDIR%%/templates/.htaccess
+%%HORDIR%%/templates/common-header.inc
+%%HORDIR%%/templates/main/main.inc
+%%HORDIR%%/themes/graphics/favicon.ico
+%%HORDIR%%/themes/graphics/forwards.png
+@dirrmtry %%HORDIR%%/config
+@dirrm %%HORDIR%%/lib/Block
+@dirrm %%HORDIR%%/lib/Driver
+@dirrm %%HORDIR%%/lib
+@dirrm %%HORDIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/cs_CZ
+@dirrm %%HORDIR%%/locale/da_DK/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/da_DK
+@dirrm %%HORDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/de_DE
+@dirrm %%HORDIR%%/locale/en_US
+@dirrm %%HORDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/es_ES
+@dirrm %%HORDIR%%/locale/fa_IR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fa_IR
+@dirrm %%HORDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fi_FI
+@dirrm %%HORDIR%%/locale/fr_FR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fr_FR
+@dirrm %%HORDIR%%/locale/gl_ES/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/gl_ES
+@dirrm %%HORDIR%%/locale/hu_HU/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/hu_HU
+@dirrm %%HORDIR%%/locale/it_IT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/it_IT
+@dirrm %%HORDIR%%/locale/nn_NO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/nn_NO
+@dirrm %%HORDIR%%/locale/pl_PL/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pl_PL
+@dirrm %%HORDIR%%/locale/pt_BR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pt_BR
+@dirrm %%HORDIR%%/locale/pt_PT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pt_PT
+@dirrm %%HORDIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ro_RO
+@dirrm %%HORDIR%%/locale/ru_RU/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ru_RU
+@dirrm %%HORDIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/zh_TW
+@dirrm %%HORDIR%%/locale
+@dirrm %%HORDIR%%/po
+@dirrm %%HORDIR%%/templates/main
+@dirrm %%HORDIR%%/templates
+@dirrm %%HORDIR%%/themes/graphics
+@dirrm %%HORDIR%%/themes
+@dirrmtry %%HORDIR%%
+@dirrmtry %%HORBAS%%