aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-02-06 21:47:48 +0800
committergarga <garga@FreeBSD.org>2006-02-06 21:47:48 +0800
commit2510be0e55443076ae2d430e5bdf050728c79b7c (patch)
tree08dff6569cd9a177614661ff2f846247234c07eb /mail
parent440701bcfe30ecf305debceabd0ed254b965e5f6 (diff)
downloadfreebsd-ports-gnome-2510be0e55443076ae2d430e5bdf050728c79b7c.tar.gz
freebsd-ports-gnome-2510be0e55443076ae2d430e5bdf050728c79b7c.tar.zst
freebsd-ports-gnome-2510be0e55443076ae2d430e5bdf050728c79b7c.zip
o Update to 3.6.3 20060203.1409 cvs snap.
o Drop NEURAL_NET (removed upstream) and TRAIN_SCRIPT (now always installed and depend on PERL5 for it). o Add an other check for old (unsupported) options. o Some Makefile clean-ups. o Fix spelling in pkg-message [1] o s/pkg_version/${PKG_VERSION}/ o Fix removal of EXAMPLESDIR on pkg-plist [2] PR: ports/92774 Submitted by: maintainer, garga [2] Obtained from: edwin [1] Approved by: maintainer [2]
Diffstat (limited to 'mail')
-rw-r--r--mail/dspam-devel/Makefile93
-rw-r--r--mail/dspam-devel/distinfo6
-rw-r--r--mail/dspam-devel/files/UPDATING36
-rw-r--r--mail/dspam-devel/files/dspam-devel.sh.in2
-rw-r--r--mail/dspam-devel/pkg-message2
-rw-r--r--mail/dspam-devel/pkg-plist8
6 files changed, 73 insertions, 74 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index f8d156c28ff3..406d1b8795b4 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -3,8 +3,7 @@
# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
#
# $FreeBSD$
-#
-# $Tecnik: ports/mail/dspam-devel/Makefile,v 1.16 2006/01/25 00:31:26 itetcu Exp $
+# $Tecnik: ports/mail/dspam-devel/Makefile,v 1.26 2006/02/03 22:06:14 itetcu Exp $
#
# Note to commiters: If don't commit a maintainer patch and as a result PKGNAME
@@ -22,11 +21,10 @@ MAINTAINER= itetcu@people.tecnik93.com
COMMENT= Bayesian spam filter - development version
PORTVER_MAJ= 3.6.3
-#SNAP_DATE= .20051211.2134
+SNAP_DATE= .20060203.1409
.ifdef(SNAP_DATE)
MASTER_SITES= http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
-WRKSRC= ${WRKDIR}/dspam-cvs-devel${SNAP_DATE}
.else
MASTER_SITES= http://dspam.irontec.com/sources/ \
http://dspam.nuclearelephant.com/sources/ \
@@ -37,19 +35,7 @@ DISTFILES= dspam-${PORTVER_MAJ}.tar.gz
WRKSRC= ${WRKDIR}/dspam-${PORTVER_MAJ}
.endif
-## maintainer only
-.ifdef(MAINT)
-MASTER_SITES= http://dspam.nuclearelephant.com/sources/
-DISTFILES= dspam-${PORTVER_MAJ}.tar.gz
-NO_CHECKSUM= yes
-. ifdef(SNAP_DATE)
-DISTFILES= snapshot-devel.tar.gz
-#FETCH_BEFORE_ARGS= -v -o ${DISTDIR}/${PORTNAME}-${PORTVERSION}.tar.gz
-. endif
-FETCH_BEFORE_ARGS= -v -o ${DISTDIR}/${PORTNAME}-${PORTVERSION}.tar.gz
-.endif
-
-_UPD_LINE_NO= 19
+_UPD_LINE_NO= 31
## debug / log / admin options
OPTIONS= DEBUG "Enable debugging logging" on
@@ -58,9 +44,6 @@ OPTIONS+= BNR_DEBUG "Enable debug for BNR" off
OPTIONS+= PREF_EXT "Preferences in database not in files" off
OPTIONS+= DAEMON "Daemonize dspam; speaks LMTP or DLMTP" on
-## algorithm options
-OPTIONS+= NEURAL_NET "Enable neural networking" off
-
#
OPTIONS+= CLAMAV "Enable clamav support" on
OPTIONS+= CLAMAV_DEVEL "Enable clamav support" off
@@ -102,9 +85,12 @@ OPTIONS+= POSTFIX_MBC "Dspam as mailbox_command in Postfix" off
OPTIONS+= QMAIL "Play nice with Qmail mail server" off
OPTIONS+= CGI "Install CGI (pulls in apache)" off
-OPTIONS+= TRAIN_SCRIPT "Install trainning script (needs perl)" off
+USE_PERL5= yes
USE_AUTOTOOLS= libtool:15
+.ifdef(SNAP_DATE)
+USE_AUTOTOOLS+= autoconf:259:env automake:19
+.endif
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
#CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
@@ -139,6 +125,14 @@ DSPAM_HOME_MODE?= 0770
.include <bsd.port.pre.mk>
+MIN_OPTIONS_VER= ${PORTNAME}-3.6.3.20060203.1409
+.ifdef(_OPTIONS_READ)
+OPTIONS_CMP!= ${PKG_VERSION} -t ${_OPTIONS_READ} ${MIN_OPTIONS_VER}
+. if ${OPTIONS_CMP} == "<"
+OPTIONS_MESSAGE= "You have unsupported (old) OPTIONS, please do a 'make config; make'"
+. endif
+.endif
+
CONFIGURE_ARGS+= --with-logdir=${LOG_DIR}
PLIST_SUB+= LOG_DIR=${LOG_DIR}
@@ -186,10 +180,6 @@ SUB_LIST+= DSPAM_HOME=${DSPAM_HOME}
_SED_SCRIPT+= -e '/%%DAEMON%%/D'
.endif
-.ifdef(WITH_NEURAL_NET)
-CONFIGURE_ARGS+= --enable-neural-networking
-.endif
-
.ifdef(WITH_CLAMAV) && defined(WITH_CLAMAV_LOCAL)
CONFIGURE_ARGS+= --enable-clamav
RUN_DEPENDS+= clamav>=0:${PORTSDIR}/security/clamav
@@ -437,15 +427,8 @@ PLIST_SUB+= CGI="@comment "
_SED_SCRIPT+= -e '/%%CGI%%/D'
.endif
-.ifdef(WITH_TRAIN_SCRIPT)
-USE_PERL5= yes
-PLIST_SUB+= TRAIN_SCRIPT=""
-.else
-PLIST_SUB+= TRAIN_SCRIPT="@comment "
-.endif
-
MAN1= dspam.1 dspam_clean.1 dspam_corpus.1 dspam_dump.1 dspam_merge.1 \
- dspam_stats.1
+ dspam_stats.1 dspam_train.1
MAN3= libdspam.3
MLINKS= libdspam.3 dspam_init.3
MLINKS+= libdspam.3 dspam_create.3
@@ -461,21 +444,23 @@ _DOCSL= courier.txt exim.txt markov.txt mysql_drv.txt ora_drv.txt \
pgsql_drv.txt pop3filter.txt postfix.txt qmail.txt relay.txt \
sendmail.txt sqlite_drv.txt
-.ifndef(MAINT)
pre-everything::
+.ifndef(MAINT)
@${ECHO_CMD} ""
@${ECHO_CMD} "Last ${FILESDIR}/UPDATING entry:"
@${GREP} -B 1 -A ${_UPD_LINE_NO} ${PKGNAME} ${FILESDIR}/UPDATING
@${ECHO_CMD} ""
@sleep 5
-.else # maintainer only
-post-fetch:
-. ifndef(STOP)
-#. include "/root/ports/upd"
-. endif
.endif
pre-extract:
+.ifdef(OPTIONS_MESSAGE)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} ${OPTIONS_MESSAGE}
+ @${ECHO_CMD} ""
+ @exit 1
+.endif
+.ifndef(MAINT)
@${ECHO_CMD} ""
@${ECHO_CMD} "Define vars below before make-ing if you need:"
@${ECHO_CMD} ""
@@ -495,6 +480,7 @@ pre-extract:
. endif
@${ECHO_CMD} ""
@sleep 5
+.endif
.for old_opt in MAILDROP PROCMAIL TRAD_BAYES ALT_BAYES SPAM_SUBJ \
USER_LOGGING SYSTEM_LOGGING WEBMAIL OPT_IN SAT PARSE_TO_HEADERS \
@@ -523,13 +509,6 @@ pre-extract:
.endfor
post-patch:
- @${REINPLACE_CMD} -e 's|%%PORTNAME%%|${PORTNAME}|; \
- s|%%PKGNAME%%|${PKGNAME}|; s|%%MAINTAINER%%|${MAINTAINER}|; \
- s|%%LIBTOOLFLAGS%%|${LIBTOOLFLAGS}|g; \
- s|-ldb-4.1|-ldb41|g;' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.in
-
@${REINPLACE_CMD} -e 's|where @a-14 > to_days(created_on);|where @a-${SIGNATURE_LIFE} > to_days(created_on);|' \
${WRKSRC}/src/tools.mysql_drv/purge.sql
@${REINPLACE_CMD} -e 's|where @a-14 > to_days(created_on);|where @a-${SIGNATURE_LIFE} > to_days(created_on);|' \
@@ -542,10 +521,7 @@ post-patch:
${WRKSRC}/src/tools.sqlite_drv/purge-2.sql
@${REINPLACE_CMD} -e "s|where julianday('now')-julianday(created_on) > 14;|where julianday('now')-julianday(created_on) > ${SIGNATURE_LIFE};|" \
${WRKSRC}/src/tools.sqlite_drv/purge-3.sql
-
-.ifdef(WITH_TRAIN_SCRIPT)
- @${REINPLACE_CMD} -e "s^%%PERL%%^${PERL}^; s^%%DSPAM_PATH%%^${PREFIX}/bin^" ${WRKSRC}/scripts/train.pl
-.endif
+ @${REINPLACE_CMD} -e "s^%%PERL%%^${PERL}^; s^%%DSPAM_PATH%%^${PREFIX}/bin^" ${WRKSRC}/scripts/train.pl
pre-configure:
@${ECHO_CMD}
@@ -559,11 +535,6 @@ pre-configure:
@${ECHO_CMD} "You need to enable at least one database back-end."
@${FALSE}
.endif
-.if defined(WITH_NEURAL_NET) && \
- !( defined(USE_MYSQL) || defined(WITH_POSTGRESQL) )
- @${ECHO_CMD} "You need MySQL or POSTGRESQL to use neural networking."
- @${FALSE}
-.endif
.if defined(WITH_VIRT_USERS) && !(defined(USE_MYSQL) || \
defined(WITH_POSTGRESQL) || defined(WITH_ORACLE) || defined(WITH_HASH) )
@${ECHO_CMD} "You need MySQL, POSTGRESQL or ORACLE for virtual users."
@@ -596,6 +567,10 @@ pre-configure:
@${ECHO_CMD} "DOMAIN_SCALE and LARGE_SCALE are incopatible"
@${FALSE}
.endif
+.ifdef(SNAP_DATE)
+ @${ECHO_CMD} "You can safely ignore the following auto* errors"
+ @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
+.endif
post-install:
${CP} ${WRKSRC}/src/dspam.conf ${WRKSRC}/src/dspam.conf.sample
@@ -616,12 +591,9 @@ post-install:
${INSTALL_DATA} mysql_objects-4.1.sql \
mysql_objects-space.sql \
mysql_objects-speed.sql \
- neural.sql \
purge-4.1.sql purge.sql \
virtual_user_aliases.sql \
virtual_users.sql ${EXAMPLESDIR}/mysql
-# @${INSTALL_DATA} ${FILESDIR}/2x_to_3x_db.sql ${EXAMPLESDIR}/mysql
-# @${INSTALL_DATA} ${FILESDIR}/310_to_320.my.sql ${EXAMPLESDIR}/mysql
.endif
.ifdef(WITH_POSTGRESQL)
@${MKDIR} ${EXAMPLESDIR}/pgsql
@@ -658,11 +630,6 @@ post-install:
${INSTALL_DATA} *.html ${CGI_PATH}/templates/
.endif
-.ifdef(WITH_TRAIN_SCRIPT)
- cd ${WRKSRC}/scripts && \
- ${INSTALL_SCRIPT} train.pl ${PREFIX}/bin/dspam_train
-.endif
-
@${SED} ${_SED_SCRIPT} ${.CURDIR}/pkg-message > ${WRKSRC}/README.FreeBSD
.if !defined(NOPORTDOCS)
diff --git a/mail/dspam-devel/distinfo b/mail/dspam-devel/distinfo
index 85dfa21f326b..750c481db666 100644
--- a/mail/dspam-devel/distinfo
+++ b/mail/dspam-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (dspam-3.6.3.tar.gz) = db1aedb9677e6bf5c7a47a72d4f130e5
-SHA256 (dspam-3.6.3.tar.gz) = 6283c067c192f589a4fb925b845ba1bd9b51fe1b3df93d7f03897d7617a4aa7a
-SIZE (dspam-3.6.3.tar.gz) = 740097
+MD5 (dspam-devel-3.6.3.20060203.1409.tar.gz) = 31a970ba8cf8b7a9aa1d45db04127bda
+SHA256 (dspam-devel-3.6.3.20060203.1409.tar.gz) = 556cc67532ef9a1110541aee24aea8a84684d34179a670b1e6320ed97908b8a7
+SIZE (dspam-devel-3.6.3.20060203.1409.tar.gz) = 391316
diff --git a/mail/dspam-devel/files/UPDATING b/mail/dspam-devel/files/UPDATING
index c4172fe467c6..ed1d9fe53a38 100644
--- a/mail/dspam-devel/files/UPDATING
+++ b/mail/dspam-devel/files/UPDATING
@@ -11,6 +11,38 @@ in the port directory:
make extract; more `find . -type f -maxdepth 2 -name UPGRADING`
###########################################################################
+# dspam-devel-3.6.3.20060203.1409
+#
+
+BugFixes:
+- accuracy fixes (esp. for FP dspam is much better that in 3.6.3 release)
+- safeguards for segfault when strange clamav behavior
+- for no output when using --classify in client/server mode
+- LOG_WARNING if truncating MySQL user/pass + plus othersmall fixes
+
+New features:
+- dspam_train: a true training and testing mechanism, useful for building
+pretrained databases or training a user with their own corpus. also provides
+a test jig for measuring efficiency/accuracy with a corpus over a
+configuration.
+- DeliveryHost for delivery to different hosts based on domain
+- ClassAlias options, useful if classifying things other than spam
+
+Removed features:
+- removed neural networking (NEURAL_NET), which was experimental, needed a
+rewrite, no support, and high maintenance
+
+Changed features:
+- changed names in dspam_stats; now displays TP (true positives),
+TN (true negatives), FN (false negatives), and FP (false positives).
+- dspam_corpus now uses default settings for features and training modes,
+instead of its own and now requires --spam or --nonspam arguments
+- the trainining buffer (Feature tb=n in dspam.conf) is now offby default
+- no signature on classify
+- ignore X-DSPAM-* in tokenizer code
+
+
+###########################################################################
# dspam-devel-3.6.3
#
@@ -102,7 +134,9 @@ you can select multiple drivers in the OPTIONS screen; see dspam.conf.
and added MySQLSupressQuote option to compensate
- read UPGRADING and CHANGELOG and adjust your dspam.conf accordingly
- !!! WARNING !!! MaxMessageSize is also applied to ClamAV virus scanning.
- Thanks to Patrick Hurrelmann <outi@bytephobia.de> for beta-testing and catching a few mistakes.
+ Thanks to Patrick Hurrelmann <outi@bytephobia.de> for beta-testing and
+catching a few mistakes.
+
###########################################################################
# dspam-devel-3.5.2.20050725.0800
diff --git a/mail/dspam-devel/files/dspam-devel.sh.in b/mail/dspam-devel/files/dspam-devel.sh.in
index 4f08547ed427..78bec67d8320 100644
--- a/mail/dspam-devel/files/dspam-devel.sh.in
+++ b/mail/dspam-devel/files/dspam-devel.sh.in
@@ -1,7 +1,7 @@
#!/bin/sh
# $FreeBSD$
# formerly $ FreeBSD: ports/mail/dspam-devel/files/dspam.rc,v 1.2 2005/02/25 03:09:26 leeym Exp $
-# $Tecnik: ports/mail/dspam-devel/files/dspam-devel.sh.in,v 1.4 2006/01/24 20:52:44 itetcu Exp $
+# $Tecnik: ports/mail/dspam-devel/files/dspam-devel.sh.in,v 1.5 2006/02/03 13:56:46 itetcu Exp $
# PROVIDE: dspam
# REQUIRE: DAEMON %%MYSQL%% %%PGSQL%% %%CLAMD%%
diff --git a/mail/dspam-devel/pkg-message b/mail/dspam-devel/pkg-message
index d3b51389a78a..e16575e809fd 100644
--- a/mail/dspam-devel/pkg-message
+++ b/mail/dspam-devel/pkg-message
@@ -8,7 +8,7 @@
uname -a, dspam --version, %%_VAR_DIR%%/db/ports/%%PORTNAME%%/options, MTA setup.
Asking about updates or telling me there is one: not only I am active on the
-mailing lists but I also track dspam csv so I already know; either there is a
+mailing lists but I also track dspam CSV so I already know; either there is a
problem with the new version or I didn't have enough time to patch the port
and _test_ the new version; please report your succes/failure if you run the
new version or the cvs version.
diff --git a/mail/dspam-devel/pkg-plist b/mail/dspam-devel/pkg-plist
index dcc772fd8605..bc6d6bb4da1e 100644
--- a/mail/dspam-devel/pkg-plist
+++ b/mail/dspam-devel/pkg-plist
@@ -15,7 +15,7 @@ bin/dspam_logrotate
bin/dspam_merge
%%PGSQL%%bin/dspam_pg2int8
bin/dspam_stats
-%%TRAIN_SCRIPT%%bin/dspam_train
+bin/dspam_train
@unexec if cmp -s %D/etc/dspam.conf %D/etc/dspam.conf.sample; then rm -f %D/etc/dspam.conf; fi
etc/dspam.conf.sample
include/dspam/buffer.h
@@ -69,22 +69,20 @@ libdata/pkgconfig/dspam.pc
%%MYSQL%%%%EXAMPLESDIR%%/mysql/mysql_objects-4.1.sql
%%MYSQL%%%%EXAMPLESDIR%%/mysql/mysql_objects-space.sql
%%MYSQL%%%%EXAMPLESDIR%%/mysql/mysql_objects-speed.sql
-%%MYSQL%%%%EXAMPLESDIR%%/mysql/neural.sql
%%MYSQL%%%%EXAMPLESDIR%%/mysql/purge-4.1.sql
%%MYSQL%%%%EXAMPLESDIR%%/mysql/purge.sql
%%MYSQL%%%%EXAMPLESDIR%%/mysql/virtual_user_aliases.sql
%%MYSQL%%%%EXAMPLESDIR%%/mysql/virtual_users.sql
%%MYSQL%%@dirrm %%EXAMPLESDIR%%/mysql
-%%MYSQL%%@dirrm %%EXAMPLESDIR%%
%%PGSQL%%%%EXAMPLESDIR%%/pgsql/pgsql_objects.sql
+%%PGSQL%%%%EXAMPLESDIR%%/pgsql/purge-pe.sql
%%PGSQL%%%%EXAMPLESDIR%%/pgsql/purge.sql
%%PGSQL%%%%EXAMPLESDIR%%/pgsql/virtual_users.sql
%%PGSQL%%@dirrm %%EXAMPLESDIR%%/pgsql
-%%PGSQL%%@dirrm %%EXAMPLESDIR%%
%%SQLITE%%%%EXAMPLESDIR%%/sqlite/purge-2.sql
%%SQLITE%%%%EXAMPLESDIR%%/sqlite/purge-3.sql
%%SQLITE%%@dirrm %%EXAMPLESDIR%%/sqlite
-%%SQLITE%%@dirrm %%EXAMPLESDIR%%
+@dirrmtry %%EXAMPLESDIR%%
%%CGI%%www/vhosts/dspam/admins.sample
%%CGI%%www/vhosts/dspam/admin.cgi
%%CGI%%www/vhosts/dspam/admingraph.cgi