aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-07-19 00:41:19 +0800
committermat <mat@FreeBSD.org>2016-07-19 00:41:19 +0800
commit3dab8f09e8b7b464777ad4102a763fd6cfa084c6 (patch)
treede0e34a6fbc7678aaaa6fa7ea4c31c9e5b56add8 /mail
parent1be4f474d368ac856b66bc1d293b083466a5a505 (diff)
downloadfreebsd-ports-gnome-3dab8f09e8b7b464777ad4102a763fd6cfa084c6.tar.gz
freebsd-ports-gnome-3dab8f09e8b7b464777ad4102a763fd6cfa084c6.tar.zst
freebsd-ports-gnome-3dab8f09e8b7b464777ad4102a763fd6cfa084c6.zip
Don't echo in post-install, use pkg-message. Also, don't "fix"
pkg-message in post-install, use SUB_FILES/SUB_LIST. Sponsored by: Absolight
Diffstat (limited to 'mail')
-rw-r--r--mail/imap-uw/Makefile26
-rw-r--r--mail/imap-uw/files/pkg-message.in15
-rw-r--r--mail/panda-imap/Makefile26
-rw-r--r--mail/panda-imap/files/pkg-message.in15
-rw-r--r--mail/qpopper/Makefile13
-rw-r--r--mail/qpopper/files/pkg-message.in7
6 files changed, 45 insertions, 57 deletions
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index b40c83b7eaee..51e2e22d1e07 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -3,6 +3,7 @@
PORTNAME= imap
PORTVERSION= 2007f
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
@@ -34,6 +35,7 @@ ALL_TARGET= bsf
OPTIONS_DEFINE= SSL SSL_AND_PLAINTEXT DRAC NETSCAPE_BRAIN_DAMAGE DOCS
OPTIONS_DEFAULT= SSL
+OPTIONS_SUB= yes
SSL_DESC= Compile with SSL support
SSL_AND_PLAINTEXT_DESC= Allow plain text passwords and SSL
DRAC_DESC= Dynamically open MTA for relaying
@@ -94,32 +96,10 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/src/mailutil/mailutil.1 ${STAGEDIR}${PREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/src/tmail/tmail.1 ${STAGEDIR}${PREFIX}/man/man1/
-post-install:
- @${CAT} ${PKGMESSAGE}
-.if ${PORT_OPTIONS:MDRAC}
- @${ECHO} "================================================================================"
- @${ECHO} "To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing"
- @${ECHO} "the hostname of the DRAC server:"
- @${ECHO}
- @${ECHO} "localhost"
- @${ECHO} "================================================================================"
-.endif
-.if ${PORT_OPTIONS:MSSL}
- @${ECHO}
- @${ECHO} "To create and install a new SSL certificate for imapd and ipop3d, type \"make"
- @${ECHO} "cert\". Or install manually in ${PREFIX}/certs."
- @${ECHO}
- @${ECHO} "Example inetd config for SSL only services:"
- @${ECHO}
- @${ECHO} "pop3s stream tcp nowait root ${PREFIX}/libexec/ipop3d ipop3d"
- @${ECHO} "imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd"
- @${ECHO} "================================================================================"
-.endif
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} -m 0755 -p ${STAGEDIR}${DOCSDIR}
@${TAR} -C ${WRKSRC}/docs -cf - . | \
(umask 022; ${TAR} -C ${STAGEDIR}${DOCSDIR} -xf -)
-.endif
cert:
@${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/certs
diff --git a/mail/imap-uw/files/pkg-message.in b/mail/imap-uw/files/pkg-message.in
index 21f0badd3448..62b3f7d2c277 100644
--- a/mail/imap-uw/files/pkg-message.in
+++ b/mail/imap-uw/files/pkg-message.in
@@ -31,3 +31,18 @@ dir accessed.
WITHOUT_SSL - build without SSL/encryption support.
WITH_SSL_AND_PLAINTEXT - build with SSL/encryption support, but allow
non-encrypted logins.
+%%DRAC%%================================================================================
+%%DRAC%%To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing
+%%DRAC%%the hostname of the DRAC server:
+%%DRAC%%
+%%DRAC%%localhost
+%%DRAC%%================================================================================
+%%SSL%%
+%%SSL%%To create and install a new SSL certificate for imapd and ipop3d, type \"make
+%%SSL%%cert\". Or install manually in ${PREFIX}/certs.
+%%SSL%%
+%%SSL%%Example inetd config for SSL only services:
+%%SSL%%
+%%SSL%%pop3s stream tcp nowait root ${PREFIX}/libexec/ipop3d ipop3d
+%%SSL%%imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd
+%%SSL%%================================================================================
diff --git a/mail/panda-imap/Makefile b/mail/panda-imap/Makefile
index 747656c9b56d..586050db9448 100644
--- a/mail/panda-imap/Makefile
+++ b/mail/panda-imap/Makefile
@@ -3,6 +3,7 @@
PORTNAME= panda-imap
PORTVERSION= 20130621
+PORTREVISION= 1
CATEGORIES= mail ipv6
MAINTAINER= thierry@FreeBSD.org
@@ -31,6 +32,7 @@ ALL_TARGET= bsf
OPTIONS_DEFINE= SSL SSL_AND_PLAINTEXT DRAC NETSCAPE_BRAIN_DAMAGE DOCS
OPTIONS_DEFAULT= SSL
+OPTIONS_SUB= yes
SSL_DESC= Compile with SSL support
SSL_AND_PLAINTEXT_DESC= Allow plain text passwords and SSL
DRAC_DESC= Dynamically open MTA for relaying
@@ -92,32 +94,10 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/src/mailutil/mailutil.1 ${STAGEDIR}${PREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/src/tmail/tmail.1 ${STAGEDIR}${PREFIX}/man/man1/
-post-install:
- @${CAT} ${PKGMESSAGE}
-.if ${PORT_OPTIONS:MDRAC}
- @${ECHO} "================================================================================"
- @${ECHO} "To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing"
- @${ECHO} "the hostname of the DRAC server:"
- @${ECHO}
- @${ECHO} "localhost"
- @${ECHO} "================================================================================"
-.endif
-.if ${PORT_OPTIONS:MSSL}
- @${ECHO}
- @${ECHO} "To create and install a new SSL certificate for imapd and ipop3d, type \"make"
- @${ECHO} "cert\". Or install manually in ${PREFIX}/certs."
- @${ECHO}
- @${ECHO} "Example inetd config for SSL only services:"
- @${ECHO}
- @${ECHO} "pop3s stream tcp nowait root ${PREFIX}/libexec/ipop3d ipop3d"
- @${ECHO} "imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd"
- @${ECHO} "================================================================================"
-.endif
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} -m 0755 -p ${STAGEDIR}${DOCSDIR}
${TAR} -C ${WRKSRC}/docs -cf - . | \
(umask 022; ${TAR} -C ${STAGEDIR}${DOCSDIR} -xf -)
-.endif
cert:
${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/certs
diff --git a/mail/panda-imap/files/pkg-message.in b/mail/panda-imap/files/pkg-message.in
index 21f0badd3448..62b3f7d2c277 100644
--- a/mail/panda-imap/files/pkg-message.in
+++ b/mail/panda-imap/files/pkg-message.in
@@ -31,3 +31,18 @@ dir accessed.
WITHOUT_SSL - build without SSL/encryption support.
WITH_SSL_AND_PLAINTEXT - build with SSL/encryption support, but allow
non-encrypted logins.
+%%DRAC%%================================================================================
+%%DRAC%%To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing
+%%DRAC%%the hostname of the DRAC server:
+%%DRAC%%
+%%DRAC%%localhost
+%%DRAC%%================================================================================
+%%SSL%%
+%%SSL%%To create and install a new SSL certificate for imapd and ipop3d, type \"make
+%%SSL%%cert\". Or install manually in ${PREFIX}/certs.
+%%SSL%%
+%%SSL%%Example inetd config for SSL only services:
+%%SSL%%
+%%SSL%%pop3s stream tcp nowait root ${PREFIX}/libexec/ipop3d ipop3d
+%%SSL%%imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd
+%%SSL%%================================================================================
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index f213340965a2..9b1d2d9dad0a 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qpopper
PORTVERSION= 4.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.qualcomm.com/eudora/servers/unix/popper/ \
http://core.ring.gr.jp/archives/net/mail/qpopper/
@@ -57,6 +57,7 @@ STANDALONE_MODE_DESC= build qpopper to be run without inetd
U_OPTION_DESC= include support for user .qpopper-options
OPTIONS_DEFAULT= APOP SSL U_OPTION
+OPTION_SUB= yes
.include <bsd.port.pre.mk>
@@ -176,14 +177,4 @@ post-install:
fi ; \
fi
-.if ${PORT_OPTIONS:MPOPPASSD}
- @${ECHO_MSG} ""
- @${ECHO_MSG} "==============================================================================="
- @${ECHO_MSG} "It adds for myself"
- @${ECHO_MSG} "/etc/devfs.conf:"
- @${ECHO_MSG} "link /dev/pts/0 pty0"
- @${ECHO_MSG} "==============================================================================="
- @${ECHO_MSG} ""
-.endif
-
.include <bsd.port.post.mk>
diff --git a/mail/qpopper/files/pkg-message.in b/mail/qpopper/files/pkg-message.in
index dcfd3ed808d3..0a9aa5207b54 100644
--- a/mail/qpopper/files/pkg-message.in
+++ b/mail/qpopper/files/pkg-message.in
@@ -4,3 +4,10 @@ To enable the qpopper-daemon, add the following line to your /etc/inetd.conf:
pop3 stream tcp nowait root %%PREFIX%%/libexec/qpopper qpopper -s
****************************************************************************
+%%POPPASSD%%
+%%POPPASSD%%===============================================================================
+%%POPPASSD%%It adds for myself
+%%POPPASSD%%/etc/devfs.conf:
+%%POPPASSD%%link /dev/pts/0 pty0
+%%POPPASSD%%===============================================================================
+%%POPPASSD%%