aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-29 22:31:50 +0800
committerpav <pav@FreeBSD.org>2006-04-29 22:31:50 +0800
commit4333f1babd385376872f5d286431e89b02f048ea (patch)
treea31bd61a1834a01bc212d489bd8bd0ccf931dbf4 /mail
parent3f88587325bdfd9368bdb04b6e0de96a89ed6e7a (diff)
downloadfreebsd-ports-gnome-4333f1babd385376872f5d286431e89b02f048ea.tar.gz
freebsd-ports-gnome-4333f1babd385376872f5d286431e89b02f048ea.tar.zst
freebsd-ports-gnome-4333f1babd385376872f5d286431e89b02f048ea.zip
This plugin handles S/MIME signed and/or encrypted mails. You can
decrypt mails, verify signatures or sign and encrypt your own mails. PR: ports/96208 Submitted by: Pawel Pekala <c0rn@o2.pl>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/claws-mail-smime/Makefile29
-rw-r--r--mail/claws-mail-smime/distinfo3
-rw-r--r--mail/claws-mail-smime/files/patch-configure.ac15
-rw-r--r--mail/claws-mail-smime/pkg-descr2
-rw-r--r--mail/sylpheed-claws-smime/Makefile29
-rw-r--r--mail/sylpheed-claws-smime/distinfo3
-rw-r--r--mail/sylpheed-claws-smime/files/patch-configure.ac15
-rw-r--r--mail/sylpheed-claws-smime/pkg-descr2
9 files changed, 99 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 0c3007404fac..c6aa3968618b 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -523,6 +523,7 @@
SUBDIR += swaks
SUBDIR += sylpheed
SUBDIR += sylpheed-claws
+ SUBDIR += sylpheed-claws-smime
SUBDIR += sylpheed2
SUBDIR += sympa
SUBDIR += sympa-elixus
diff --git a/mail/claws-mail-smime/Makefile b/mail/claws-mail-smime/Makefile
new file mode 100644
index 000000000000..6e05ff4f5a9e
--- /dev/null
+++ b/mail/claws-mail-smime/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: sylpheed-claws-smime
+# Date created: 23 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smime
+PORTVERSION= 0.5
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= S/MIME plugin for sylpheed-claws
+
+LIB_DEPENDS= gpgme.15:${PORTSDIR}/security/gpgme
+BUILD_DEPENDS= sylpheed-claws>=2.1.1:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=2.1.1:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+
+PLIST_FILES=lib/sylpheed-claws/plugins/smime.a \
+ lib/sylpheed-claws/plugins/smime.la \
+ lib/sylpheed-claws/plugins/smime.so
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-smime/distinfo b/mail/claws-mail-smime/distinfo
new file mode 100644
index 000000000000..2f2087d36355
--- /dev/null
+++ b/mail/claws-mail-smime/distinfo
@@ -0,0 +1,3 @@
+MD5 (smime-0.5.tar.gz) = d2f842d13ba9c805571183cff9f6d9b6
+SHA256 (smime-0.5.tar.gz) = 24304da796d35dcd89a4c5fc30e7596bdf9897e8cf7b59fdc3744e678d9fb8ed
+SIZE (smime-0.5.tar.gz) = 322337
diff --git a/mail/claws-mail-smime/files/patch-configure.ac b/mail/claws-mail-smime/files/patch-configure.ac
new file mode 100644
index 000000000000..2f11eca8d385
--- /dev/null
+++ b/mail/claws-mail-smime/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Fri Apr 7 16:57:27 2006
++++ configure.ac Fri Apr 7 16:59:27 2006
+@@ -42,7 +42,11 @@
+
+ dnl check for sylpheed-claws
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 2.1.0.1)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=${prefix}/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
diff --git a/mail/claws-mail-smime/pkg-descr b/mail/claws-mail-smime/pkg-descr
new file mode 100644
index 000000000000..52ed69ed792c
--- /dev/null
+++ b/mail/claws-mail-smime/pkg-descr
@@ -0,0 +1,2 @@
+This plugin handles S/MIME signed and/or encrypted mails. You can
+decrypt mails, verify signatures or sign and encrypt your own mails.
diff --git a/mail/sylpheed-claws-smime/Makefile b/mail/sylpheed-claws-smime/Makefile
new file mode 100644
index 000000000000..6e05ff4f5a9e
--- /dev/null
+++ b/mail/sylpheed-claws-smime/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: sylpheed-claws-smime
+# Date created: 23 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smime
+PORTVERSION= 0.5
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= S/MIME plugin for sylpheed-claws
+
+LIB_DEPENDS= gpgme.15:${PORTSDIR}/security/gpgme
+BUILD_DEPENDS= sylpheed-claws>=2.1.1:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=2.1.1:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+
+PLIST_FILES=lib/sylpheed-claws/plugins/smime.a \
+ lib/sylpheed-claws/plugins/smime.la \
+ lib/sylpheed-claws/plugins/smime.so
+
+.include <bsd.port.mk>
diff --git a/mail/sylpheed-claws-smime/distinfo b/mail/sylpheed-claws-smime/distinfo
new file mode 100644
index 000000000000..2f2087d36355
--- /dev/null
+++ b/mail/sylpheed-claws-smime/distinfo
@@ -0,0 +1,3 @@
+MD5 (smime-0.5.tar.gz) = d2f842d13ba9c805571183cff9f6d9b6
+SHA256 (smime-0.5.tar.gz) = 24304da796d35dcd89a4c5fc30e7596bdf9897e8cf7b59fdc3744e678d9fb8ed
+SIZE (smime-0.5.tar.gz) = 322337
diff --git a/mail/sylpheed-claws-smime/files/patch-configure.ac b/mail/sylpheed-claws-smime/files/patch-configure.ac
new file mode 100644
index 000000000000..2f11eca8d385
--- /dev/null
+++ b/mail/sylpheed-claws-smime/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Fri Apr 7 16:57:27 2006
++++ configure.ac Fri Apr 7 16:59:27 2006
+@@ -42,7 +42,11 @@
+
+ dnl check for sylpheed-claws
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 2.1.0.1)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=${prefix}/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
diff --git a/mail/sylpheed-claws-smime/pkg-descr b/mail/sylpheed-claws-smime/pkg-descr
new file mode 100644
index 000000000000..52ed69ed792c
--- /dev/null
+++ b/mail/sylpheed-claws-smime/pkg-descr
@@ -0,0 +1,2 @@
+This plugin handles S/MIME signed and/or encrypted mails. You can
+decrypt mails, verify signatures or sign and encrypt your own mails.