aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-05-23 13:19:16 +0800
committerjbeich <jbeich@FreeBSD.org>2018-05-23 13:19:16 +0800
commit45f53047e1a10ccc05caa21c5358c3a5f9679a8a (patch)
treee3dac136536ef6809e4ab645ab1a1f8f5d8a1fff /mail
parent8ee1b07684b04558fd0178284b581dbc1ee3d758 (diff)
downloadfreebsd-ports-gnome-45f53047e1a10ccc05caa21c5358c3a5f9679a8a.tar.gz
freebsd-ports-gnome-45f53047e1a10ccc05caa21c5358c3a5f9679a8a.tar.zst
freebsd-ports-gnome-45f53047e1a10ccc05caa21c5358c3a5f9679a8a.zip
gecko: restore support for native extensions after r470668/r470672
PR: 226919
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/files/patch-addon-search6
2 files changed, 4 insertions, 4 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 242af3613d0b..853c6d555e0b 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 52.8.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-addon-search b/mail/thunderbird/files/patch-addon-search
index e92bf3c15652..dcc684409e80 100644
--- a/mail/thunderbird/files/patch-addon-search
+++ b/mail/thunderbird/files/patch-addon-search
@@ -45,7 +45,7 @@ index f70fd8d7e3bd8..81e8cd7764fdf 100644
addon.isPlatformCompatible = Array.some(nodes, function(aNode) {
let text = aNode.textContent.toLowerCase().trim();
- return text == "all" || text == Services.appinfo.OS.toLowerCase();
-+ return text == "all" || text == "linux";
++ return text == "all" || text == "linux" || text == Services.appinfo.OS.toLowerCase();
});
break;
case "install":
@@ -54,7 +54,7 @@ index f70fd8d7e3bd8..81e8cd7764fdf 100644
let os = node.getAttribute("os").trim().toLowerCase();
// If the os is not ALL and not the current OS then ignore this xpi
- if (os != "all" && os != Services.appinfo.OS.toLowerCase())
-+ if (os != "all" && os != "linux")
++ if (os != "all" && os != "linux" && os != Services.appinfo.OS.toLowerCase())
break;
}
@@ -67,7 +67,7 @@ index f70fd8d7e3bd8..81e8cd7764fdf 100644
try {
for (let platform of this.targetPlatforms) {
- if (platform.os == Services.appinfo.OS) {
-+ if (platform.os == "Linux") {
++ if (platform.os == "Linux" || platform.os == Services.appinfo.OS) {
if (platform.abi) {
needsABI = true;
if (platform.abi === abi)