aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-07-01 01:33:21 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-07-01 01:33:21 +0800
commit470e29edb53d55a5638aede82800fef8b9982ff3 (patch)
treea6e7220bc941da0142fd01424ab802c9fd78388b /mail
parent74cf767915452b97dae5ec604e4566c63b3e5112 (diff)
downloadfreebsd-ports-gnome-470e29edb53d55a5638aede82800fef8b9982ff3.tar.gz
freebsd-ports-gnome-470e29edb53d55a5638aede82800fef8b9982ff3.tar.zst
freebsd-ports-gnome-470e29edb53d55a5638aede82800fef8b9982ff3.zip
- Take maintainership
- Attempt to limit portscout to version 1.2 - Fix rc script for one* commands [1] Not bumping PORTREVISION as the installed version doesn't change, should not affect dependent ports. PR: 177497 [1] Submitted by: nick@3wh.net [1]
Diffstat (limited to 'mail')
-rw-r--r--mail/dovecot/Makefile6
-rw-r--r--mail/dovecot/files/dovecot.in18
2 files changed, 12 insertions, 12 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 1c76fd74c86e..32bf91916fd0 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -3,12 +3,12 @@
PORTNAME= dovecot
PORTVERSION= 1.2.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/${PORTVERSION:R}/ \
http://www.rename-it.nl/dovecot/${PORTVERSION:R}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Secure and compact IMAP and POP3 servers
LICENSE= LGPL21 MIT
@@ -31,6 +31,8 @@ CONFLICTS= dovecot2-2.[0-9].*
USES= iconv libtool:keepla
USE_RC_SUBR= dovecot
+PORTSCOUT= limit:^1\.2
+
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var \
diff --git a/mail/dovecot/files/dovecot.in b/mail/dovecot/files/dovecot.in
index cadfadc7c8de..c1b3e1b6f562 100644
--- a/mail/dovecot/files/dovecot.in
+++ b/mail/dovecot/files/dovecot.in
@@ -50,13 +50,11 @@ restart_cmd()
# To start multiple instances of dovecot set dovecot_config to
# a space seperated list of configuration files.
-if checkyesno ${name}_enable; then
- for config in ${dovecot_config}; do
- required_files="${config}"
- command_args="-c ${config}"
- base_dir=$(${command} ${command_args} -a | /usr/bin/awk -F ': ' '/^base_dir:/ { print $2 }')
- login_dir=$(${command} ${command_args} -a | /usr/bin/awk -F ': ' '/^login_dir:/ { print $2 }')
- pidfile="${base_dir}/master.pid"
- run_rc_command "$1"
- done
-fi
+for config in ${dovecot_config}; do
+ required_files="${config}"
+ command_args="-c ${config}"
+ base_dir=$(${command} ${command_args} -a | /usr/bin/awk -F ': ' '/^base_dir:/ { print $2 }')
+ login_dir=$(${command} ${command_args} -a | /usr/bin/awk -F ': ' '/^login_dir:/ { print $2 }')
+ pidfile="${base_dir}/master.pid"
+ run_rc_command "$1"
+done