aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2013-08-30 22:42:06 +0800
committerfeld <feld@FreeBSD.org>2013-08-30 22:42:06 +0800
commit4e67af8c0e9c1d82ae47c1923da6f1e4592de7fe (patch)
treebe52e5545928bb2e75165c112bda170e87fbdb96 /mail
parent1d80d752ec569685a08bf5d9637d825fbec81c55 (diff)
downloadfreebsd-ports-gnome-4e67af8c0e9c1d82ae47c1923da6f1e4592de7fe.tar.gz
freebsd-ports-gnome-4e67af8c0e9c1d82ae47c1923da6f1e4592de7fe.tar.zst
freebsd-ports-gnome-4e67af8c0e9c1d82ae47c1923da6f1e4592de7fe.zip
- Actually commit rc script fixes
- Convert to new Perl USES - Move pkg-install logic to @exec and post-install - Other suggested cleanup Approved by: crees (mentor)
Diffstat (limited to 'mail')
-rw-r--r--mail/archiveopteryx/Makefile8
-rw-r--r--mail/archiveopteryx/files/archiveopteryx.in39
-rw-r--r--mail/archiveopteryx/pkg-descr2
-rw-r--r--mail/archiveopteryx/pkg-install11
-rw-r--r--mail/archiveopteryx/pkg-plist2
5 files changed, 25 insertions, 37 deletions
diff --git a/mail/archiveopteryx/Makefile b/mail/archiveopteryx/Makefile
index 8e1950f254bf..8f60609110af 100644
--- a/mail/archiveopteryx/Makefile
+++ b/mail/archiveopteryx/Makefile
@@ -8,15 +8,16 @@ CATEGORIES= mail
MASTER_SITES= http://archiveopteryx.org/download/
MAINTAINER= feld@FreeBSD.org
-COMMENT= An advanced PostgreSQL-based IMAP/POP server
+COMMENT= Advanced PostgreSQL-based IMAP/POP server
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/bsd.txt
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
+USES= perl5
USE_BZIP2= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_PGSQL= yes
MAN5= aoxsuper.conf.5 archiveopteryx.conf.5
@@ -47,7 +48,8 @@ do-install:
@cd ${WRKSRC} && ${JAM} install
post-install:
- @${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
+ ${INSTALL} -d -o root -g wheel -m 700 /var/db/aox/jail
+ ${INSTALL} -d -o ${USERS} -g ${GROUPS} /var/db/aox/messages
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/mail/archiveopteryx/files/archiveopteryx.in b/mail/archiveopteryx/files/archiveopteryx.in
index 620724fe201b..55a44d9993f3 100644
--- a/mail/archiveopteryx/files/archiveopteryx.in
+++ b/mail/archiveopteryx/files/archiveopteryx.in
@@ -15,46 +15,41 @@
. /etc/rc.subr
-name="archiveopteryx"
+name=archiveopteryx
rcvar=archiveopteryx_enable
+load_rc_config $name
archiveopteryx_enable=${archiveopteryx_enable:-"NO"}
-pidfile=/var/run/${name}.pid
+pidfile=/var/run/aox/${name}.pid
config_file=%%PREFIX%%/etc/archiveopteryx/archiveopteryx.conf
required_files=$config_file
command=%%PREFIX%%/bin/aox
-extra_commands="status"
-status_cmd="do_status"
-start_cmd="do_start"
-stop_cmd="do_stop"
-restart_cmd="do_restart"
+extra_commands=status
+status_cmd="${command} show status"
+start_cmd=do_start
+stop_cmd=do_stop
+restart_cmd=do_restart
do_start()
{
- echo -n "Starting Archiveopteryx: "
- ${command} start
- echo "done."
+ echo -n "Starting Archiveopteryx: "
+ ${command} start
+ echo "done."
}
do_stop()
{
- echo -n "Stopping Archiveopteryx: "
- ${command} stop
- echo "done."
+ echo -n "Stopping Archiveopteryx: "
+ ${command} stop
+ echo "done."
}
do_restart()
{
- echo -n "Restarting Archiveopteryx: "
- ${command} restart
- echo "done."
+ echo -n "Restarting Archiveopteryx: "
+ ${command} restart
+ echo "done."
}
-do_status()
-{
- ${command} show status
-}
-
-load_rc_config $name
run_rc_command "$1"
diff --git a/mail/archiveopteryx/pkg-descr b/mail/archiveopteryx/pkg-descr
index 0ec33166e59b..33066ea944d9 100644
--- a/mail/archiveopteryx/pkg-descr
+++ b/mail/archiveopteryx/pkg-descr
@@ -3,4 +3,4 @@ long-term archival storage. It seeks to make it practical not only to
manage large archives, but to use the information therein on a daily
basis instead of relegating it to offline storage.
-WWW: http://www.archiveopteryx.org/
+WWW: http://www.archiveopteryx.org/
diff --git a/mail/archiveopteryx/pkg-install b/mail/archiveopteryx/pkg-install
deleted file mode 100644
index 699261f65c6e..000000000000
--- a/mail/archiveopteryx/pkg-install
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-INSTALL=/usr/bin/install
-AOXGROUP=aox
-AOXUSER=aox
-
-if [ "$2" = POST-INSTALL ]; then
- ${INSTALL} -d -o root -g wheel -m 700 /var/db/aox/jail
- ${INSTALL} -d -o ${AOXUSER} -g ${AOXGROUP} /var/db/aox/messages
- ${INSTALL} -d -o ${AOXUSER} -g ${AOXGROUP} /var/run/aox
-fi
diff --git a/mail/archiveopteryx/pkg-plist b/mail/archiveopteryx/pkg-plist
index 0a348c2d236f..ef11378e8e32 100644
--- a/mail/archiveopteryx/pkg-plist
+++ b/mail/archiveopteryx/pkg-plist
@@ -23,3 +23,5 @@ sbin/recorder
@dirrmtry /var/db/aox/messages
@dirrmtry /var/db/aox
@dirrmtry /var/run/aox
+@exec install -d -o root -g wheel -m 700 /var/db/aox/jail
+@exec install -d -o %%USERS%% -g %%GROUPS%% /var/db/aox/messages