aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2003-01-22 23:21:51 +0800
committerdougb <dougb@FreeBSD.org>2003-01-22 23:21:51 +0800
commit4fc216f1bb562ac704c18f6acf252b8d0620a52a (patch)
treebb43b0b55ae3e1ba6834b2fa1852696b55f56311 /mail
parent1ede3443e32e75b43179c0082659a54f27c110c4 (diff)
downloadfreebsd-ports-gnome-4fc216f1bb562ac704c18f6acf252b8d0620a52a.tar.gz
freebsd-ports-gnome-4fc216f1bb562ac704c18f6acf252b8d0620a52a.tar.zst
freebsd-ports-gnome-4fc216f1bb562ac704c18f6acf252b8d0620a52a.zip
Re-creation of the Bourne Shell based pgp filters for Pine that used
to be part of the pine4 port. These have been updated to A) actually work, and B) use gnupg if it's available.
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/pine-pgp-filters/Makefile27
-rw-r--r--mail/pine-pgp-filters/distinfo1
-rw-r--r--mail/pine-pgp-filters/pkg-comment1
-rw-r--r--mail/pine-pgp-filters/pkg-descr12
-rw-r--r--mail/pine-pgp-filters/pkg-plist8
6 files changed, 50 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index f094efc29784..cb44e0a69ca9 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -188,6 +188,7 @@
SUBDIR += pgen
SUBDIR += pgp4pine
SUBDIR += pgpsendmail
+ SUBDIR += pine-pgp-filters
SUBDIR += pine4
SUBDIR += pm-lib
SUBDIR += pmail
diff --git a/mail/pine-pgp-filters/Makefile b/mail/pine-pgp-filters/Makefile
new file mode 100644
index 000000000000..ca11412245d7
--- /dev/null
+++ b/mail/pine-pgp-filters/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pine-pgp-filters
+# Date created: 22 January 2003
+# Whom: dougb
+#
+# $FreeBSD$
+#
+
+PORTNAME= pine-pgp-filters
+PORTVERSION= 1.0
+CATEGORIES= mail
+MASTER_SITES= http://dougbarton.net/FreeBSD/Downloads/ \
+ ${MASTER_SITE_LOCAL}/dougb
+
+MAINTAINER= DougB@FreeBSD.org
+
+do-build:
+ cd ${WRKSRC} && ./configure --prefix=${PREFIX}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} ${DOCSDIR}
+.for file in INSTALL README
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/pine-pgp-filters/distinfo b/mail/pine-pgp-filters/distinfo
new file mode 100644
index 000000000000..a69f19bf0232
--- /dev/null
+++ b/mail/pine-pgp-filters/distinfo
@@ -0,0 +1 @@
+MD5 (pine-pgp-filters-1.0.tar.gz) = e394462d55d86b87442486db1fd764f4
diff --git a/mail/pine-pgp-filters/pkg-comment b/mail/pine-pgp-filters/pkg-comment
new file mode 100644
index 000000000000..0db76e3f6ffa
--- /dev/null
+++ b/mail/pine-pgp-filters/pkg-comment
@@ -0,0 +1 @@
+Simple, fast, sh-based filters to integrate Pine with gnupg, or pgp6
diff --git a/mail/pine-pgp-filters/pkg-descr b/mail/pine-pgp-filters/pkg-descr
new file mode 100644
index 000000000000..a829d91f4e8a
--- /dev/null
+++ b/mail/pine-pgp-filters/pkg-descr
@@ -0,0 +1,12 @@
+Simple, fast, sh-based filters to integrate Pine with gnupg, or pgp6.
+
+In addition to the standard functions of encrypt/decrypt and sign/verify, I've
+added a pseudo-filter to verify messages that were sent using MIME encoding to
+attach the signature. See INSTALL for how to use it. It's not possible for a
+sending filter to create these kinds of MIME messages, since Pine does not
+give the user the ability to twiddle attachments.
+
+WWW: http://dougbarton.net/FreeBSD/Downloads/
+
+- Doug Barton
+DougB@FreeBSD.org
diff --git a/mail/pine-pgp-filters/pkg-plist b/mail/pine-pgp-filters/pkg-plist
new file mode 100644
index 000000000000..8eb9291b7042
--- /dev/null
+++ b/mail/pine-pgp-filters/pkg-plist
@@ -0,0 +1,8 @@
+libexec/ppf_decrypt
+libexec/ppf_encrypt
+libexec/ppf_mime
+libexec/ppf_sign
+libexec/ppf_verify
+%%PORTDOCS%%share/doc/pine-pgp-filters/INSTALL
+%%PORTDOCS%%share/doc/pine-pgp-filters/README
+%%PORTDOCS%%@dirrm share/doc/pine-pgp-filters