aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoruqs <uqs@FreeBSD.org>2013-01-08 22:46:14 +0800
committeruqs <uqs@FreeBSD.org>2013-01-08 22:46:14 +0800
commit535fe620bdcda40e636235eef384d2e30a75596b (patch)
tree30d3463760c440ea23e223e11376b0464f0d8704 /mail
parentbd9ac117d539dfd2f841b350bcdd132c9e0ca643 (diff)
downloadfreebsd-ports-gnome-535fe620bdcda40e636235eef384d2e30a75596b.tar.gz
freebsd-ports-gnome-535fe620bdcda40e636235eef384d2e30a75596b.tar.zst
freebsd-ports-gnome-535fe620bdcda40e636235eef384d2e30a75596b.zip
Fix obspamlogd rc script's use of tests, while here fix whitespace.
Approved by: beat (mentor)
Diffstat (limited to 'mail')
-rw-r--r--mail/spamd/Makefile1
-rw-r--r--mail/spamd/files/obspamlogd.in26
2 files changed, 14 insertions, 13 deletions
diff --git a/mail/spamd/Makefile b/mail/spamd/Makefile
index 225b32e3231a..9e8e196c1e88 100644
--- a/mail/spamd/Makefile
+++ b/mail/spamd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= spamd
PORTVERSION= 4.9.1
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF
MASTER_SITE_SUBDIR=freebsdspamd.berlios
diff --git a/mail/spamd/files/obspamlogd.in b/mail/spamd/files/obspamlogd.in
index 7182e92ecb24..136c66fe5495 100644
--- a/mail/spamd/files/obspamlogd.in
+++ b/mail/spamd/files/obspamlogd.in
@@ -33,20 +33,20 @@ pidfile="/var/run/spamlogd.pid"
obspamlogd_precmd()
{
- if [ ! -z ${obspamlogd_pflog_if} ]; then
- # Configure i/f explicitly
- load_kld pflog || {
- warn "Unable to kldload pflog module"
- return 1
- }
+ if [ ! -z "${obspamlogd_pflog_if}" ]; then
+ # Configure i/f explicitly
+ load_kld pflog || {
+ warn "Unable to kldload pflog module"
+ return 1
+ }
- if ! ifconfig ${obspamlogd_pflog_if} create up; then
- warn "could not bring up ${obspamlogd_pflog_if}"
- return 1
- fi
+ if ! ifconfig ${obspamlogd_pflog_if} create up; then
+ warn "could not bring up ${obspamlogd_pflog_if}"
+ return 1
+ fi
- rc_flags="${rc_flags} -l ${obspamlogd_pflog_if}"
- fi
+ rc_flags="${rc_flags} -l ${obspamlogd_pflog_if}"
+ fi
_rc=0
/sbin/mount -p | grep 'fdescfs.*/dev/fd.*fdescfs.*rw' 2>&1 > /dev/null
_rc=${?}
@@ -63,7 +63,7 @@ obspamlogd_precmd()
obspamlogd_cleanup()
{
- if [ -n ${obspamlogd_pflog_if} ]; then
+ if [ -n "${obspamlogd_pflog_if}" ]; then
ifconfig ${obspamlogd_pflog_if} destroy
fi
/bin/rm -f ${pidfile}