aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-29 07:43:11 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-29 07:43:11 +0800
commit5a9eb432cb3e1001191a86cd3b31c0ad0af30692 (patch)
treeb1e18e9198940685c72f284ddb5089fd93ffd574 /mail
parent2f77fed5b89d164c9d3d2bc830d076a39569998a (diff)
downloadfreebsd-ports-gnome-5a9eb432cb3e1001191a86cd3b31c0ad0af30692.tar.gz
freebsd-ports-gnome-5a9eb432cb3e1001191a86cd3b31c0ad0af30692.tar.zst
freebsd-ports-gnome-5a9eb432cb3e1001191a86cd3b31c0ad0af30692.zip
[1]:
- Create the bogomilter user with /sbin/nologin as shell and /nonexistent as home directory - Update the maintainer's email address Moreover: - Unconditionally define PORTDOCS, as ${NOPORTDOCS} is now tested by bsd.port.mk - Install manual page in ${MAN8PREFIX} [1]: PR: ports/82583 Submitted by: maintainer
Diffstat (limited to 'mail')
-rw-r--r--mail/milter-bogom/Makefile7
-rw-r--r--mail/milter-bogom/pkg-install3
2 files changed, 5 insertions, 5 deletions
diff --git a/mail/milter-bogom/Makefile b/mail/milter-bogom/Makefile
index 8cc211a02d3c..31f39454d561 100644
--- a/mail/milter-bogom/Makefile
+++ b/mail/milter-bogom/Makefile
@@ -1,12 +1,13 @@
# New ports collection makefile for: milter-bogom
# Date created: 12 Feb 2005
-# Whom: Victor Balada Diaz <victor@alf.dyndns.ws>
+# Whom: Victor Balada Diaz <victor@bsdes.net>
#
# $FreeBSD$
#
PORTNAME= milter-bogom
PORTVERSION= 1.7.1
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.usebox.net/jjm/bogom/ \
http://blackshell.usebox.net/bogom/
@@ -28,9 +29,7 @@ USE_RC_SUBR= milter-bogom.sh
PLIST_FILES= sbin/bogom \
etc/bogom.conf-example
-.if !defined(NOPORTDOCS)
PORTDOCS= README CHANGELOG
-.endif
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' ${WRKSRC}/bogom.8
@@ -42,7 +41,7 @@ post-patch:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/bogom ${PREFIX}/sbin
- @${INSTALL_MAN} ${WRKSRC}/bogom.8 ${PREFIX}/man/man8
+ @${INSTALL_MAN} ${WRKSRC}/bogom.8 ${MAN8PREFIX}/man/man8
@${INSTALL_DATA} ${WRKSRC}/bogom.conf-example ${PREFIX}/etc
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/mail/milter-bogom/pkg-install b/mail/milter-bogom/pkg-install
index d7da1bade2e9..a3fdc9b28cb5 100644
--- a/mail/milter-bogom/pkg-install
+++ b/mail/milter-bogom/pkg-install
@@ -11,7 +11,8 @@ pw user show bogomilter > /dev/null 2>&1
if [ $? != 0 ]
then
echo "===> Adding user bogomilter"
- pw useradd bogomilter -u 174 -c "milter-bogom"
+ pw useradd bogomilter -u 174 -c "milter-bogom" -s /sbin/nologin \
+ -d /nonexistent
else
echo "===> Using existing user bogomilter"
fi