aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2010-11-24 18:25:51 +0800
committerarved <arved@FreeBSD.org>2010-11-24 18:25:51 +0800
commit5b679981f4f1ba7d78405b9846e08147d86e9144 (patch)
tree980e2734f7b438b4c4ce7f6dc8902d088eacece6 /mail
parent371b15d940a5bfa909cceb16b514fded08bf46e2 (diff)
downloadfreebsd-ports-gnome-5b679981f4f1ba7d78405b9846e08147d86e9144.tar.gz
freebsd-ports-gnome-5b679981f4f1ba7d78405b9846e08147d86e9144.tar.zst
freebsd-ports-gnome-5b679981f4f1ba7d78405b9846e08147d86e9144.zip
Add spamass-ixhash, a plugin for Spamassassin, that
computes MD5 checksums of fragments of the body of an e-mail and compares them to those of know spam. PR: 152216 Submitted by: Michael Ranner
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/spamass-ixhash/Makefile51
-rw-r--r--mail/spamass-ixhash/distinfo2
-rw-r--r--mail/spamass-ixhash/files/pkg-message.in5
-rw-r--r--mail/spamass-ixhash/pkg-descr8
5 files changed, 67 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 07f6f4ec36ed..a1141df776fd 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -639,6 +639,7 @@
SUBDIR += softfail
SUBDIR += solidpop3d
SUBDIR += sortmail
+ SUBDIR += spamass-ixhash
SUBDIR += spamass-milter
SUBDIR += spamass-rules
SUBDIR += spamass-rules_du_jour
diff --git a/mail/spamass-ixhash/Makefile b/mail/spamass-ixhash/Makefile
new file mode 100644
index 000000000000..b7aef99ee3df
--- /dev/null
+++ b/mail/spamass-ixhash/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: spamass-ixhash
+# Date created: 2010-11-12
+# Whom: Michael Ranner <michael@ranner.eu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iXhash
+PORTVERSION= 1.5.5
+CATEGORIES= mail
+MASTER_SITES= SF/ixhash/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
+PKGNAMEPREFIX= spamass-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= michael@ranner.eu
+COMMENT= The iXhash plugin for SpamAssassin
+
+RUN_DEPENDS= spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Net-DNS>=0.63:${PORTSDIR}/dns/p5-Net-DNS
+
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+SUB_FILES= pkg-message
+NO_BUILD= yes
+SPAMASS_CONF= etc/mail/spamassassin
+SPAMASS_FILES= iXhash.cf iXhash.pm
+INSTALL_DIR= ${PREFIX}/${SPAMASS_CONF}
+
+PORTDOCS= CHANGELOG LICENSE WHERE_ARE_THE_OTHER_FILES INSTALL README
+PLIST_FILES= ${SPAMASS_CONF}/iXhash.cf.sample ${SPAMASS_CONF}/iXhash.pm
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/etc/mail,${LOCALBASE}/etc/mail," \
+ ${WRKSRC}/iXhash/iXhash.cf
+
+do-install:
+ @${MKDIR} ${INSTALL_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/iXhash/iXhash.cf ${INSTALL_DIR}/iXhash.cf.sample
+ ${INSTALL_DATA} ${WRKSRC}/iXhash/iXhash.pm ${INSTALL_DIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+. for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+. endfor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/spamass-ixhash/distinfo b/mail/spamass-ixhash/distinfo
new file mode 100644
index 000000000000..0b4c692e9d94
--- /dev/null
+++ b/mail/spamass-ixhash/distinfo
@@ -0,0 +1,2 @@
+SHA256 (iXhash-1.5.5.tgz) = b44e8f845c2e1c2c8a8dd1cf1af6568e8886b076c230be076cbe56481b2fe5db
+SIZE (iXhash-1.5.5.tgz) = 11900
diff --git a/mail/spamass-ixhash/files/pkg-message.in b/mail/spamass-ixhash/files/pkg-message.in
new file mode 100644
index 000000000000..f70b8d9c40fe
--- /dev/null
+++ b/mail/spamass-ixhash/files/pkg-message.in
@@ -0,0 +1,5 @@
+*************************************************************************
+
+iXhash is installed in %%PREFIX%%/etc/mail/spamassassin
+
+*************************************************************************
diff --git a/mail/spamass-ixhash/pkg-descr b/mail/spamass-ixhash/pkg-descr
new file mode 100644
index 000000000000..89a80905c73b
--- /dev/null
+++ b/mail/spamass-ixhash/pkg-descr
@@ -0,0 +1,8 @@
+iXhash is a plugin for the popular spam filter SpamAssassin.
+
+It computes MD5 checksums of fragments of the body of an e-mail and compares
+them to those of know spam. As such it works similar to the now standard
+plugins that use the Pyzor, Razor and DCC software packages from within
+SpamAssassin.
+
+WWW: http://ixhash.sourceforge.net/