aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
committermarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
commit5cc9328814fb9b8e64ff3588af7e6031c1d3514b (patch)
treedf0b6bb8e4e84920da9881d421090dc67f70c629 /mail
parente058c31decaf84a24b7ab7306f65221b33ada080 (diff)
downloadfreebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.gz
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.zst
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'mail')
-rw-r--r--mail/dspam-devel/Makefile2
-rw-r--r--mail/dspam/Makefile2
-rw-r--r--mail/gmime2/Makefile2
-rw-r--r--mail/libesmtp/Makefile2
-rw-r--r--mail/libetpan/Makefile2
-rw-r--r--mail/libnewmail/Makefile2
-rw-r--r--mail/xfmail/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index 7648ffbc83ea..ec66e26748ea 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -61,7 +61,7 @@ OPTIONS+= BROKEN_MTA "Enable if MTA pases ^M to dspam" off
OPTIONS+= CGI "Install CGI (pulls in apache)" off
USE_GNOME= pkgconfig
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index 7648ffbc83ea..ec66e26748ea 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -61,7 +61,7 @@ OPTIONS+= BROKEN_MTA "Enable if MTA pases ^M to dspam" off
OPTIONS+= CGI "Install CGI (pulls in apache)" off
USE_GNOME= pkgconfig
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
diff --git a/mail/gmime2/Makefile b/mail/gmime2/Makefile
index 3d318e518770..6a8810db37da 100644
--- a/mail/gmime2/Makefile
+++ b/mail/gmime2/Makefile
@@ -19,7 +19,7 @@ USE_ICONV= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnometarget glib20 lthack
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/mail/libesmtp/Makefile b/mail/libesmtp/Makefile
index fd407d862af7..d1dfe8d9bbc1 100644
--- a/mail/libesmtp/Makefile
+++ b/mail/libesmtp/Makefile
@@ -19,7 +19,7 @@ COMMENT= A library for posting electronic mail
USE_BZIP2= yes
USE_GMAKE= yes
USE_OPENSSL= yes
-USE_LIBTOOL_VER=15
+USE_INC_LIBTOOL_VER=15
USE_PERL5_BUILD=yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/mail/libetpan/Makefile b/mail/libetpan/Makefile
index 7cbecd2c6c3e..b044f3c44073 100644
--- a/mail/libetpan/Makefile
+++ b/mail/libetpan/Makefile
@@ -17,7 +17,7 @@ COMMENT= A mail library
USE_ICONV= yes
USE_OPENSSL= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/mail/libnewmail/Makefile b/mail/libnewmail/Makefile
index df2e0e65b8bd..972926425434 100644
--- a/mail/libnewmail/Makefile
+++ b/mail/libnewmail/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= gnutls.12:${PORTSDIR}/security/gnutls \
USE_LIBLTDL= yes
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/mail/xfmail/Makefile b/mail/xfmail/Makefile
index 72ce34333823..28d401c34012 100644
--- a/mail/xfmail/Makefile
+++ b/mail/xfmail/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms \
USE_BZIP2= yes
USE_GNOME= glib12
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_X_PREFIX= yes
USE_XPM= yes
INSTALLS_SHLIB= yes