aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2013-06-25 02:38:25 +0800
committerlippe <lippe@FreeBSD.org>2013-06-25 02:38:25 +0800
commit5d8524fe629804b6f600e7f66cdb81d6b0bb417f (patch)
treec9ad9804bbcc763cf3bf3c25bbb0e79e781027e1 /mail
parentbd25d3deb57d12f90d9bbe4b3105e5f1371902a7 (diff)
downloadfreebsd-ports-gnome-5d8524fe629804b6f600e7f66cdb81d6b0bb417f.tar.gz
freebsd-ports-gnome-5d8524fe629804b6f600e7f66cdb81d6b0bb417f.tar.zst
freebsd-ports-gnome-5d8524fe629804b6f600e7f66cdb81d6b0bb417f.zip
Email::Sender replaces the old and sometimes problematic Email::Send library,
while this module replaces the Email::Send::SMTP::TLS. WWW: http://search.cpan.org/dist/Email-Sender-Transport-SQLite/ PR: ports/179891 Submitted by: Alexandre Biancalana <ale@biancalanas.net>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Email-Sender-Transport-SMTP-TLS/Makefile21
-rw-r--r--mail/p5-Email-Sender-Transport-SMTP-TLS/distinfo2
-rw-r--r--mail/p5-Email-Sender-Transport-SMTP-TLS/pkg-descr4
-rw-r--r--mail/p5-Email-Sender-Transport-SMTP-TLS/pkg-plist10
5 files changed, 38 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 6cde65af10cd..f026c0280847 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -351,6 +351,7 @@
SUBDIR += p5-Email-Reply
SUBDIR += p5-Email-Send
SUBDIR += p5-Email-Sender
+ SUBDIR += p5-Email-Sender-Transport-SMTP-TLS
SUBDIR += p5-Email-Sender-Transport-SQLite
SUBDIR += p5-Email-Simple
SUBDIR += p5-Email-Stuff
diff --git a/mail/p5-Email-Sender-Transport-SMTP-TLS/Makefile b/mail/p5-Email-Sender-Transport-SMTP-TLS/Makefile
new file mode 100644
index 000000000000..df0166f2f648
--- /dev/null
+++ b/mail/p5-Email-Sender-Transport-SMTP-TLS/Makefile
@@ -0,0 +1,21 @@
+# Created by: Alexandre Biancalana <ale@biancalanas.net>
+# $FreeBSD$
+
+PORTNAME= Email-Sender-Transport-SMTP-TLS
+PORTVERSION= 0.14
+CATEGORIES= mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ale@biancalanas.net
+COMMENT= Email::Sender with Net::SMTP::TLS (Eg. Gmail)
+
+RUN_DEPENDS= p5-Email-Sender>=0.091660:${PORTSDIR}/mail/p5-Email-Sender \
+ p5-Net-SMTP-TLS-ButMaintained>=0.2:${PORTSDIR}/mail/p5-Net-SMTP-TLS-ButMaintained
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Email::Sender::Transport::SMTP::TLS.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-Sender-Transport-SMTP-TLS/distinfo b/mail/p5-Email-Sender-Transport-SMTP-TLS/distinfo
new file mode 100644
index 000000000000..ce8920d097fa
--- /dev/null
+++ b/mail/p5-Email-Sender-Transport-SMTP-TLS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Email-Sender-Transport-SMTP-TLS-0.14.tar.gz) = ea7369a11bb3bcf36e0d43348c0fcc0ec65bf4eecf5c28e9d11a5aeb3a5b66b7
+SIZE (Email-Sender-Transport-SMTP-TLS-0.14.tar.gz) = 13208
diff --git a/mail/p5-Email-Sender-Transport-SMTP-TLS/pkg-descr b/mail/p5-Email-Sender-Transport-SMTP-TLS/pkg-descr
new file mode 100644
index 000000000000..1ef353488995
--- /dev/null
+++ b/mail/p5-Email-Sender-Transport-SMTP-TLS/pkg-descr
@@ -0,0 +1,4 @@
+Email::Sender replaces the old and sometimes problematic Email::Send library,
+while this module replaces the Email::Send::SMTP::TLS.
+
+WWW: http://search.cpan.org/dist/Email-Sender-Transport-SQLite/
diff --git a/mail/p5-Email-Sender-Transport-SMTP-TLS/pkg-plist b/mail/p5-Email-Sender-Transport-SMTP-TLS/pkg-plist
new file mode 100644
index 000000000000..726a10ebd1df
--- /dev/null
+++ b/mail/p5-Email-Sender-Transport-SMTP-TLS/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Email/Sender/Transport/SMTP/TLS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Sender/Transport/SMTP/TLS/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Sender/Transport/SMTP/TLS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Sender/Transport/SMTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Sender/Transport
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Sender
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email
+@dirrmtry %%SITE_PERL%%/Email/Sender/Transport
+@dirrmtry %%SITE_PERL%%/Email/Sender
+@dirrmtry %%SITE_PERL%%/Email