aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-07-11 03:12:03 +0800
committerrakuco <rakuco@FreeBSD.org>2014-07-11 03:12:03 +0800
commit5fdecbef13252aad6efe7069c9967b0c993682b1 (patch)
tree913b6906ef7dc733702c725823698876e86a0eae /mail
parent250007458525881ce72dea5bc72e93fa3f63ebab (diff)
downloadfreebsd-ports-gnome-5fdecbef13252aad6efe7069c9967b0c993682b1.tar.gz
freebsd-ports-gnome-5fdecbef13252aad6efe7069c9967b0c993682b1.tar.zst
freebsd-ports-gnome-5fdecbef13252aad6efe7069c9967b0c993682b1.zip
- Support staging.
- Use the @sample keyword in the plist. PR: 191728 Submitted by: takefu@airport.fm
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix-logwatch/Makefile34
-rw-r--r--mail/postfix-logwatch/pkg-plist5
2 files changed, 19 insertions, 20 deletions
diff --git a/mail/postfix-logwatch/Makefile b/mail/postfix-logwatch/Makefile
index 75ff745a5e51..adbdb298f774 100644
--- a/mail/postfix-logwatch/Makefile
+++ b/mail/postfix-logwatch/Makefile
@@ -3,11 +3,12 @@
PORTNAME= postfix-logwatch
PORTVERSION= 1.40.00
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF/logreporters/${PORTNAME}/release/${PORTVERSION}
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Postfix MTA log parser
LICENSE= MIT
@@ -16,36 +17,35 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PORTDOCS= Bugs Changes README
PORTEXAMPLES= ${PORTNAME}.conf ${PORTNAME}.conf-topn
-MAN1= ${PORTNAME}.1
-
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
NO_BUILD= yes
+SHEBANG_FILES= ${PORTNAME}
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-patch:
@cd ${WRKSRC} && ${REINPLACE_CMD} -e '\
s!/usr/local/etc!${ETCDIR}! \
' ${PORTNAME} ${PORTNAME}.1 README
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
- @${CP} ${WRKSRC}/${PORTNAME}.conf ${WRKSRC}/${PORTNAME}.conf.sample
- @${MKDIR} ${ETCDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample ${ETCDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${STAGEDIR}${ETCDIR}/${PORTNAME}.conf.sample
post-install:
@if [ ! -f ${ETCDIR}/${PORTNAME}.conf ]; then \
- ${CP} -p ${ETCDIR}/${PORTNAME}.conf.sample ${ETCDIR}/${PORTNAME}.conf; \
+ ${CP} -p ${STAGEDIR}${ETCDIR}/${PORTNAME}.conf.sample ${STAGEDIR}${ETCDIR}/${PORTNAME}.conf; \
fi
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/mail/postfix-logwatch/pkg-plist b/mail/postfix-logwatch/pkg-plist
index be3df4da16a1..f38f32701481 100644
--- a/mail/postfix-logwatch/pkg-plist
+++ b/mail/postfix-logwatch/pkg-plist
@@ -1,5 +1,4 @@
-@unexec if cmp -s %D/%%ETCDIR%%/postfix-logwatch.conf.sample %D/%%ETCDIR%%/postfix-logwatch.conf; then rm -f %D/%%ETCDIR%%/postfix-logwatch.conf; fi
-%%ETCDIR%%/postfix-logwatch.conf.sample
-@exec if [ ! -f %B/postfix-logwatch.conf ] ; then cp -p %B/%f %B/postfix-logwatch.conf; fi
+@sample %%ETCDIR%%/postfix-logwatch.conf.sample
@dirrmtry %%ETCDIR%%
bin/postfix-logwatch
+man/man1/postfix-logwatch.1.gz